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All information contained in this user manual is the exclusive property of Delta 

Electronics Inc. (hereinafter referred to as "Delta ") and is protected by copyright law 

and all other laws. Delta retains the exclusive rights of this user manual in 

accordance with the copyright law and all other laws. No parts in this manual may be 

reproduced, transmitted, transcribed, translated or used in any other ways without 

the prior consent of Delta.  

 

Limitation of Liability  

The contents of this user manual are only for the use of DIAStudio manufactured by 

Delta. Except as defined in special mandatory laws, Delta provides this user manual 

“as is” and does not offer any kind of warranty through this user manual for using the 

product, either express or implied, including but not limited to the following: 

(i) this product will meet user needs or expectations; 

(ii) the information contained in the product is current and correct;  

(iii) the product does not infringe any rights of any other person. User shall bear 

their own risk to use this product.  

 

In no event shall Delta, its subsidiaries, affiliates, managers, employees, agents, 

partners and licensors be liable for any direct, indirect, incidental, special, derivative 

or consequential damages (including but not limited to the damages for loss of 

profits, goodwill, use or other intangible losses) unless the laws contains special 

mandatory provisions to the contrary. 

Delta reserves the right to make changes to the user manual and the products 

described in the user manual without prior notice and afterwards.
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Chapter 1: Overview 
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1.1 DIAStudio Integrated Engineering Software 
 

The DIAStudio is an all-in-one integrated engineering platform, on which users can 

efficiently develop machinery systems, from product selection, programming, to 

exporting. 

It simplifies the process, and helps to save time and cost for building machinery 

systems. 

 

 

Figure 1 - 1: DIAStudio Features 

 
1.1.1 Key Software 
 

The DIAStudio comprises of 6 key software: 

• DIASelector: quick, easy, smart selection tool. 

• DIADesigner: Integrated development & engineering software. 

• DIAScreen: Intuitive visualization software. 

• DIAInstaller: System installation & update management. 

• COMMGR: Communication management. 

• DIADesigner-AX: Motion development and engineering software. 

 

The DIAStudio supports efficient and flexible data transmission between software. It 

also facilitates for tag sharing between software. 
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1.2 DIAScreen Overview 
 

The DIAScreen application is a part of DIAStudio software suite. DIAScreen allows 

user to configure Delta DOP series, TP series and AX-Series HMIs.  

The features including: 

• Tag sharing with DIADesigner & DIADesigner-AX 

• User-friendly editing interface, versatile 3D image library 

• Smooth display for meters and other elements 

• Faster software download speed 

• Improved the output results clearly 

• Multi-lingual support with Traditional Chinese, Simplified Chinese and English  

• Supports Recipe and Macros 

• Ability to set passwords and levels 

 

1.3 Operating Environment 
 

The following table provides the specifications for the DIAScreen operating 

environment: 

 

Item System Requirement 

Operating System Windows 7 / 8.1 / 10 Server 2012 R2 32/64 bits 

CPU Intel Celeron 540 1.8GHz (min.) , Intel Core i5 M520 2.4 GHz 
(min.) 

Memory 2GB or above (recommend to use 4GB or above) 

Hard Disk Drive 10GB or above 

Monitor Resolution: 1024 x 768 Pixels, 1920 x 1080 Pixels 

Keyboard/Mouse General Keyboard Mouse or Windows compatible device 

Printer Printer with Windows driver (optional for printing of project 
content) 
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Item System Requirement 

USB Used in Connection with the 
device According to the 

communication interface 
provided by the device Ethernet Used in Connection with the 

device 

Software Need to install Microsoft.Net Framework 4.6.2 
 

1.4 List of Supported Models 
 

DIAScreen supports the following HMI: 

 

Series Description 

AX series AX-8 series controller soft-HMI 

DOP-100 series Touch-sensitive high-color HMI interface 

DOP-H Series (Handheld) Handheld high-color HMI interface 

DXMC series Motion controller with integrated HMI interface 

IMP series 
Motion control development platform integrating 
HMI interface 

TP All series Text-based HMI interface 
 

NOTE: 

1. DIAScreen supports AX-8 series soft-HMI planning function, please refer to AX-8 

series operation manual and DOPSoft operation manual. 

2. DIAScreen supports DOP-100 series and DOP-H series HMI planning function, 

please refer to HMI product operation manual and DOPSoft operation manual. 

3. DIAScreen supports DXMC series HMI planning function, please refer to DXMC-P 

product operation manual and DOPSoft operation manual. 

The following chapters will take the TP series as an example to introduce the 

DIAScreen function. 
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Chapter 2: Installation and General Operation 
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2.1 Install, Uninstall and Update DIAScreen 
 

Ensure that the host computer follows the minimum criteria mentioned in 1.3 

Operating Environment and DIAInstaller is operating normally on it. 

DIAInstaller is a resident program that manages various software of DIAStudio. 

Users can download, install and update the DIAStudio software in DIAInstaller, and 

all processes are executed in the background without affecting other operations of 

the user. 

DIAStudio software download and installation tools: https://diastudio.deltaww.com/ 

 

Refer to the software download and installation manual to complete the software 

installation. 

 

 

Figure 2 - 1: DIAInstaller 

 

2.2 Startup DIAScreen  
 

Launch DIAScreen by double-clicking on the desktop shortcut icon as shown in the 

following figure. 
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Figure 2 - 2: DIAScreen shortcut 

 

DIAScreen application opens, as shown in the following figure. 

 

 

Figure 2 - 3: DIAScreen on launch 

 

Follow these steps to create a new TP series project: 

1. Click File > New in the Menu bar, Ctrl+N in keyboard or 

Click the   icon from the Standard toolbar 

Result: The Project Wizard window displays as shown in the following figure. 
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Figure 2 - 4: Project Wizard 

 

The following table describes the three main sections of the Project Wizard 

window: 

 

HMI Series Description 

Series Select AX/DOP-100/DOP-H(Handheld)/DXMC/IMP/TP series 

HMI List Select TP model type 

Project Setup Enter a project name and select the target device 

 

2. When selecting a TP series model type, the Project Wizard window displays 

the options as shown in the following figure. 
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Figure 2 - 5: Project Wizard - TP Series 

 

3. Select the TP series model to be planned in the HMI list. 

4. Enter Project Name and select PLC or Inverter Controller to connect. 

5. Click on Finish button. 

Result: A new project is created as shown in the following figure. 
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Figure 2 - 6: DIAScreen - New Project 

 

The following table describes the default user interface elements. 

 

Legend Area Name 

1 Window title 

2 Menu bar 

3 Tool bar 

4 Screen Editing Area 

5 Screen Management window 

6 Object Inspection Area 

7 Status bar 

8 Output 
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2.2.1 Window Title 
 

The Window Title displays the application’s icon and name and the buttons to 

minimize, maximize and close the application as shown in the following figure. 

 

 

Figure 2 - 7: DIAScreen - Window Title 

 

2.2.2 Menu Bar 
 

The Menu bar contains eleven different menus. The menu items vary depending on 

what user is doing in the application. The items that appear gray are not available. 

Different TP model types support different menu items.  

The brief introduction of the Menu bar is given here. Refer Chapter 3: Basic Editing 

Functions for more information. Menu bar is shown in the following figure. 

 

 

Figure 2 - 8: DIAScreen TP Menu Bar 

 

2.2.2.1 File: 
 

Use the File menu to access a file. Refer 3.1 Menu Bar - File for more information. 

File menu is shown in the following figure. File menu is shown in the following figure. 
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Figure 2 - 9: DIAScreen TP File menu 

 

2.2.2.2 Edit: 
 

The Edit menu provides the functions to edit a project. Refer 3.2 Menu Bar - Edit for 

more information. Edit menu is shown in the following figure. 

 

 

Figure 2 - 10: DIAScreen TP Edit menu 
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2.2.2.3 View: 
 

The View menu helps to view screens and configure the appearance of a work 

environment. View menu is shown in the following figure. 

 

 

Figure 2 - 11: DIAScreen TP View menu 

 

2.2.2.4 Compile: 
 

The Compile menu compiles the settings on the screen and a text panel. Refer 3.4 

Menu Bar - Compile for more information. Compile menu is shown in the following 

figure. 

 

 

Figure 2 - 12: DIAScreen TP Compile menu 

 

2.2.2.5 Element(O): 
 

The Element(O) menu provides the objects to use and edit in a text panel. Different 

models support different elements. Refer 3.5 Menu Bar - Element(O) for more 

information. Element menu is shown in the following figure. 
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Figure 2 - 13: DIAScreen TP Element(O) menu 

 

NOTE: The Element menu items vary depending on the type of TP series text panel 

user select. 

 

2.2.2.6 Screen Setting: 
 

The Screen Setting menu provides the functions to set particular screens in a text 

panel. Different models support different items. Refer 3.6 Menu Bar - Screen Setting 

for more information. Screen Setting menu is shown in the following figure. 

 

 

Figure 2 - 14: DIAScreen TP Screen Setting menu 
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NOTE: The Screen Setting menu items vary depending on the type of TP series 

text panel the user has selected. 

 

2.2.2.7 Global Setting: 
 

The Global Setting menu provides the functions to configure the text panel. It is 

applicable to all the screens in a text panel. However, in the text panel, if the setting 

for a particular screen conflicts with the settings for all the screens, the settings for 

the particular screen has priority. Different models support different items. Refer 3.7 

Menu Bar - Global Setting for more information. Global Setting menu is shown in the 

following figure. 

 

 

Figure 2 - 15: DIAScreen TP Global Setting menu 

 

NOTE: The Global Setting menu items vary depending on the type of TP series text 

panel user select. 

 

2.2.2.8 Communication: 
 

The Communication menu provides the functions to download data from the 

computer to a text panel and upload data from the text panel to the computer. Refer 

3.8 Menu Bar - Communication for more information. Communication menu is shown 

in the following figure. 
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Figure 2 - 16: DIAScreen TP series Communication menu 

 

2.2.2.9 Tools: 
 

Use the Tools menu to set up the communications between the computer and a text 

panel as well as configure the environment in DIAScreen. Different models support 

different items. Refer 3.9 Menu Bar - Tools for more information. Tools menu is 

shown in the following figure. 

 

 

Figure 2 - 17: DIAScreen TP Tools menu 

 

2.2.2.10 Window: 
 

The Window menu allows user to rearrange and close windows. Refer 3.10 Menu 

Bar - Window for more information. Window menu is shown in the following figure. 
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Figure 2 - 18: DIAScreen TP Window menu 

 

2.2.2.11 Help: 
 

The Help menu provides information about the version of DIAScreen. Refer 3.11 

Menu Bar - Help for more information. Help menu is shown in the following figure. 

 

 

Figure 2 - 19: DIAScreen TP Help 

 

2.2.3 Toolbar 
 

The DIAScreen has eight different toolbars. User can click icons on the Toolbar to 

carry out specific edit operations. These are common functions that appear on the 

Menu bar and the Toolbar. The icons may vary depending what user is doing in 

DIAScreen. The icons that appear gray are not available for the given mode. 

 

DIAScreen Toolbars are: 

• Standard Toolbar 

• Zoom Toolbar 

• Element Selection Toolbar 
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• Drawing Toolbar 

• Alignment Toolbar 

• Font Toolbar 

• Picture Toolbar 

• Communication Toolbar 

 

2.2.3.1 Standard Toolbar: 
 

The Standard Toolbar provides common functions that user will use frequently in 

DIAScreen. Standard Toolbar is shown in the following figure. 

 

 

Figure 2 - 20: DIAScreen TP Standard Toolbar 

 

The Standard Toolbar functions are described in the following table: 

 

Function - Icon Description 

 Click to create new DIAScreen project. 

 Click to open previously created DIAScreen project. 

 Click to save the current DIAScreen project. 

 Click to export selected screen to bitmap file. 

 Click to undo the last action. 

 Click to redo the previous action. 

 Click to cut the selection to the clipboard. 

 Click to copy the selection to the clipboard. 

 Click to paste the selection from clipboard. 

 Click to find the specified content. 

 Click to create a new screen. 
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Function - Icon Description 

 Click to select (open) existing screen. 

 Click to print screens. 

 Click to open the About window. 
 

2.2.3.2 Zoom Toolbar: 
 

The Zoom Toolbar provides common functions to zoom in and zoom out. Zoom 

Toolbar is shown in the following figure. 

 

 

Figure 2 - 21: DIAScreen TP Zoom Toolbar 

 

The Zoom Toolbar functions are described in the following table: 

 

Function - Icon Description 

 Enter the zoom level. 

 Click to zoom in (enlarge). 

 Click to zoom out (reduce). 

 Click to zoom in 1:1 ratio. 
 

2.2.3.3 Element Selection Toolbar: 
 

The Element Selection Toolbar provides the object icons for the selected model 

type. Element Toolbar is shown in the following figure. 

 

 

Figure 2 - 22: DIAScreen TP Element Selection Toolbar 
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The Element Selection Toolbar functions are described in the following table: 

 

Function - Icon Description 

 Click to select a Static Text. 

 Click to select a Numeric/ASCII display. 

 Click to select a Bit Lamp. 

 Click to select a Word Lamp. 

 Click to select a Static Bitmap. 

 Click to select a Dynamic Bitmap. 

 Click to select a Scale. 

 Click to select a Bar. 

 Click to select a Meter. 

 Click to select a Message Display. 

 Click to select a Button. 

 Click to open RTC window. 

 Click to select a Multistate Indicator. 

 Click to select a Measurement. 

 Click to select a Numeric Input. 

 Click to select a Curve. 

 Click to select a X-Y Curve. 

 
Click to open Delta Products Communication Device 
Setting window. 

 Click to select an Alarm function. 

 Click to select Slider. 

 Click to select Input List. 

 Click to select Combobox. 
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2.2.3.4 Drawing Toolbar: 
 

The Drawing Toolbar provides functions to draw simple figures. To draw a simple 

figure, click a geometric icon on the Toolbar. Drawing Toolbar is shown in the 

following figure. 

 

 

Figure 2 - 23: DIAScreen TP Drawing Toolbar 

 

The Drawing Toolbar functions are described in the following table: 

 

Function - Icon Description 

 Click to draw Line. 

 Click to draw Rectangle. 

 Click to draw Rectangle (Solid). 

 Click to draw Circle (Outline). 

 Click to draw Circle (Solid). 

 Click to draw Curve. 

 Click to draw Chord (Outline). 

 Click to draw Chord (Solid). 

 Click to draw Sector (Outline). 

 Click to draw Sector (Solid). 

 Click to draw Polygon. 

 Click to change to Width-1. 

 Click to change to Width-2. 

 Click to change to Width-3. 

 Click to change to dashed line. 
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2.2.3.5 Alignment Toolbar: 
 

The Alignment Toolbar provides the functions for adjusting the positions of the 

objects and for arranging the objects. Alignment Toolbar is shown in the following 

figure. 

 

 

Figure 2 - 24: DIAScreen TP Alignment Toolbar 

 
The Alignment Toolbar functions are described in the following table: 

 

Function - Icon Description 

 Click to group objects. 

 Click to ungroup objects. 

 Click to bring objects to front. 

 Click to send objects to back. 

 Click to bring forward. 

 Click to send backward. 

 Click to move elements one pixel to left. 

 Click to move elements one pixel to right. 

 Click to move elements one pixel to up. 

 Click to move elements one pixel to down. 

 Click to align left. 

 Click to align right. 

 Click to align top. 

 Click to align bottom. 

 Click to equal horizontal spacing. 

 Click to equal vertical spacing. 
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2.2.3.6 Font Toolbar: 
 

The Font toolbar provides the functions to set the appearance of the text. Font 

Toolbar is shown in the following figure. 

 

 

Figure 2 - 25: DIAScreen TP Font Toolbar 

 
The Font Toolbar functions are described in the following table: 

 

Function - Icon Description 

 Select font size. 

 Select font type. 

 Click to align text left. 

 Click to align text horizontal center. 

 Click to align text right. 

 Click to align text top. 

 Click to align text vertical center. 

 Click to align text bottom. 

 Click to change text color. 

 Click to bold the text. 

 Click to italicize the text. 

 Click to underline the text. 
 

2.2.3.7 Picture Toolbar: 
 

The Picture Toolbar provides the functions to adjust the positions of the images in 

an object and to select an image file. Picture Toolbar is shown in the following figure. 
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Figure 2 - 26: DIAScreen TP Picture Toolbar 

 

The Picture Toolbar functions are described in the following table: 

 

Function - Icon Description 

 Click to align picture left. 

 Click to align picture horizontally center. 

 Click to align picture right. 

 Click to align picture top. 

 Click to align picture vertically center. 

 Click to align picture bottom. 

 
2.2.3.8 Communication Toolbar: 
 

The Communication Toolbar provides the functions to Compile All, upload and 

download a project, and to configure basic settings. Communication Toolbar is 

shown in the following figure. 

 

 

Figure 2 - 27: DIAScreen TP Communication Toolbar 

 

The Communication Toolbar functions are described in the following table: 

 

Function - Icon Description 

 Click to Build All. 

 Click to upload project from TP series text panel. 

 Click to download project to TP series text panel. 

 Click to open Basic Setting. 
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2.2.4 Screen Editing Area 
 

The Screen Editing Area is an area for designing or editing a screen. It is the area 

displayed on the screen of a Text Panel. Screen Editing Area is shown in the 

following figure. 

 

 

Figure 2 - 28: Screen Editing Area 

 

2.2.4.1 Adding an Element to the Screen Editing Area: 
 

Follow these steps to add an element, for example – a button to a screen: 

1. Click Element(O) > Button on the menu bar, or  

Click the  icon on the Element Selection Toolbar as shown in the following  

figure. 
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Figure 2 - 29: Insert Button 

 

2. In the Screen Editing Area, drag the mouse on the button to set the exact size 

as shown in the following figure. 

 

 

Figure 2 - 30: Insert a Button and dragging 

 
3. Release the mouse cursor.  

Result: Button is added to the Screen Editing Area. 

 

2.2.4.2 Resizing the Button: 
 

Follow these steps to resize a button in a screen: 

1. Click the button element in the Screen Editing Area as shown in the following 
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figure. 

 

 

Figure 2 - 31: Object which is selected 

 

2. Click the frame of the Button. 

3. Press and hold the left mouse curser and drag vertically or horizontally to 

resize the Button element as shown in the following figure. 

 

 

Figure 2 - 32: Object resizing 

 

Double-click an item in the Screen Editing Area, to open the window to set the 

object properties. For example, the Button settings window is shown in the following 

figure. 
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Figure 2 - 33: Button window 

 

Right-click the Screen Editing Area to display a context menu. Common functions 

on the Menu bar and Standard Toolbar displays in the context menu. Context menu 

of the Screen Editing Area is shown in the following figure. 

 

 

Figure 2 - 34: Screen Editing Area context menu 
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2.2.5 Screen Management Window 
 

The screens that user created in the TP project display in the Screen Management 
Window. At least one screen with number 0 exists. Boot Screen is the welcome 

screen in the Text Panel. Boot screen cannot be added or deleted. When user 

double-click a screen in the Screen Management Window, it displays in the Screen 

Editing Area. Screen Management Window is shown in the following figure. 

 

 

Figure 2 - 35: Screen Management Window 

 

Right-click in the Screen Management Window to display a context menu as below. 

 

 

Figure 2 - 36: Screen Man agement Window context menu 

 

The Screen Management Window has two icons in the upper right corner, to hide 

and close the Screen Management Window as shown in Figure 2 - 35: Screen 

Management Window. 
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2.2.6 Properties 
 

The properties for the objects added to the screens display in the Properties window. 

User can directly change the properties of the objects in Properties window. 

Properties window for TP is shown in the following figure. 

 

 

Figure 2 - 37: Properties window 

 

If user selects several objects or if user do not select any object, the Properties 
window is blank. Use the two icons on the upper right corner of the Properties 
window to hide and close the Properties window. 
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2.2.7 Status Bar 
 

The Status Bar for the selected object includes the Device Type, mouse 

coordinates, TP Model Type, Caps lock, Number lock and Scroll lock status 

information.  

 

 

Figure 2 - 38: Status Bar 

 

2.2.8 Output 

 
The Output window displays compiling data and error messages as shown in the 

following figure.  

 

 

Figure 2 - 39: Output window 
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Chapter 3: Basic Editing Functions 
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3.1 Menu Bar - File  
 

This section provides the detailed information about the functions available from the 

File menu. The File menu functions are: 

• New 

• Open 

• Save 

• Save As 

• Print 

• User Menu Setting 

• Export Element Properties 

• Close 

• Previously opened Projects 

• Exit  

 

3.1.1 New 
 

User can create a new project in DIAScreen for the TP series text panel from the 

Menu bar, Toolbar or using keyboard shortcuts. 

Follow these steps to create a new project: 

 
1. Click File > New on Menu bar, Ctrl+N in keyboard or 

Click the  icon in the Standard Toolbar. 

Result: The Project Wizard window displays as shown in the following figure. 
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Figure 3 - 1: Project Wizard 

 

2. Select TP series in the Series field. 

3. Select the particular TP Series from the HMI List. 

4. Enter a name in Project Name under Project Setup. 

5. Select the device from the PLC or Inverter Controller drop-down menu. 

6. Click on Finish button. 

Result: New TP project is created as shown in the following figure. 
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Figure 3 - 2: New TP Project 

 

3.1.2 Open 
 

User can open a previously created project for the TP series text panel from the 

Menu bar, Toolbar, or using keyboard shortcuts. 

Follow these steps to open a project: 

1. Click File > Open on Menu bar, Ctrl+O in keyboard or 

           Click the  icon in the Standard Toolbar. 

Result: The Open window displays as shown in the following figure. 
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Figure 3 - 3: Open Project window 

 

2. Browse to the file location and select the TP project. 

3. Click on Open button. 

 

 

Figure 3 - 4: Open Project 

 

Result: The Project opens as shown in the above figure. 
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3.1.3 Save 
 

User can save a project in DIAScreen, either from Menu bar, or Toolbar, or using 

keyboard shortcuts. 

Follow the steps to save a project: 
1. Click File > Save on Menu bar, Ctrl+S in keyboard or 

Click the  icon on the Standard Toolbar. 

Result: The project is saved. 

NOTE: If user is saving the project for the first time, the Save As window 

appears as shown in the following figure. 

 

 

Figure 3 - 5: Project Save - first time 

 

2. Select a suitable location, enter a project name in the File Name field and 

click on Save button. 

Result: The project is saved. 
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3.1.3.1 Create auto Update Data File 
 

Remark: This item is only applicable to DOP-100 series and DXMC series. 

 

The DIAScreen software will automatically compile the current screen data, and then 

save the file in the specified path. When the HMI detects the external device and 

there is an automatic update file, it will display the automatic update firmware to 

update the HMI project. 

 

1. Click on File > Create Auto Update Data file. 
 

 

Figure 3 - 6: Auto Update File Path  

 

Result: It displays the Setting window as shown in the following figure. 
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Figure 3 - 7: Setting Window 

 

Features Description 
Enable Protection Enable password protection mechanism 

Password Password protection 

Archive folder The folder path where the update file is expected to be 
saved 

 

• After setting, compile, the project will be automatically updated to the 

specified external path. 

 

If the model of the project is DXMC series, after creating the project, set the archive 

path and execute the compilation. The DIAScreen software will automatically create 

a folder with the same name as the project under the project path, and save the 

current screen data update file in this folder. This update file can be directly imported 

into DXMC model software-DMARS (DELTA Motion and Robot Software) to perform 

HMI screen update. 
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Figure 3 - 8: The screen is automatically updated 

 

3.1.4 Save As 
 

User can save the TP project with a different name or to a different location by 

clicking File > Save As.  

Follow the steps to Save As a project: 

1. Click File > Save As on Menu bar. 

Result: The Save As window displays as shown in the following figure. 

 

 

Figure 3 - 9: Save As 
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2. Select the location, enter a project name in the File Name field and click on 

Save button. 

Result: The project is saved. 

 

3.1.5 Print 
 

After user has designed the screens, he/she can print them using the Print option on 

File menu. User can print two types of screens: 

• General screen 

• Boot screen 

User can print the general screens and also Boot screen.  

 

3.1.5.1 General Screen 
 

Follow the steps to print a TP screen: 

1. Click on File > Print > Print TP Screen as shown in the following figure. 

 

Figure 3 - 10: Print TP Screen 
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Result: The Print TP Screen window displays as shown in the following 

figure: 

 

 

Figure 3 - 11: Print TP Screen window 

 

2. Select either Print by Screen or Print by Picture. 

3. Select the appropriate print screen settings. 

4. Click on Print button. 

Result: The screen prints. 

 

3.1.5.2 Boot Screen 
 

The Print TP Screen functions are described in the following table: 

 

Function Description 

Print by Screen Click to print by screen. 
Print by Picture Click to print by picture. 

File Name Click to display project name in the print. 
Screen Click to display screen in the print. 

Screen Title Click to display screen name in the print. 
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Function Description 

Change Screens 
Condition Click to display Screen Change Condition in the print result. 

All Element 
information on 

Screen 
Click to display all element information on screen. 

Print Setup Click to setup print environment. 
Print Preview Click to display a print preview. 

Print Click to print. 
Cancel Click to cancel the print action. 

 

Follow these steps to print a Boot Screen: 

 

 

Figure 3 - 12: Print Boot Screen 

 

1. Click File > Print > Print Boot Screen as shown in the above figure. 

NOTE: Refer Print TP Screen for more information. 

Result: The Boot Screen prints. 
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3.1.6 User Menu Setting 
 

DIAScreen allows user to select which language to design the menus and the 

messages with the User Menu Setting. In addition to the built-in languages in 

DIAScreen, user can use other languages. 

 

The User Menu Setting on the File menu is described with a TP04G panel as an 

example: 

1. Create a project with the TP04G model type. 

2. Click the File > User Menu Setting on the Menu bar. 

Result: A sub-menu displays with the options of TP02, TP04, TP05 and TP08 

as shown in the following figure.  

 

 

Figure 3 - 13: User Menu Setting 

 

3. Click TP04G. 

Result: The system prompts user to save the project. Then 21 screens of TP-

04 displays in the Screen Management Window as shown in the following 

figure. 
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Figure 3 - 14: Screen Management Setting - User Menu Setting results 

 

NOTE: User can edit the menus in the language he/she wants to use. User 

cannot change the functions and the sizes of the menus. User can only 

change the language. 

4. To modify a screen, double-click on any of the items in Screen Management 
Setting window. For example – Backlight in screen_0 [1]. 

Result: The Static Text window appears as shown in the following figure. 

 



Chapter 3                                                                                                     DIAScreen 

46 
 

 

Figure 3 - 15: Static Text window - User Menu item - Backlight 

 

5. In the window, edit the items using the desired language and click on OK 

button as shown in the following figure. 

 

 

Figure 3 - 16: Static Text window - User Menu - Backlight edited 
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6. After user edit the menu, touch 1.D/L AP TP04G <= PC on the screen of the 

TP04G series text panel. WAIT COMM… displays. 

7. Click Communication > Download Menu to TP on the Menu bar as shown 

in the following figure.  

 

 

Figure 3 - 17: Download Menu to TP 

 

Result: The 21 menus are downloaded to the TP04G series text panel. 

NOTE: The Download Menu to TP is only available when using User Menu 
Setting.  

 

3.1.6.1 Post Download Menu to TP: 
 

Touch the TP04G SETUP on the main menu displayed on TP04G series text panel 

screen. Touch Language and press Enter on the panel and then select USER 
DEFINE. After USER DEFINE is selected, the user-defined language can be used. 

 

3.1.7 Export Element Properties(O) 
 

User can export the screen’s element properties as a .txt file or a .xls file with Export 
Element Properties(O). 

 

Follow these steps to export the element properties for a screen: 

1. Click on File > Export Element Properties(O) on the Menu bar as shown in 

the following figure. 
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Figure 3 - 18: Export Element Properties(O) 

 

Result: The Export Element Properties window displays as shown in the 

following figure. 

 

 

Figure 3 - 19: Export Element Properties window 

 

The Export Element Properties window displays the function mentioned in the 

following table: 
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Function Description 

TP Screen Click to select a particular screen in the Screen Selection 
field. 

Boot Screen Click to select Boot Screen. 
All Screens Click to select elements for all screens in the project. 

Screen Selection 

Displays the list of screens in the project: 
• TP Screen 
• Boot Screen 
• All Screens 
 
NOTE: The TP Screen is default value. 

Preview Displays the screen contents in graphic. 
 

2. Select either, TP Screen, Boot Screen, or All Screens. 

NOTE: If TP Screen is selected, user must select a particular screen for 

which the element property is exported.  

3. Click on Export All. 

Result: The Export window displays as shown in the following figure. 

 

 

Figure 3 - 20: Export window 

 

4. Select Text File or Excel File as the export file format and click on OK button. 

Result: The Save As window displays. 

5. Select a location, enter a file name and click on Save to export the element 

properties. 
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3.1.8 Close 
 

Click the File > Close to close the current project.  

Result: Home page of DIAScreen displays. 

 

3.1.9 Previously Opened Projects 
 

A list of previously opened projects displays when user opens File menu. Click on a 

project to open it. An example with list of previously displayed projects are shown in 

the following figure. 

 

 

Figure 3 - 21: List of previously opened projects 

 

3.1.10 Exit 
 

Click File > Exit to close the DIAScreen application.  

 

3.2 Menu Bar - Edit 
 

This section provides detailed information about the functions available from the Edit 
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menu. Edit menu functions are: 

• New Screen 

• Save Screen Bitmap 

• Undo 

• Redo 

• Delete 

• Cut 

• Copy(C) 

• Paste 

• Duplicate(M) 

• Copy Screen 

• Paste Screen 

• Bring to Front(T) 

• Send to Back(B) 

• Bring Forward(U) 

• Bring Backward(D) 

• Select All 

 

3.2.1 New Screen 
 

User can create a new screen in DIAScreen for TP function from the Edit menu bar 

or Toolbar. 

Follow these steps to create a new screen: 

1. Click on Edit > New Screen on the Menu bar, or 

Click the  icon on the Standard Toolbar, or 

           Click New Screen from the Screen Management Window context menu. 
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Result: The New Screen window displays as shown in the following figure.  

 

 

Figure 3 - 22: New Screen 

 

2. Enter a name in the Screen Name field and click on OK button. 

Result: A new screen is created. 

 

3.2.2 Save Screen Bitmap 
 

User can save the current screen to a clipboard or file using the Save Screen 
Bitmap function as shown in the following figure. 

The Save Screen Bitmap has two options: 

• Save to Clipboard 

• Save to File 

 

 

Figure 3 - 23: Save Screen Bitmap 

 

 



Chapter 3                                                                                                     DIAScreen 

53 
 

3.2.2.1 Save to Clipboard 
 

1. Click on Edit > Save Screen Bitmap > Save to Clipboard on the Menu bar, 

or  

          Press the Ctrl+Alt+P keys simultaneously. 

     Result: The current screen is ready to be pasted into an editor, e.g. MS-Paint.  

2. Paste the clipboard item to an editor. 

 

3.2.2.2 Save to File  
 

1. Click on Edit > Save Screen Bitmap > Save to File on the Menu bar, or 

           Press the Ctrl+Alt+F keys simultaneously. 

Result: The Save As window displays.  

2. Select a location and click on Save to save the file as a .bmp file. 

 

3.2.3 Undo 
 

User can undo a previous action in the TP project by clicking Edit > Undo on the 

Menu bar or by pressing Ctrl+Z keys simultaneously.  

Result: The previous action is cancelled. 

 

3.2.4 Redo 
 

User can redo a previous action in the TP project by clicking Edit > Redo on the 

Menu bar or by pressing Ctrl+R keys simultaneously.  

Result: The previous action is redone. 
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3.2.5 Delete 
 

User can delete elements selected on a screen in the TP project by clicking Edit > 

Delete on the Menu bar or by pressing the Delete key.  

Result: The selected elements on the screen is are deleted. 

 

3.2.6 Cut 
 

User can cut elements selected on a screen in the TP project by clicking Edit > Cut 
on the Menu bar or by pressing Ctrl+X in keyboard.  

Result: The selected elements on the screen is are cut. 

 

3.2.7 Copy 
 

User can copy elements selected on a screen in the TP project by clicking Edit > 

Copy on the Menu bar or by pressing Ctrl+C in keyboard.  

Result: The selected elements on the screen are are copied. 

 

3.2.8 Paste 
 

User can paste elements that are cut or copied to a screen in the TP project by 

clicking Edit > Paste on the Menu bar or by pressing Ctrl+V in keyboard.  

Result: The selected elements is pasted to the screen. 

 

3.2.9 Duplicate 
 

User can create duplicates of an element in the TP project by clicking Edit > 

Duplicate.  
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Result: Duplicate window displays as shown in the following figure. 

 

 

Figure 3 - 24: Duplicate window 

 

The Duplicate window function are described in the following table: 

 

Function Description 

Horizontal Number Select the check box and enter the number of horizontal 
copies user need. 

Vertical Number Select the check box and enter the number of vertical 
copies user need. 

Horizontal Spacing Select the horizontal spacing, in pixels, user need. 
Vertical Spacing Select the vertical spacing, in pixels, user need. 

Offset Address Select the check box to offset address from the copied 
location. 

Horizontal Direction Select to duplicate in horizontal direction. 
Vertical Direction Select to duplicate in vertical direction. 

OK Click to duplicate. 
Cancel Click to cancel duplication action. 

 

As an example, the copied element is duplicated as shown in the following figure. 
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Figure 3 - 25: Duplicate result 

 

3.2.10 Copy Screen 
 

User can copy all the elements on the current screen by clicking Edit > Copy 
Screen or by clicking Copy Screen from the screen’s context menu. 

 

3.2.11 Paste Screen 
 

User can paste all the copied elements to a current screen by clicking Edit > Paste 
Screen or by clicking Paste Screen from the screen’s context menu. 

 

3.2.12 Bring to Front 
 

User can bring an element in front of all the other elements by clicking Edit > Bring 
to Front(T) or by clicking Bring to Front from the element’s context menu.  

 

3.2.13 Send to Back 
 

User can send an element behind all other elements by clicking Edit > Send to 
Back(B) or by clicking Send to Back from the element’s context menu. 
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3.2.14 Bring Forward 
 

User can bring an element in front of another element that is one layer above it by 

clicking Edit > Bring Forward or by clicking Bring Forward from the element’s 

context menu. 

 

3.2.15 Send Backward 
 

User can send an element behind another element that is one layer below it by 

clicking Edit > Send Backward or by clicking Send Backward from the element’s 

context menu. 

 

3.2.16 Select All 
 

User can select all the elements on a screen by clicking Edit > Select All or by 

pressing Ctrl+A in keyboard. 

 

3.2.17 Paste multiple Element Graphics 
 

Remark: This function is applicable to DOP-100 series and AX-8 series. 

DIAScreen supports copying and pasting multiple graphics: 

 

1. Click Element > Graphic > State Graphic to draw the element as shown in 

the following figure. 
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Figure 3 - 26: Draw Element 
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2. Double-click on the element. 

Result: The Status Graphic window appears as shown in the following 

figure. 

 

 

Figure 3 - 27: State Graphic Tab 

 

3. Click on the Picture tab and then select the required graphic from the Picture 
Bank Name. 
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Figure 3 - 28: Graphic library name menu 

 

Result: The screen displays the selected graphics as shown in the following 

figure. 

 

 

Figure 3 - 29: Graphics 
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4. After repeating step 1 to draw the elements, use the right-click copy and paste 

function to create the required number of elements. 

5. Right-click on the element image and click on Copy Image from the menu. 

 

 

Figure 3 - 30: Copy graphics 

 

6. Select all the components, and then right-click.  
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Figure 3 - 31: Paste Image 

 

7. Click on Paste Image.  

Result: Multiple element images are pasted as shown in the following figure. 

 

 

Figure 3 - 32: Multiple component graphics 
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3.3 Menu Bar - View  
 

This section provides the detailed information about the functions available in View 

menu. View menu functions are: 

• Toolbar 

• Display Address Information 

• Properties 

• Screen Manager 

• Output Window 

• Grid Setting 

 

3.3.1 Toolbar 
 

DIAScreen has eight Toolbars and a Status bar. User can display or hide them by 

clicking View > Toolbar on the Menu bar as shown in the following figure. 

 

 

Figure 3 - 33: View > Toolbar 

 

A check mark next to its name indicates that the toolbar displays the application. To 

hide a toolbar, clear the check box.  
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3.3.2 Display Address Information 
 

In TP70P series models, the address information of each object setting can be 

displayed or hidden. Click the menu View > Display Address information, the 

upper left corner of all components will display the address information, as shown 

below 

 

 

Figure 3 - 34: Display Address Information 

 

3.3.3 Properties 
 

User can switch between displaying or hiding the Properties window by clicking the 

View > Properties menu option. A check mark next to the name in the menu 

indicates that the window is open. Clear the check box to hide the Properties 

window. 

 

3.3.4 Screen Manager 
 

User can display or hide the Screen Management Window by clicking the View > 

Screen Manager menu option. A check mark next to the name of Screen Manager 
indicates that the Screen Management Window is open. Clear the check box to 

hide the Screen Management Window. 
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3.3.5 Output Window 
 

User can check the results of the project compilation in the Output Window. Output 

window shows messages, error and warnings. Refer 3.4.1 Compile All for more 

information. Display the Output Window using the View > Output Window. A check 

mark next to the name of the Output Window indicates that the Output Window is 

open. Clear the check box to hide the Output window. 

 

3.3.6 Grid Setting 
 

User can adjust the grid settings from the Grid Setting window. Click View > Grid 
Setting to open the Grid Settings window as shown in the following figure. 

 

 

Figure 3 - 35: Grid Setting window 

 

The Grid Setting window functions are described in the following table: 

 

Function Description 
Show Grid Select the check box to display grid. 

Snap to Grid Select the check box to snap to grid. 
<Color pallet> Select the grid color(TP70P series). 
Spacing Width Enter the grid horizontal spacing width. 
Spacing Height Enter the grid vertical spacing height. 

OK Click to change the grid settings. 
Cancel Click to cancel the grid getting action. 
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3.4 Menu Bar - Compile  
 

This section provides detailed information about the functions available in Compile 

menu. Compile Menu function includes: 

• Compile All 

 

3.4.1 Compile All 
 

After user finish designing the screens and settings functions, user can compile the 

TP project with the Compile All function. After a project compiles successfully, 

download it to a TP series text panel.  

 

Follow these steps to compile a project:  

1. Click Compile > Compile All on the menu bar, or 

           Press Ctrl+F7 keys simultaneously, or 

           Click the  icon on the Communication toolbar. 

Result: A pop-up message displays the completion of compile process.  

 

 

Figure 3 - 36: Compile message 

 

Then the Output window displays the compile results in Message, Error and 

Warning tabs as shown in the following figure.  
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Figure 3 - 37: Output window after compile 

 

2. In case of compilation errors, check the contents in the Output window and 

correct the errors. 

 

3.5 Menu Bar - Element(O) 
 

In this section, the detailed information is presented for functions available on the 

Element(O) menu For a brief description please refer to 2.2.2 Menu bar. Different 

models support different elements. Element(O) Menu functions are: 

• Geometric Graphic 

• Static Text 

• Numeric/ASCII Display 

• Lamp(16x16) 

• Bitmap 

• Scale 
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• Bar(P) 

• Meter 

• Message Display 

• Button 

• RTC(L) 

• Range Indicator 

• Measurement 

• Numeric Input 

• Curve 

• X-Y Curve 

• Alarm 

• Slider 

• Input List 

• ComboBox 

• Delta Products Communication Device Setting 

 

3.5.1 Geometric Graphic 
 

User can add geometric objects to a screen with the Geometric Graphic element.  

Geometric Graphics supported are: 

• Line 

• Rectangle(Outline) 

• Rectangle(Solid) 

• Circle(Outline) 

• Circle(Solid) 

• Curve 
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• Chord(Outline) 

• Chord(Solid) 

• Sector(Outline) 

• Sector(Solid) 

• Polygon 

 

Follow these steps to add a geometric graphic element to a screen for the TP series 

text panel: 

1. Click the Element(O) > Geometric Graphic > Element on the Menu bar, or 

           Click a Geometric Graphic icon on the Drawing Toolbar. 

2. Click the screen and drag the mouse to the required dimensions. 

Result: The selected Geometric Graphic element is added to the screen.  

NOTE: All elements in Geometric Graphic menu except Polygon can be 

added with this procedure. 

The Geometric Graphic elements available for general model TP series text 

panel is shown in the following figure. 

 

 

Figure 3 - 38: Element(O) > Geometric Graphic (general models) 
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The Geometric Graphic elements available for the TP70P series text panel are 

show in the following figure. Figure 3 - 39: Geometric Graphic (TP70P series) 

 

 

Figure 3 - 39: Geometric Graphic (TP70P series) 

 

The Geometric Graphic elements for general model and TP70PPP series text panel 

are shown in the following table: 

 

Geometric Graphic General Model TP70PPP series 
Line 

   

Rectangle(Outline) 
   

Rectangle(Solid) 
  

Not Applicable 

Circle(Outline) 
 

  

Circle(Solid) 
 

 
Not Applicable 

Curve 
 

  

Chord(Outline) 
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Geometric Graphic General Model TP70PPP series 

Chord(Solid) 
 

 

Not Applicable 

Sector(Outline) 
 

  

Sector(Solid) 
 

 

Not Applicable 

Polygon 
 

  
 

Follow these steps to add a Polygon to a screen: 

1. Click Element(O) > Geometric Graphic > Polygon on the Menu bar, or 

           Click the  icon on the Drawing Toolbar.  

2. Click on the screen and then click each point to form the polygon. 

3. When user have created the required corners, right-click the mouse to finish. 

Result: The Polygon is added to the screen as shown in the above table. 

 

User can open the property setting windows for the Geometric Graphic elements by 

double-clicking the element. The property setting window is not available for the 

general models. For the TP70P series text panel, there are two tabs in the property 

setting window for all Geometric Graphic element. 

• Property 

• Coordinates 

 

The Property tab in the Line element window for the TP70P series text panel is 

shown in the following figure. 
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Figure 3 - 40: Line element window - Property tab for TP70P series 

 

The Property tab in the Rectangle(Outline) element window for the TP70P series 

text panel is shown in the following figure Figure 3 - 41: Rectangle(Outline) element 

window - Property tab for TP70P series. 

 

 

Figure 3 - 41: Rectangle(Outline) element window - Property tab for TP70P 
series 
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The Property tab in the Circle(Outline) element window for the TP70P series text 

panel is shown in the following figure. 

 

 

Figure 3 - 42: Circle(Outline) element window – Property tab for TP70P series 

 

The Property tab in the Curve element window for the TP70P series text panel is 

shown in the following figure. 
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Figure 3 - 43: Curve element window – Property tab for TP 70 series 

 

The Property tab in the Chord(Outline) element window for the TP70P series text 

panel is shown in the following figure. 

 

 

Figure 3 - 44: Chord(Outline) element window – Property tab for TP70P series 
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The Property tab in the Sector(Outline) element window for the TP70P series text 

panel is shown in the following figure. 

 

 

Figure 3 - 45: Sector(Outline) element window – Property tab for TP70P series 

 

The Property tab in the Polygon element window for the TP70P series text panel is 

shown in the following figure. 
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Figure 3 - 46: Polygon element window – Property tab for TP70P series 

 

The Property tab in the Geometric Graphic element’s window displays properties 

as mentioned in the following table: 

 

Function Description 

Solid 
Select the check box to enable the solid element (fill). 
 
NOTE: The Solid check box is not selected by default. 

Background 
Color Select the background color. 

Border Color Select the border color. 
 

Click the Coordinates tab to open it. The Coordinates tab for all the Geometric 
Graphic elements displays the properties as shown in the following figure. 
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Figure 3 - 47: Geometric Graphic element window - Coordinates tab 

 
The Coordinates tab in the Geometric Graphic element’s window displays 

properties as mentioned in the following table: 

 

Function Description 

X Displays the X coordinate of the Geometric Graphic element. 
Enter a value to change the X coordinate. 

Y Displays the Y coordinate of the Geometric Graphic element. 
Enter a value to change the Y coordinate. 

Width Displays the width of Geometric Graphic element. Enter a value 
to change the width. 

Height Displays the height of Geometric Graphic element. Enter a value 
to change the height. 

 

3.5.2 Static Text 
 

User can add text to a screen using the Static Text element.  
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The Static Text element for general model and TP70P series text panel is shown in 

the following table: 

 

Element General Model TP70P Series 

Static 
Text 

  
 

3.5.2.1 Static Text in General Model TP Series Text Panel: 
 

Follow these steps to add a Static Text to a screen and edit the properties in a 

general model TP series text panel: 

1. Click on Element(O) > Static Text on Menu bar, or 

Click the  icon on the Element Selection Toolbar. 

2. Click the screen and drag the mouse to the required dimensions. 

Result: The Static Text element is added to the screen. 

3. Double-click the Static Text element to edit the properties. 

Result: The Static Text window displays as shown in the following figure. 

The Property tab displays by default. The Static Text window has three tabs 

for general model TP series text panel: 

• Property 

• Text 

• Coordinates 
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Figure 3 - 48: Static Text window – Property tab for general model 

 

The Property tab in the Static Text window displays properties as mentioned in the 

following table: 

 

Function Description 

Outline 

Select the desired outline. Options are: 
• No Border 
• Single Border 
• Double Border 
• Thick Border 
• Dot Border 
• Dotted Line Border 
 
NOTE: The default value is Single Border. 

Text Direction 

Select the text direction. Options are: 
• From Left to Right 
• From Right to Left 
• From Top to Bottom 
• From Bottom to Top 
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Function Description 
NOTE: The default value is From Left to Right. 

 

Click the Text tab in the Static Text window to display the Text tab as shown in the 

following figure. 

 

 

Figure 3 - 49: Static Text - Text tab for general model 

 

The Text tab in the Static Text window displays properties as mentioned in the 

following table: 

 

Function Description 
Text field Enter the text. 

Font Type field Select the font type. 
Font Size field Select the font size. 

Bold field Select the check box to make the text bold. 
Italic field Select the check box to make the text italic. 

Font Color field Select the font color of the text. 

Horiz. alignment 
Select the horizontal alignment. Options are: 
• Align Left 
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Function Description 
• Horiz. Centering 
• Align Right 
 
NOTE: The default value is Align Left. 

Vert. alignment 

Select the vertical alignment. Options are: 
• Align Top 
• Vert. Centering 
• Align Bottom 
 
NOTE: The default value is Align Top. 

 

Click the Coordinates tab in the Static Text window to display the Coordinates tab 

as shown in the following figure. 

 

 

Figure 3 - 50: Static Text window – Coordinates tab for general model 

 

The Coordinates tab in the Static Text window displays properties as mentioned in 

the following table: 
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Function Description 

X Displays the X coordinate for the Static Text element. Enter a 
value to change the X coordinate. 

Y Displays the Y coordinate for the Static Text element. Enter a 
value to change the Y coordinate. 

Width Displays the Width for the Static Text element. Enter a value to 
change the width. 

Height Displays the Height for the Static Text element. Enter a value to 
change the height. 

 

4. Set the properties as per user’s requirements and click on OK button. 

 

3.5.2.2 Static Text in TP70P Series Text Panel: 
 

Steps for adding a Static Text element to TP70P series text panel are the same as 

the steps for the general model TP series text panel. Refer 3.5.2.1 Static Text in 

general model TP series text panel: for more information. 

 

Double-click the Static Text element in the TP70P series text panel to open the 

Static Text window as shown in the following figure. The Property tab displays by 

default. The Static Text window has three tabs for TP70P series text panel: 

• Property 

• Text 

• Coordinates 
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Figure 3 - 51: Static Text window – Property tab for TP70P series 

 

The Property tab in the Static Text window displays properties as mentioned in the 

following table: 

 

Function Description 

Text Direction 

Select the text direction. Options are: 
• From Left to Right 
• From Right to Left 
• From Top to Bottom 
• From Bottom to Top 
 
NOTE: The default value is From Left to Right. 

Enable 3D Style 

Select to enable or disable 3D style. Options are: 
• Yes 
• No 
 
NOTE: The default value is Yes. 

Border Width 
Enter the border width. 
 
NOTE: The default value is 5. 

Border Color Select the border color. 
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Function Description 
Background 

Color Select the background color. 

 

Click the Text tab in the Static Text window to display the Text tab as shown in the 

following figure. 

 

 

Figure 3 - 52: Static Text window – Text tab for TP70P series 

 

The Text tab in the Static Text window for the TP70P series text panel displays 

properties as mentioned in the following table: 

 

Function Description 
Text field Enter the text. 

Font Type field Select the font type. 
Font Size field Select the font size. 

Bold field Select the check box to make the text bold. 
Italic field Select the check box to make the text italic. 

Font Color field Select the font color. 
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Function Description 

Horiz. alignment 

Select the horizontal alignment. Options are: 
• Align Left 
• Horiz. Centering 
• Align Right 
 
NOTE: The default value is Align Left. 

Vert. alignment 

Select the vertical alignment. Options are: 
• Align Top 
• Vert. Centering 
• Align Bottom 
 
NOTE: The default value is Align Top. 

 

Click the Coordinates tab in the Static Text window to display the Coordinates tab 

as shown in the following figure. 

 

 

Figure 3 - 53: Static Text window – Coordinates tab for TP70P series 

 

The Coordinates tab in the Static Text window for TP70P series text panel displays 

properties as mentioned in the following table: 
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Function Description 

X Displays the X coordinate for the Static Text element. Enter a 
value to change the X coordinate. 

Y Displays the Y coordinate for the Static Text element. Enter a 
value to change the Y coordinate. 

Width Displays the Width for the Static Text element. Enter a value to 
change the width. 

Height Displays the Height for the Static Text element. Enter a value to 
change the height. 

 

3.5.3 Numeric/ASCII Display 
 

A TP series text panel reads the value from a device and displays it on the screen in 

the TP series text panel using the Numeric/ASCII Display element.  

 

The Numeric/ASCII Display element for the general model and TP70P series text 

panel is shown in the following table: 

 

Element General Model TP70P series 

Numeric/ASCII 
Display   

 

3.5.3.1 Numeric/ASCII Display in General Model TP Series Text Panel: 
 

Follow these steps to add a Numeric/ASCII Display element to a screen and edit the 

properties in a general model TP series text panel: 

1. Click Element(O) > Numeric/ASCII Display on the Menu bar, or  

Click the  icon on the Element Selection Toolbar. 

2. Click the screen and drag the mouse to the required dimensions. 

Result: The Numeric/ASCII Display element is added to the screen. 

3. Double-click the Numeric/ASCII Display element to edit the properties. 
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Result: The Numeric/ASCII Display window for the general model TP series 

is shown in the following figure. The Property tab displays by default. The 

Numeric/ASCII Display window for general model TP series text panel has 

two tabs: 

• Property 

• Coordinates 

 

 

Figure 3 - 54: Numeric/ASCII Display window – Property tab for general model 

 

The Property tab in Numeric/ASCII Display window for the general model TP 

series text panel displays properties as mentioned in the following table: 

 

Function Description 
Refer Device -

Device Address 
Select the device address that the text panel reads to 
display its value. 

Value Type 

Select the datatype for the variable. Options are: 
• Unsigned 
• Signed 
• Hex 
• BCD 



Chapter 3                                                                                                     DIAScreen 

88 
 

Function Description 
• ASCII 
• Binary 
• Float 
 
NOTE: The default value is Unsigned. 

Value Length 

Select the bit length. Options are: 
• 16 Bits 
• 32 Bits 
 
NOTE: The default value is 16 Bits. 

Value Format - 
Integer Digits 

Select the number of integer places. Options are: 
• 1 
• 2 
• 3 
• 4 
• 5 
 
NOTE: The default value is 5. 

Value Format -
Fractional Digits 

Select the number of decimal places. Options are: 
• 0 
• 1 
• 2 
• 3 
• 4 
• 5 
 
NOTE: The default value is 0. 

Outline 

Select the border type. Options are: 
• No Border 
• Single Border 
• Double Border 
• Thick Border 
• Dot Border 
• Dotted Line Border 
 
NOTE: The default value is No Border. 

Font Setting 
Select the font setting. Options are: 
• 5x8 
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Function Description 
• 8x8 
• 8x12 
• 8x16 
 
NOTE: The default value is 5x8. 

Horiz. alignment 

Select the horizontal alignment. Options are: 
• Align Left 
• Horizontal Centering 
• Align Right 
 
NOTE: The default value is Align Left. 

Leading Zeros 

Select whether to display leading zeros or not. Options are: 
• No 
• Yes 
 
NOTE: The default value is No. 

Arithmetic Select to perform an arithmetic operation on the device 
address. Click  to open Operation Setting dialog box. 

 

User can perform an arithmetic operation in the Operation Setting window. Click  

to select an operator. Click   to open Refer Device window to set an operand. 

Click  to clear the settings.  

 

An example of arithmetic operation to display D0 = ((D0 + D1) x D10) is shown in the 

following figure. 
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Figure 3 - 55: Operations Setting window 

 

Example 1: (Integer Digits and Fractional Digits) 

Suppose the value in T0 is 500 (the time interval that T0 measures is 50 seconds).  

Case 1: If Integer Digits = 3 and Fractional Digits = 0. 

Result: 500 displays. 

 

Case 2: If Integer Digits = 3 and if Fractional Digits = 1. 

Result: 50.0 displays. 

 

Example 2: (Integer Digits, Fractional Digits and Leading Zeros) 

Suppose take a value of 32483 

Case 1: If Integer Digits = 5, Fractional Digits = 2 and Leading Zeros = No. 

Result: 324.83 displays. 

 

Case 2: If Integer Digits = 5, Fractional Digits = 2 and Leading Zeros = Yes. 

Result: 00324.83 displays. 
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Click the Coordinates tab in the Numeric/ASCII Display window to display the 

Coordinates tab as shown in the following figure. 

 

 

Figure 3 - 56: Numeric/ASCII Display window – Coordinates tab for general 
model 

 

The Coordinates tab in the Numeric/ASCII Display window for general model TP 

series text panel displays properties as mentioned in the following table: 

 

Function Description 

X Displays the X coordinate for the Numeri/ASCII Display element. 
Enter a value to change the X coordinate. 

Y Displays the Y coordinate for the Numeric/ASCII Display element. 
Enter a value to change the Y coordinate. 

Width Displays the width for the Numeric/ASCII Display element. Enter 
a value to change the width. 

Height Displays the height for the Numeric/ASCII Display element. Enter 
a value to change the height. 

 

4. Set the properties as per user’s requirements and click on OK button. 
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3.5.3.2 Numeric/ASCII Display in TP70P Series Text Panel: 
 

The procedure to add a Numeric/ASCII Display element in TP70P series text panel 

is same as that of general model TP series text panel. Refer 3.5.3.1 Numeric/ASCII 

Display in general model TP series text panel: for more information. 

 

The Numeric/ASCII Display window for the TP70P series text panels displays as 

shown in the following figure. The Property tab displays by default. The 

Numeric/ASCII Display window has two tabs for the TP70P series text panel: 

• Property 

• Coordinates 

 

 

Figure 3 - 57: Numeric/ASCII Display window – Property tab for TP70P series 

 

The Property tab in the Numeric/ASCII Display window for the TP70P series text 

panel displays properties as mentioned in the following table: 
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Function Description 
Refer Device -Device 

Address 
Select the device address that the text panel reads to 
display its value. 

Value Type 

Select the datatype of the variable. Options are: 
• Unsigned 
• Signed 
• Hex 
• BCD 
• Binary 
• Float 
 
NOTE: The default value is Unsigned. 

Value Length 

Select the bit length. Options are: 
• 16 Bits 
• 32 Bits 
 
NOTE: The default value is 16 Bits. 

Value Format - Integer 
Digits 

Select the number of integer places. Options are: 
• 1 
• 2 
• 3 
• 4 
• 5 
 
NOTE: The default value is 5. 

Value Format - 
Fractional Digits 

Select the number of decimal places. Options are: 
• 0 
• 1 
• 2 
• 3 
• 4 
• 5 
 
NOTE: The default value is 0. 

Font Setting 

Click to open the Font Setting dialog box. User can set 
the following properties: 
• Font 
• Size 
• Bold 
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Function Description 
• Italics 
 
Click OK to save settings. 

Horiz. alignment 

Select the horizontal alignment. Options are: 
• Align Left 
• Horizontal Centering 
• Align Right 
 
NOTE: The default value is Align Left. 

Leading Zeros 

Select whether to display leading zeros. Options are: 
• No 
• Yes 
 
NOTE: The default value is No. 

Color Setting – 
Border Color 

Select the border color. 

Color Setting – Font 
Color Select the font color. 

Color Setting – 
Background Color Select the background color. 

 

Click the Coordinates tab in the Numeric/ASCII Display window to display the 

Coordinates tab as shown in the following figure. 
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Figure 3 - 58: Numeric/ASCII Display window – Coordinates tab for TP70P 
series 

 

The Coordinates tab in the Numeric/ASCII Display window for the TP70P series 

text panel displays properties as mentioned in the following table: 

 

Function Description 

X Displays the X coordinate for the Numeric/ASCII Display element. 
Enter a value to change the X coordinate. 

Y Displays the Y coordinate for the Numeric/ASCII Display element. 
Enter a value to change the Y coordinate. 

Width Displays the width for Numeric/ASCII Display element. Enter a 
value to change the width. 

Height Displays the height for Numeric/ASCII Display element. Enter a 
value to change the height. 

 

5. Set the properties as per user’s requirements and click on OK button. 
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3.5.4 Lamp (16x16) 
 

User can show the state(s) of a Boolean/multiple state variable with the Lamp 

element. User can add a Lamp element to the screen by clicking Element(O) > 

Lamp(16x16). TP series supports two types of Lamps: 

• Bit Lamp (for Boolean variable) 

• Word Lamp (for variable with multiple states) 

 

The options to add a Lamp element from menu bar are shown in the following figure. 

 

 

Figure 3 - 59: Lamp(16x16) options 

 

3.5.4.1 Bit Lamp in General Model TP Series Text Panel: 
 

Follow these steps to add a Bit Lamp to a screen and edit the properties in a general 

model TP series text panel: 

1. Click Element(O) > Lamp(16x16) > Bit Lamp on the Menu bar, or 

Click the  icon on the Element Selection Toolbar. 

2. Click the screen and drag the mouse to the required dimensions. 

Result: The Bit Lamp element is added to the screen as shown in the 

following figure. 
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Figure 3 - 60: Bit Lamp 

 

3. Double-click the Bit Lamp element to edit the properties. 

Result: The Bit Lamp window displays as shown in the following figure. The 

Property tab is the default tab in the Bit Lamp window. The Bit Lamp window 

has two tabs for general model TP series text panel: 

• Property 

• Coordinates 

 

 

Figure 3 - 61: Bit Lamp window – Property tab for general model 

 

The Property tab in the Bit Lamp window for general model TP series text panel 

displays properties as mentioned in the following table: 
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Function Description 
Refer Device -

Device Address 
Select the device address that has the images user want to 
display. 

Bitmap Setting – 
ON Bitmap 

Select the image to display when the value of the variable is 1. 

Bitmap Setting – 
OFF Bitmap Select the image to display when the value of the variable is 0. 

 

Click on the Coordinates tab in the Bit Lamp window to display the Coordinates tab 

as shown in the following figure. 

 

 

Figure 3 - 62: Bit Lamp window – Coordinates tab for general model 

 

The Coordinates tab in the Bit Lamp window for general model TP series text panel 

displays properties as mentioned in the following table: 

 

Function Description 

X Displays the X coordinate for the Bit Lamp element. Enter a 
value to change the X coordinate. 
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Function Description 

Y Displays the Y coordinate for the Bit Lamp element. Enter a 
value to change the Y coordinate. 

Width 
Displays the width of the Bit Lamp element. 
 
NOTE: Width is read-only. 

Height 
Displays the height of the Bit Lamp element. 
 
NOTE: Height is read-only. 

 

4. Set the properties as per user’s requirements and click on OK button. 

 

3.5.4.2 Word Lamp in General Model TP Series Text Panel: 
 

Follow these steps to add a Word Lamp to a screen and edit the properties in a 

general model TP series text panel: 

1. Click Element(O) > Lamp(16x16) > Word Lamp on the Menu bar, or 

Click the  icon on the Element Selection Toolbar.  

2. Click the screen and drag the mouse to the required dimensions. 

Result: The Word Lamp element is added to the screen. 

NOTE: Bit Lamp and Word Lamp images look similar. 

3. Double-click the Word Lamp element to edit the properties. 

Result: The Word Lamp property window is shown in the following figure. 

The Word Lamp window has two tabs for general model TP series text panel:  

• Property 

• Coordinates 

The Property tab is the default tab in the Word Lamp window. 
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Figure 3 - 63: Word Lamp window – Property tab for general model 

 

The Property tab in the Word Lamp window for general model TP series text panel 

displays properties as mentioned in the following table: 

 

Function Description 
Refer Device -Device 

Address 
Select the device address that has the images user 
want to display. 

Range Value Sequence -
From Max to Min Select to define range values in descending order. 

Range Value Sequence -
From Min to Max Select to define range values in ascending order. 

All States Table Enter the values for states from state0 to state4. 

All States Table -
Reference Value 

Click the Reference Value button to open Range 
Value Reference Value dialog box. Enter the Range 
Limit for Lower Bound and Upper Bound. 

Value Type 

Select the variable datatype. Options are: 
• Unsigned 
• Signed 
• Hex 
• BCD 
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Function Description 
NOTE: The default value is Unsigned. 

Value Length 

Select the Bit Length. Options are: 
• 16 Bits 
• 32 Bits 
 
NOTE: The default value is 16 Bits. 

Bitmap Select the image from the drop down menu for the 
different states. 

State Select the state value from the drop down menu for 
the desired states. 

 

The value in a device address is compared to the values corresponding to state0 to 

state4. If the device address’s value is greater than or equal to the value of a state, 

the Word Lamp corresponding to the state displays on the text panel screen.  

There are five states (state0 ~ state4). User can set the images and the range values 

for the four states. If the value in the device address is greater than or equal to a 

range value, the image corresponding to the state displays on the screen.  

 

Example: 

Range Value Sequence = From Max to Min, state 0 = 300, state 1 = 100. 

Case 1:  Variable value is greater than or equal to 300. 

Result: image corresponding to state0 displays. 

 

Case 2: Variable value is more than 100 and less than 300. 

Result: Image corresponding to state1 displays. 

 

Click on the Coordinates tab in the Word Lamp window to display the Coordinates 

tab as shown in the following figure. 
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Figure 3 - 64: Word Lamp window – Coordinates tab for general model 

 

The Coordinates tab in the Word Lamp window for general model TP series text 

panel displays properties as mentioned in the following table: 

 

Function Description 

X Displays the X coordinate for the Word Lamp element. Enter a 
value to change the X coordinate. 

Y Displays the Y coordinate for the Word Lamp element. Enter a 
value to change the Y coordinate. 

Width 
Displays the width for the Word Lamp element 
 
NOTE: Width is read-only. 

Height 
Displays the height for the Word Lamp element 
 
NOTE: Height is read-only. 

 

4. Set the properties as per user’s requirements and click on OK button. 
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3.5.5 Bitmap 
 

User can add a bitmap to a screen with the Bitmap element. The DIAScreen 

supports two types of bitmaps as displayed  

• Static Bitmap 

• Dynamic Bitmap 

 

 

Figure 3 - 65: Bitmap options 

 

3.5.5.1 Static Bitmap: 
 

User can add a bitmap that is static in nature with the Static Bitmap element.  

An example of Static Bitmap is shown in the following figure. 

 

 

Figure 3 - 66: Static Bitmap 

 

Static Bitmap in General Model TP Series Text Panel: 
 

Follow these steps to add a Static Bitmap to a screen and edit the properties in a 

general model TP series text panel: 

1. Click Element(O) > Bitmap > Static Bitmap on the Menu bar, or 
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Click the  icon on the Element Selection Toolbar. 

2. Click the screen and drag the mouse cursor to the required dimensions. 

Result: The Static Bitmap element is added to the screen. 

3. Double-click the Static Bitmap to edit the properties. 

Result: The Static Bitmap window displays as shown in the following figure. 

The Property tab is the default tab of Static Bitmap window. Static Bitmap 

window has two tabs for general model TP series text panel: 

• Property 

• Coordinates 

 

 

Figure 3 - 67: Static Bitmap window – Property tab for general model 

 

The Property tab in the Static Bitmap window for general model TP series text 

panel displays properties as mentioned in the following table: 
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Function Description 

Bitmap Read 

Click to display the Open window to select a location and the .bmp 
file to display. 
 
NOTE: Bitmap images are available in:  
< drive>\Program Files (x86)\Delta Industrial Automation\ 
DIAStudio\DIAScreen\ScrEditApp\TPSeries\BmpGroup\<folders> 

Clear Picture Click to delete the current bitmap. 
 

Click on the Coordinates tab in the Static Bitmap window to display the 

Coordinates tab as shown in the following figure. 

 

 

Figure 3 - 68: Static Bitmap window – Coordinates tab for general model 

 

The Coordinates tab in the Static Bitmap window for general model TP series text 

panel displays properties as mentioned in the following table: 

 

Function Description 

X Displays the X coordinate for the Static Bitmap element. Enter a 
value to change the X coordinate. 
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Function Description 

Y Displays the Y coordinate for the Static Bitmap element. Enter a 
value to change the Y coordinate. 

Width 
Displays the width for the Static Bitmap element 
 
NOTE: Width is read-only. 

Height 
Displays the height for the Static Bitmap element 
 
NOTE: Height is read-only. 

 

4. Set the properties as per user’s requirements and click OK button. 

 

Static Bitmap in TP70P Series Text Panel: 
 

The procedure to add a Static Bitmap element in TP70P series text panel is same as 

that of Static Bitmap element to a general model TP series text panel. Refer Static 

Bitmap in general model TP series text panel: for more information. 

 

The Static Bitmap window for TP70P series text panel is shown in following figure. 

The Property tab displays by default. The Static Bitmap window has two tabs for 

TP70P series text panel: 

• Property 

• Coordinates 
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Figure 3 - 69: Static Bitmap window – Property tab for TP70P series 

 

The Property tab in the Static Bitmap window for the TP70P series text panel 

displays properties as mentioned in the following table: 

 

Function Description 

Bitmap 
Settings – 
From File 

Click to display the Open window to select a location and 
the .bmp file to display. 
 
NOTE: Bitmap images are available in:  
<drive>\Program Files (x86)\Delta Industrial Automation\ 
DIAStudio\DIAScreen\ScrEditApp\TPSeries\BmpGroup\<folders> 

Bitmap 
Settings – 

Clear Picture 
Click to delete the current bitmap. 

Use HMI 
Picture Bank Select a picture bank and an image in the picture bank. 

 

Click the Coordinates tab in the Static Bitmap window to display the Coordinates 
tab as shown in the following figure. 
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Figure 3 - 70: Static Bitmap window – Coordinates tab for TP70P series 

 

The Coordinates tab in the Static Bitmap window for the TP70P series text panel 

displays properties as mentioned in the following table: 

 

Function Description 

X Displays the X coordinate for the Static Bitmap element. Enter 
value to change the X coordinate. 

Y Displays the Y coordinate for the Static Bitmap element. Enter 
value to change the Y coordinate. 

Width 
Displays the width for the Static Bitmap element. 
 
NOTE: Width is read-only. 

Height 
Displays the height for the Static Bitmap element. 
 
NOTE: Height is read-only. 

 

5. Set the properties as per user’s requirements and click on OK button. 
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3.5.5.2 Dynamic Bitmap: 
 

User can add a bitmap that is dynamic in nature using the Dynamic Bitmap 

element. The value in a device address is compared to the values corresponding to 

a state. If the value in the device address is greater than or equal to the value of the 

state, the image corresponding to the state displays on the text panel screen. A 

dynamic image is different from a static image because the Dynamic Bitmap image 

corresponds to a state.  

 

Dynamic Bitmap in General Model TP Series Text Panel: 
 

Follow these steps to add a Dynamic Bitmap to a screen and edit the properties in a 

general model TP series text panel: 

1. Click Element(O) > Bitmap > Dynamic Bitmap on the Menu bar, or 

Click the  icon on the Element Selection Toolbar. 

2. Click the screen and drag the mouse to the desired requirements. 

Result: The Dynamic Bitmap element is added to the screen. 

3. Double-click the Dynamic Bitmap to edit the properties. 

Result: The Dynamic Bitmap window displays as shown in the following 

figure.  

The Dynamic Bitmap window has two tabs for general model TP series text 

panel: 

• Property 

• Coordinates 

The Property tab displays by default. 
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Figure 3 - 71: Dynamic Bitmap window – Property tab for general model 

 

The Property tab in the Dynamic Bitmap window for general model TP series text 

panel displays properties as mentioned in the following table: 

 

Function Description 
Refer Device 

– Device 
Address 

Select the device address that has the images user want to display. 

Refer Device 
- Bit Select Bit if the variable is a Boolean datatype. 

Refer Device 
- Value Select Value if the variable has multiple states. 

Bitmap Read 

Click to display the Open window to select the location and .bmp 
file to display. 
 
NOTE: Bitmap images are available in:  
<drive>\Program Files (x86)\Delta Industrial Automation\ 
DIAStudio\DIAScreen\ScrEditApp\TPSeries\BmpGroup\<folders> 

Clear Picture Click to delete the current bitmap. 
 



Chapter 3                                                                                                     DIAScreen 

111 
 

If user select Bit, select images corresponding to values 0 and 1. If user select 

Value, then user can set up to a maximum of 255 states.  

If Value is selected, the Dynamic Bitmap window displays the Property tab as 

shown in the following figure. 

 

 

Figure 3 - 72: Dynamic Bitmap window – Property tab (Value) for general model 

 

If user select Value, the Property tab in the Dynamic Bitmap window displays extra 

properties as mentioned in the following table: 

 

Function Description 
Range Value 

Sequence - From Max 
to Min 

Select to define range values in the descending order. 

Range Value 
Sequence - From Min 

to Max 
Select to define range values in the ascending order. 

All States Table Enter the values for state0 to stateN, where N = (State 
Counts -1). 
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Function Description 

All States Table - 
Reference Value 

Click Reference Value open the Range Value 
Reference Value dialog box. Enter the Range Limit for 
Lower Bound and Upper Bound. 

Value Type 

Select the variable datatype. Options are: 
• Unsigned 
• Signed 
• Hex 
• BCD 
 
NOTE: The default value is Unsigned. 

Value Length 

Select the bit length here. Options are: 
• 16 Bits 
• 32 Bits 
 
NOTE: The default value is 16 Bits. 

State Counts 
Select the number of states. 
 
NOTE: The default value is 2. 

 

When user selects Bit or Value and click Bitmap Read, a File Open dialog will be 

displayed. User needs to select the .bmp files to be displayed for the particular state. 

User can set the images corresponding to the states and set the range values for the 

states. If the value in the device address is greater than or equal to a range value, 

the image corresponding to the state for the range value displays.  

 

Example: 

Range Value Sequence = From Max to Min, state 0 = 300, state 1 = 100. 

Case 1:  Variable value is greater than or equal to 300. 

Result: Image corresponding to state0 displays. 

 

Case 2: Variable value is more than 100 and less than 300. 

Result: Image corresponding to state1 displays. 
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Click on the Coordinates tab in the Dynamic Bitmap window to display the 

Coordinates tab as shown in the following figure. 

 

 

Figure 3 - 73: Dynamic Bitmap window – Coordinates tab for general model 

 

The Coordinates tab in the Dynamic Bitmap window for general model TP series 

text panel displays properties as mentioned in the following table: 

 

Function Description 

X Displays the X coordinate for the Dynamic Bitmap element. 
Enter a value to change the X coordinate. 

Y Displays the Y coordinate for the Dynamic Bitmap element. 
Enter a value to change the Y coordinate. 

Width 
Displays the width for the Dynamic Bitmap element. 
 
NOTE: Width is read-only. 

Height 
Displays the height for the Dynamic Bitmap element. 
 
NOTE: Height is read-only. 
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4. Set the properties as per user’s requirements and click on OK button. 

 

Dynamic Bitmap in TP70P Series Text Panel: 
 

Procedure to add a Dynamic Bitmap element to TP70P series text panel is the same 

as to add Dynamic Bitmap element to a general model TP series text panel. Refer 

Dynamic Bitmap in general model TP series text panel: for more information. 

 

The Dynamic Bitmap window for the TP70P series text panel is shown in the 

following figure. The Dynamic Bitmap window has two tabs for TP70P series text 

panel: 

• Property 

• Coordinates 

The Property tab displays by default. 

 

 

Figure 3 - 74: Dynamic Bitmap window – Property tab for TP70P series 
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The Property tab in the Dynamic Bitmap window for the TP70P series text panel 

displays properties as mentioned in the following table: 

 

Function Description 
Change State 

by – Refer 
Device 

Select the device address for animation of bitmap. 

Change State 
by – Automatic 

Control 
Select to do change state by automatic control. 

Refer Device - 
Device 

Select the device address that has the images user want to 
display. 

Refer Device – 
Value Type 

Select the variable datatype. Options are: 
• Unsigned 
• Signed 
• Hex 
• BCD 
 
NOTE: The default value is Unsigned. 

Refer Device – 
Value Length 

Select the bit length. Options are: 
• 16 Bits 
• 32 Bits 
 
NOTE: The default value is 16 Bits. 

State Counts Select the number of states. 

Bitmap Setting 
– From File 

Click to display the Open window to select the location and 
the .bmp file to display. 
 
NOTE: Bitmap images are available in:  
<drive>\Program Files (x86)\Delta Industrial Automation\ 
DIAStudio\DIAScreen\ScrEditApp\TPSeries\BmpGroup\<folders> 

Bitmap Setting 
– Clear Picture Click to delete the current Bitmap. 

User HMI 
Picture Bank Click to select the picture bank and an image in the picture bank 
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NOTE: The Change State by and HMI picture bank options are only available for the 

TP70P series.  

The Change State by property has the following options: 

• Refer Device 

• Automatic Control 

The default value is Refer Device. If user change the option to Automatic Control, 
then the Property tab displays as shown in the following figure. 

 

 

Figure 3 - 75: Dynamic Bitmap window – Property tab – Automatic Control for 
TP70P series 

 

When user select Automatic Control, an additional property displays in the 

Property tab as mentioned in the following table: 

 

Function Description 
Automatic 

Control - Time Enter a time with the multiplication factor of 10ms. 
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NOTE: For the Automatic Control option, user need to select a value in the Time 

field that has a multiplication factor of 10ms. 

 

Click on the Coordinates tab in the Dynamic Bitmap window to display the 

Coordinates tab. 

The Coordinates tab in the Dynamic Bitmap window for the TP70P series text 

panel displays properties as mentioned in the following table: 

 

Function Description 

X Displays the X coordinate for the Dynamic Bitmap element. 
Enter a value to change the X coordinate. 

Y Displays the Y coordinate for the Dynamic Bitmap element. 
Enter a value to change the Y coordinate. 

Width Displays the width for the Dynamic Bitmap element. Enter a 
value to change the width. 

Height Displays the height for the Dynamic Bitmap element. Enter a 
value to change the height. 

 

5. Set the properties as per user’s requirements and click on OK button. 

 

3.5.6 Scale 
 

User can add a scale to a screen with the Scale element.  

 

Follow these steps to add a Scale to a screen and edit the properties in a general 

model TP series text panel: 

1. Click Element(O) > Scale on the Menu bar, or 

           Click the  icon on the Element Selection Toolbar. 

2. Click the screen and drag the mouse to the required dimensions. 

Result: The Scale element is added to the screen. 
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Figure 3 - 76: Scale element 

 

3. Double-click the Scale element to edit the Scale properties. 

Result: The Scale window is displayed as shown in the following figure.  

The Scale window has two tabs for general model TP series text panels: 

• Property 

• Coordinates 

The Property tab is displayed by default. 

 

 

Figure 3 - 77: Scale window – Property tab for general model 

 

The Property tab in the Scale window for the general model TP series text panel 

displays properties as mentioned in the following table: 
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Function Description 

Scale Position 

Select the Scale position. Options are: 
• Top 
• Bottom 
• Left 
• Right 
 
NOTE: The default value is Top. 

Direction 

Select the scaling direction. Options are: 
• Forward Direction 
• Reverse Direction 
 
NOTE: The default value is Forward Direction. 

Value Length 

Select the value length. Options are: 
• 16 Bits 
• 32 Bits 
 
NOTE: The default value is 16 Bits.  

Maximum 
Enter the maximum value for the Scale. 
 
NOTE: The default value is 100. 

Minimum 
Enter the minimum value for the Scale. 
 
NOTE: The default value is 0. 

Font Setting 

Select the font setting. Options are: 
• 5x8 
• 8x8 
• 8x12 
• 8x16 
 
NOTE: The default value is 5x8. 

Scale Mark 
Number 

Enter the intervals between the major tick marks. 
 
NOTE: The default value is 5. 

Subscale Mark 
Number 

Enter the intervals between the minor tick marks. 
 
NOTE: The default value is 2. 
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Click on the Coordinates tab in the Scale window to display the Coordinates tab as 

shown in the following figure. 

 

 

Figure 3 - 78: Scale window – Coordinates tab for general model 

 

The Coordinates tab in the Scale window for the general model TP series text panel 

displays properties as mentioned in the following table: 

 

Function Description 

X Displays the X coordinate for the Scale element. Enter a value 
to change the X coordinate. 

Y Displays the Y coordinate for the Scale element. Enter a value 
to change the Y coordinate. 

Width Displays the width for the Scale element. Enter a value to 
change the width. 

Height Displays the height for the Scale element. Enter a value to 
change the height. 

 

4. Set the properties as per user’s requirements and click on OK button. 
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Example: 
 

Scale Position = Top, Direction = Forward Direction, Minimum = 0, Maximum = 

100. Font Setting = 5x8, Scale Mark Number = 5 and Subscale Mark Number = 4 

displays as shown in the following figure. 

 

 

Figure 3 - 79: Scale element 

 

3.5.7 Bar(P) 
 

User can display the value of a variable in a bar with the Bar element.  

The Bar element for general model and TP70P series text panel is shown in the 

following table: 

 

Element General Model TP70P series 

Bar 

  
 

3.5.7.1 Bar Element in General Model TP Series Text Panel: 
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Follow these steps to add a Bar element to a screen and edit the properties in a 

general model TP series text panel: 

1. Click Element(O) > Bar(P) on the Menu bar, or 

Click the  icon on the Element Selection Toolbar. 

2. Click the screen and drag the mouse to the required dimensions. 

Result: The Bar element is added to the screen. 

3. Double-click the Bar element to edit the Bar properties. 

Result: The Bar window is displayed as shown in the following figure. The 

Bar window has two tabs for general model TP series text panel: 

• Property 

• Coordinates 

The Property tab is displayed by default. 

 

 

Figure 3 - 80: Bar window - Property tab for general model 

 

The Property tab in the Bar window for the general model TP series text panel 

displays properties as mentioned in the following table: 
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Function Description 
Refer Device - Device 

Address 
Select the device address whose value user want to 
display. 

Value Type 

Select the datatype of the variable. Options are: 
• Unsigned 
• Signed 
• Hex 
• BCD 
 
NOTE: The default value is Unsigned. 

Value Length 

Select the Bit Length. Options are: 
• 16 Bits 
• 32 Bits 
 
NOTE: The default value is 16 Bits. 

Maximum 
Enter the maximum value. 
 
NOTE: The default value is 65535. 

Minimum 
Enter the minimum value. 
 
NOTE: The default value is 0. 

Orientation 

Select the orientation of the Bar element. Options are: 
• From Bottom to Top 
• From Top to Bottom 
• From Right to Left 
• From Left to Right 
 
NOTE: The default value is From Bottom to Top. 

 

Click on the Coordinates tab in the Bar window to display the Coordinates tab as 

shown in the following figure. 
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Figure 3 - 81: Bar window - Coordinates tab for general model 

 

The Coordinates tab in the Bar window for the general model TP series text panel 

displays properties as mentioned in the following table: 

 

Function Description 

X Displays the X coordinate for the Bar element. Enter a value to 
change the X coordinate. 

Y Displays the Y coordinate for the Bar element. Enter a value to 
change the Y coordinate. 

Width Displays the width for the Bar element. Enter a value to change 
the width. 

Height Displays the height for the Bar element. Enter a value to 
change the height. 

 

4. Set the properties as per user’s requirements and click on OK button. 
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3.5.7.2 Bar Element in TP70P Series Text Panel: 
 

Steps to add a Bar element to the TP70P series text panel are the same as the steps 

to add a Bar element to the general model TP series text panel. Refer 3.5.7.1 Bar 

element in general model TP series text panel: for more information. 

 

The Bar window for TP70P series is displayed as shown in the following figure. The 

Bar window displays two tabs for TP70P series text panel: 

• Property 

• Coordinates 

The Property tab is displayed by default. 

 

 

Figure 3 - 82: Bar window - Property tab for TP70P series 

 

The Property tab in the Bar window for the TP70P series text panel displays 

properties as shown in the following table: 
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Function Description 
Refer Device – 
Device Address Select the device address whose value user want to display. 

Value Type 

Select the datatype of the variable. Options are: 
• Unsigned 
• Signed 
• Hex 
• BCD 
 
NOTE: The default value is Unsigned. 

Value Length 

Select the Bit Length. Options are: 
• 16 Bits 
• 32 Bits 
 
NOTE: The default value is 16 Bits. 

Maximum 
Enter the maximum value. 
 
NOTE: The default value is 65535. 

Minimum 
Enter the minimum value. 
 
NOTE: The default value is 0. 

High Limit 
Enter high limit value. 
 
NOTE: The default value is 65535. 

Low Limit 
Enter low limit value. 
 
NOTE: The default value is 0. 

Orientation 

Select the orientation of the Bar element. Options are: 
• From Bottom to Top 
• From Top to Bottom 
• From Right to Left 
• From Left to Right 
 
NOTE: The default value is From Bottom to Top. 

Enable 3D Style 

Select to enable or disable the 3D style. Options are: 
• Yes 
• No 
 
NOTE: The default value is Yes. 
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Function Description 

Border Width 
Select the border width. 
 
NOTE: The default value is 5. 

Border Color Select the border color. 
Foreground 

Color Select the foreground color. 

Background 
Color Select the background color. 

High Range 
Color Select the high range color. 

Low Range 
Color Select the low range color. 

Target Value 
Setting - Enable 

Target 
Deviation Value 

Select the check box to enable Target Deviation value settings. 
 
NOTE: Target Deviation is not selected by default. 

Target Value 
Setting - Target Enter the Target value. 

Target Value 
Setting - 
Deviation 

Enter the Deviation value. 

Target Value 
Setting - Target 

Color 
Select the Target color. 

 

If the value of the variable is less than the Lower Limit, then the Bar’s foreground 

color changes from the Foreground Color to Low Range Color. If the value of the 

variable is greater than the High Limit, the Bar’s foreground color changes from the 

Foreground Color to High Range Color. 

If the value of the variable is in the range of (Target – Deviation) or (Target + 

Deviation) and the Enable Target Deviation Value is set, then the Bar’s foreground 

color changes from Foreground Color to Target Color. 

 

Example:  

Target Value = 50, Deviation = 5. 
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If the value of the variable is in the range of 45 to 55, the Bar’s foreground color is 

set to the Target Color. 

If the value of the variable is in the range of (Target – Deviation) to (Target + 

Deviation) and is less than the Low Limit, the Bar’s foreground color is set to the 

Low Range Color. If the value of the variable is in the range of (Target – Deviation) 

to (Target + Deviation) and is greater than High Limit, then the Bar’s foreground 

color is set to the High Range Color. 

Click the Coordinates tab in the Bar window to display the Coordinates tab as 

shown in the following figure. 

 

 

Figure 3 - 83: Bar window - Coordinates tab for TP70P series 

 

The Coordinates tab in the Bar window for the TP70P series text panel displays 

properties as mentioned in the following table: 

 

Function Description 

X Displays the X coordinate for the Bar element. Enter a value to 
change the X coordinate. 
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Function Description 

Y Displays the Y coordinate for the Bar element. Enter a value to 
change the Y coordinate. 

Width Displays the width for the Bar element. Enter a value to change the 
width. 

Height Displays the height for the Bar element. Enter a value to change 
the height. 

 

3.5.8 Meter 
 

User can add the value of a variable to a screen using the pointer of a dial meter 

pointer with the Meter element.  

 

The Meter element for general model and TP70P series text panel is shown in the 

following table: 

 

Element General Model TP70P series 

Meter 

  
 

3.5.8.1 Meter Element in General Model TP Series Text Panel: 
 

Follow these steps to add a Meter to a screen and edit the properties in a general 

model TP series text panel: 

1. Click Element(O) > Meter on the Menu bar, or 

Click the  icon on the Element Selection Toolbar. 

2. Click the screen and drag the mouse to the required dimensions. 
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Result: The Meter element is added to the screen. 

3. Double-click on the Meter element to edit the Meter properties. 

Result: The Meter window is displayed as shown in the following figure. The 

Meter window has two tabs for general model TP series text panel: 

• Property 

• Coordinates 

The Property tab is displayed by default. 

 

 

Figure 3 - 84: Meter window – Property tab for general model 

 

The Property tab in Meter window for general model TP series text panel displays 

properties as mentioned in the following table: 

 

Function Description 
Refer Device - 

Device Address Select the device address whose value user want to display. 

Value Type 
Select the datatype of the variable. Options are: 
• Unsigned 
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Function Description 
• Signed 
• Hex 
• BCD 
 
NOTE: The default value is Unsigned. 

Value Length 
Select the bit length. Option is: 
• 16 Bits 

Integer Digits 

Select the number of integer places. Options are: 
• 1 
• 2 
• 3 
• 4 
• 5 
 
NOTE: The default value is 3. 

Fractional Digits 

Select the number of decimal places. Options are: 
• 0 
• 1 
• 2 
• 3 
• 4 
• 5 
 
NOTE: The default value is 0. 

Maximum 
Enter the maximum value for the Meter’s scale. 
 
NOTE: The default value is 100. 

Minimum 
Enter the minimum value for the Meter’s scale. 
 
NOTE: The default value is 0. 

Style – 
300 Degree 

Click to select 300-degree Meter. 
 
NOTE: The 300 Degree option is checked by default. 

Style – 
360 Degree 

Click to select 360-degree Meter. 

Font Setting 
Select the Font Setting. Options are: 
• 5x8 
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Function Description 
• 8x8 
• 8x12 
• 8x16 
 
NOTE: The default value is 5x8. 

Scale Mark 
Number 

Enter the precision of main scale for the Meter. 
 
NOTE: The default value is 3. 

Subscale Mark 
Number 

Enter the precision of subscale for the Meter. 
 
NOTE: The default value is 2. 

 

Example: (300 Degree and 360 Degree Meters) 

Sample Meter elements with 300 Degree and 360 Degree for general models are 

shown in the following figure. 

 

 

Figure 3 - 85: Meters - 300 and 360 Degrees for general model 

 

Example: 

Style = 360 Degree, Minimum = 0, Maximum = 100, Font Setting = 5x8, Scale 
Mark Number = 5 and Subscale Mark Number = 4 is shown in the following figure. 
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Figure 3 - 86: Meter – example for general model 

 

Click the Coordinates tab in the Bar window to display the Coordinates tab as 

shown in the following figure. 

 

 

Figure 3 - 87: Meter window – Coordinates tab for general model 

 

The Coordinates tab in the Meter window for general model TP series text panel 

displays properties as mentioned in the following table: 

 

Function Description 

X Displays the X coordinate for the Meter element. Enter value to 
change the X coordinate. 
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Function Description 

Y Displays the Y coordinate for the Meter element. Enter value to 
change the Y coordinate. 

Width 
Displays the width for the Meter element. 
 
NOTE: Width is read-only. 

Height 
Displays the height for the Meter element. 
 
NOTE: Height is read-only. 

 

4. Set the properties as per user’s requirements and click on OK button. 

 

3.5.8.2 Meter Element in TP70P Series Text Panel: 
 

The procedure to add a Meter element to a TP70P series text panel is same as the 

adding Meter element to a general model TP series text panel. Refer 3.5.8.1 Meter 

element in general model TP series text panel: for more information. 

 

The Meter window in the TP70P series is shown in the following figure. The Meter 

window has four tabs for TP70P series text panel: 

• Property 

• Appearance 

• Constraint 

• Coordinates 

The Property tab is displayed by default. 
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Figure 3 - 88: Meter window – Property tab for TP70P series 

 

The Property tab in the Meter window for the TP70P series text panel displays 

properties as mentioned in the following table: 

 

Function Description 
Refer Device – 
Read Address Select the device address whose value user want to display. 

Value Type 

Select the datatype for the variable. Options are: 
• Unsigned 
• Signed 
• Hex 
• BCD 
 
NOTE: The default value is Unsigned. 

Value Length 
Select the bit length. Option is: 
• 16 Bits 

Value Setting – 
Maximum 

Enter the maximum value for the Meter’s scale. 
 
NOTE: The default value is 65535. 
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Function Description 

Value Setting – 
Minimum 

Enter the minimum value for the Meter’s scale. 
 
NOTE: The default value is 0. 

 

Click on the Appearance tab in the Meter window of the TP70P series text panel to 

display the contents as shown in the following figure. 

 

 

Figure 3 - 89: Meter window - Appearance tab for TP70P series 

 
The Appearance tab in the Meter window for the TP70P series text panel displays 

properties as mentioned in the following table: 

 

Function Description 

Angle Settings – Start Angle 

Enter the start angle value. 
 
Example: The 12:00 position is 0 angle, and 
the 3:00 position is 90 angle. 

Angle Settings – End Angle Enter the end angle value.  
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Function Description 

Font Settings 

Click to open the Font Setting dialog box to 
set the following properties: 
• Font 
• Size 
• Bold 
• Italics  
 
Click on OK to save the settings. 

Font Color Select the font color for Scale Mark Number 
field. 

Show Value 

Select whether to display or hide the text 
near Scale Mark Number. Options are: 
• Yes 
• No 
 
NOTE: The default value is Yes. 

Background Settings – Border 
Color 

Select the border color of the meter (dial 
color). 

Background Settings – 
Background Color Select the background color of the meter. 

Background Settings – 
Transparent Color 

Select the transparent color.  
 
NOTE: If the Transparent Color is the same 
as the Background Color, the Meter’s 
background color is transparent. 

Background Settings – Show Full 
Circle 

Select to display the meter in a circle or 
angular format. Options are: 
• Yes 
• No 
 
If Circle is set to Yes, then the circular dial 
displays in the meter. If Circle is set to No, 
then the area between End Angle and Start 
Angle is not displayed to users. 
 
NOTE: The default value is Yes. 

Scale – Show Scale 

Select whether to display or hide the scale. 
Options are: 
• Yes 
• No 
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Function Description 
 
NOTE: The default value is Yes. 

Scale – Scale Mark Number 
Select the required number of scale marks. 
 
NOTE: The default value is 4. 

Scale – Subscale Mark Number 

Select the required number of subscale 
marks. 
 
NOTE: The default value is 2. 

Scale – Mark Color Select the color of the scale marks. 

Pointer Settings – Pointer Width 
Select the width of the pointer width. 
 
NOTE: The default value is 2. 

Pointer Settings – Pointer Color Select the color of the pointer. 
 

Click the Constraint tab in the Meter window of the TP70P series text panel to 

display the contents as shown in the following figure. 

 

 

Figure 3 - 90: Meter window – Constraint tab for TP70P series 
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The Constraint tab in the Meter window for the TP70P series text panel displays 

properties as mentioned in the following table: 

 

Function Description 

Enable Range 
Setting 

Select the check box to enable the constraint setting. Clear the 
check box to disable the constraint setting. 
 
NOTE: The Enable Range Setting is disabled by default. 

High Limit and 
Color field 

Enter a high limit range. Select a color for the region between 
the High Limit and the Maximum value. 

Low Limit and 
Color field 

Enter a low limit range. Select a color for the region between 
the Minimum and the Low Limit. 

Inside Color 
field 

Select a color for the region between Low Limit and High 
Limit.  

 

Click the Coordinates tab in the Meter window for the TP70P series text panel to 

display the contents as shown in the following figure. 

 

 

Figure 3 - 91: Meter window - Coordinates tab for TP70P series 
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The Coordinates tab in the Meter window for the TP70P series text panel displays 

properties as mentioned in the following table: 

 

Function Description 

X Displays the X coordinate for the Meter element. Enter a value to 
change the X coordinate. 

Y Displays the Y coordinate for the Meter element. Enter a value to 
change the Y coordinate. 

Width 
Displays the width for the Meter element. 
 
NOTE: Width is read-only. 

Height 
Displays the height for the Meter element 
 
NOTE: Height is read-only. 

 

Example: 

Minimum = 0, Maximum = 100, Start Angle = 200, End Angle = 160, Show Value 

= Yes, Circle = Yes, Scale Mark Number = 4 and Subscale Mark Number = 4, 

Pointer Width = 3, Enable Range Setting = selected, High Limit = 80, Low Limit 
= 20 with the Font Color (RGB) = (0,0,0), Border Color = (192,192,0), Background 
Color = (255,255,255), Transparent Color = (255,0,128), Mark Color = (0,0,0), 

Pointer Color = (100,100,0), High Limit Color = (255,0,0), Low Limit Color = 

(0,0,255), and Inside Color = (255,225,0) is shown in the following figure. 

 

 

Figure 3 - 92: Meter - TP70P series – example 
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3.5.9 Message Display 

 
User can display the state of a variable on a screen in a message using the 

Message Display element.  

 

The Message Display element for general model and TP70P series text panel is 

shown in the following table: 

 

Element General Model TP70P series 

Message 
Display   

 

3.5.9.1 Message Display Element in General Model TP Series Text Panel: 
 

Follow these steps to add a Message Display to a screen and edit the properties in a 

general model TP series text panel: 

1. Click on the Element(O) > Message Display on the Menu bar, or 

Click the  icon on the Element Selection Toolbar. 

2. Click the screen and drag the mouse to the required dimensions. 

Result: The Message Display element is added to the screen. 

3. Double-click the Message Display element to edit the Message Display. 

Result: The Message Display window displays as shown in the following 

figure. The Message Display window has three tabs for the general model TP 

series text panel: 

• Property 

• Text 

• Coordinates 

The Property tab displays by default. 
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Figure 3 - 93: Message Display window – Property tab (Bit) for general model 

 

The Property tab in the Message Display window for the general model TP series 

text panel displays properties as mentioned in the following table: 

 

Function Description 
Refer Device - 

Device Address 
Select the device address based on which message user want 
to display. 

Refer Device – 
Bit 

Select Bit if there are only two states for which messages are 
displayed. 
 
NOTE: The default value is Bit. 

Refer Device - 
Value 

Select Value, if there are multiple states for which messages are 
displayed. 

Static 
Select if user want a static message display. 
 
NOTE: The default value is Static. 

Blink Select if user want a blinking message display. 
Moving Sign Select if user want a scrolling message display. 

Direction Select the direction of the scrolling message display. Options 
are: 
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Function Description 
• From Bottom to Top 
• From Top to Bottom 
• From Left to Right 
• From Right to Left 
 
NOTE: The Direction is enabled only if Moving Sign is 
selected. The default value is From Bottom to Top. 

Interval(ms) 

Select an interval in milliseconds for the display animation. 
Options are: 
• 500 
• 1000 
• 1500 
• 2000 
• 2500 
 
NOTE: The default value is 500. 

State Select the state number for which user want to assign 
properties. 

 

If user select Value, the Property tab in the Message Display window displays as 

shown in the following figure. 

 

 

Figure 3 - 94: Message Display window - Property tab (Value) for general model 
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When user select Value, the Property tab in the Message Display window for 

general model TP series text panel displays extra properties as mentioned in the 

following table: 

 

Function Description 
Range Value 

Sequence - From 
Max to Min 

Select to define the range values in descending order. 

Range Value 
Sequence - From Min 

to Max 
Select to define the range values in ascending order. 

All States Table Enter the values for each state from state0 to stateN, 
where N = (State Counts -1). 

All States Table - 
Reference Value 

Click the button to open the Range Value Reference 
Value dialog box to enter the Range Limit for the Lower 
Bound and Upper Bound. 

Value Type 

Select the variable datatype. Options are: 
• Unsigned 
• Signed 
• Hex 
• BCD 
 
NOTE: The default value is Unsigned. 

Value Length 

Select the bit length here. Options are: 
• 16 Bits 
• 32 Bits 
 
NOTE: The default value is 16 Bits. 

State Counts Select the number of states. 
 

Click the Text tab in the Message Display window for the general model TP series 

text panel to display the contents as shown in the following figure. 
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Figure 3 - 95: Message Display window – Text tab for general model 

 

The Text tab in the Message Display window for the general model TP series text 

panel displays properties as mentioned in the following table: 

 

Function Description 

Text field Enter the text to display in the message display for a particular 
state. 

Process the text 
of all states Click to use the text in the text field for all the states. 

Font type field Select the font type. 
Font size field Select the font size. 

Bold check box Select to bold the font. 
Italics check box Select to italicize the font. 

 

Click the Coordinates tab in the Message Display window for the general model TP 

series text panel to display the contents as shown in the following figure. 
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Figure 3 - 96: Message Display window – Coordinates tab for general model 

 

The Coordinates tab in the Message Display window for the general model TP 

series text panel displays properties as mentioned in the following table: 

 

Function Description 

X Displays the X coordinate for the Message Display element. 
Enter a value to change the X coordinate. 

Y Displays the Y coordinate for the Message Display element. 
Enter a value to change the Y coordinate. 

Width Displays the width for the Message Display element. Enter a 
value to change the width. 

Height Displays the height for Message Display element. Enter a value 
to change the height. 

 

4. Set the properties as per user’s requirements and click on OK button. 

 

3.5.9.2 Message Display Element in TP70P Series Text Panel: 
 

The procedure for adding a Message Display element to a TP70P series text panel 

is same as for the general model TP series text panel. Refer 3.5.9.1 Message 

Display element in general model TP series text panel: for more information. 
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For the TP70P series, the Message Display window displays the properties as 

shown in the following figure. The Message Display window has four tabs for TP70P 

series text panel: 

• Property 

• Text 

• Appearance 

• Coordinates 

The Property tab displays by default. 

 

 

Figure 3 - 97: Message Display window – Property tab (Bit) for TP70P series 

 

The Property tab in the Message Display window for the TP70P series text panel 

displays properties as mentioned in the following table: 

 

Function Description 
Refer Device - 
Read Address 

Select the device address based on which the message user 
want to display. 

Refer Device – 
Bit 

Select Bit if there are only two states for which messages are 
displayed. 
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Function Description 
 
NOTE: The default value is Bit. 

Refer Device - 
Value 

Select Value, if there are multiple states for which messages 
are displayed. 

Value Type 

Select the datatype for the variable. Options are: 
• Unsigned 
• Signed 
• Hex 
• BCD 
 
NOTE: The default value is Unsigned. This field is enabled 
only when Value is selected. 

Value Length 

Select the bit length. Options are: 
• 16 Bits 
• 32 Bits 
 
NOTE: The default value is 16 Bits. This field is enabled only 
when Value is selected. 

State Counts 
Select the number of state counts. 
 
NOTE: The State Counts is enabled only if Value is selected. 

Range Value 
Sequence – 

From Max to Min 

Select the range value sequence from maximum value to 
minimum value. 
 
NOTE: The Range Value Sequence field is available only 
when Value is selected. If Value is selected, the default value 
is From Max to Min. 

Range Value 
Sequence – 

From Min to Max 

Select the range value sequence from minimum value to 
maximum value. 
 
NOTE: The Range Value Sequence field is enabled only if 
Value is selected. 

All States Table 
Enter the value for each state.  
 
NOTE: The number of States is set in State Counts. 

Static 
Select if user want a static message display. 
 
NOTE: The default value is Static. 

Blink Select if user want a blinking message display. 
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Function Description 
Moving Sign Select if user want a scrolling message display. 

Direction 

Select the direction of the scrolling message display. Options 
are: 
• From Bottom to Top 
• From Top to Bottom 
• From Left to Right 
• From Right to Left 
 
NOTE: The Direction is enabled only if Moving Sign is 
selected. The default value is From Bottom to Top. 

Interval(ms) 

Select an interval in milliseconds for the display animation. 
Options are: 
• 500 
• 1000 
• 1500 
• 2000 
• 2500 
 
NOTE: The default value is 500. 

State Select the state for which user want to assign properties. 
 

When user select Value, the Property tab in the Message Display for the TP70P 

series text panel displays the contents as shown in the following figure. 
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Figure 3 - 98: Message Display window – Property tab (Value) for TP70P series 

 

The Property tab in the Message Display window for the TP70P series text panel 

displays extra properties as mentioned in the following table: 

 

Function Description 
Range Value 

Sequence -From 
Max to Min 

Select to define the range values in descending order. 

Range Value 
Sequence -From Min 

to Max 
Select to define the range values in ascending order. 

All States Table Enter the values for each state from state0 to stateN, 
where N = (State Counts -1). 

All States Table - 
Reference Value 

Click the button to open Range Value Reference Value 
dialog box to enter the Range Limit for Lower Bound and 
Upper Bound. 

Value Type 

Select the variable datatype. Options are: 
• Unsigned 
• Signed 
• Hex 
• BCD 
 



Chapter 3                                                                                                     DIAScreen 

151 
 

Function Description 
NOTE: The default value is Unsigned. 

Value Length 

Select the bit length. Options are: 
• 16 Bits 
• 32 Bits 
 
NOTE: The default value is 16 Bits. 

State Counts Select the number of states. 
 

Click the Text tab in the Message Display window for the TP70P series text panel 

to display the contents as shown in the following figure. 

 

 

Figure 3 - 99: Message Display window – Text tab for TP70P series 

 

The Text tab in the Message Display window for the TP70P series text panel 

displays properties as mentioned in the following table: 

 

Function Description 

Text field Enter the text to display in the message display for a particular 
state. 
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Function Description 
Process the text 

of all states 
Click to copy the text in text field and paste in the text field for 
all states. 

Font type field Select the font type. 
Font size field Select the font size. 

Bold check box Select to bold the font. 
Italics check box Select to italicize the font. 
Font Color field Select the font color. 

 

Click the Appearance tab in the Message Display window for the TP70P series text 

panel to display the contents as shown in the following figure. 

 

 

Figure 3 - 100: Message Display window – Appearance tab for TP70P series 

 

The Appearance tab in the Message Display window for the TP70P series text 

panel displays properties as mentioned in the following table: 

 

Function Description 

Enable 3D Style 
Select to enable or disable the 3D style. Options are: 
• Yes 
• No 
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Function Description 
 
NOTE: The default value is Yes. 

Border Width 
Select the border width. 
 
NOTE: The default value is 5. 

Border Color Select the border color. 
Background 

Color Select the background color. 

 

Click the Coordinates tab in the Message Display window for the TP70P series text 

panel to display the contents as shown in the following figure. 

 

 

Figure 3 - 101: Message Display window – Coordinates tab for TP70P series 

 

The Coordinates tab in the Message Display window for the TP70P series text 

panel displays properties as mentioned in the following table: 

 

Function Description 

X Displays the X coordinate for the Message Display element. 
Enter a value to change the X coordinate. 
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Function Description 

Y Displays the Y coordinate for the Message Display element. 
Enter a value to change the Y coordinate. 

Width Displays the width for the Message Display element. Enter a 
value to change the width. 

Height Displays the height for the Message Display element. Enter a 
value to change the height. 

 

3.5.10 Button 
 

Use the Button element to perform the following actions: 

• Turn a device on and off 

• Reset a button 

• Start and stop a pulse 

• Toggle the button 

• Perform momentary action and multi-state operations 

• Input a value 

• Set a constant value 

• Increment and decrement the value of a variable 

• Go to a screen 

• Set passwords 

• Scroll a screen 

• Set the RTC and PLC Link settings 

• Set the Recipe Write/Read settings 

 

The Button element for general model and TP70P series text panel is shown in the 

following table: 
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Element General Model TP70P series 

Button 
  

 

The functions of Button elements are described in the following table: 

 

Button Type Functions 

Set to On 
When user press the button, the device address linked to 
the button turns ON. Once the button is released, the 
device address remains ON. 

Set to Off 
When user press the button, the device address lined to 
the button turns of OFF. Once the button is release, the 
device address remains OFF. 

Pulse On 
When user press the button, a signal going from low to 
high value is sent to the device address linked to the 
button. 

Pulse Off When user press the button, a signal going from high to 
low value is sent to the device address linked to the button. 

Maintained 

When user press the button, the device address linked to 
the button turns ON. Once the button is released, the 
device address remains ON. When user press the button 
again, the device address turns OFF and remains OFF 
once the button is released.  

Momentary 
When user press the button, the device address linked to 
the button turns ON. Once the button is released, the 
device address turns OFF. 

Multistate 
When user press the button, the state of the device 
address linked to the button changes. User can select the 
Bit option, Value option, or the LSB option. 

Set Value 
When user press the button, a dialog box opens to enter a 
value that is written to the device address linked to the 
button. 

Set Constant When user press the button, a constant value is written to 
the device address linked to the button. 

Increment When user press the button, the value of the device 
address linked to the button increments by one. 

Decrement When user press the button, the value of the device 
address linked to the button decrements by one. 

Goto Screen When user press the button, the specified screen opens. 
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Button Type Functions 

Set password When user press the button, a dialog box opens to change 
the user level and password. 

Screen Scroll When user press the button, the screen scrolls up or down. 

Recipe Write/Read When the button is pressed, the Recipe writes or read from 
the device address linked to the button. 

RTC Setting When the button is pressed, the RTC dialog box displays 
to perform RTC settings. 

 

NOTE: Refer A.2 Button Types and supported Models to check the Button types 

supported in TP series text panel.  

 

3.5.10.1 Button Element in General Model TP Series Text Panel: 
 

Follow these steps to add a Button to a screen and edit the properties in a general 

model TP series text panel: 

1. Click on the Element(O) > Button on the Menu bar, or 

Click the  icon on the Element Selection Toolbar. 

2. Click the screen and drag the mouse to the required dimensions. 

Result: The Button element is added to the screen. 

3. Double-click on the Button element to edit the Button properties. 

Result: The Button window displays as shown in the following figure. The 

Button window has four tabs for the general model TP series text panel: 

• Property 

• Text 

• Appearance 

• Coordinates 

The Property tab displays by default. 
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Figure 3 - 102: Button window - Property tab - Set to On for general model 

 

NOTE: If the Button Type is set to - Set to On, Set to Off, Pulse On, Pulse Off, 
Momentary, the Property tab in the Button window displays the properties as 

shown in the above figure. If user selects Momentary, he/she cannot select a user 

level. 

 

The Property tab in the Button window for the general model TP series text panel 

displays properties as mentioned in the following table: 

 

Function Description 

Button Type 

Select the button type. Options are: 
• Set to On 
• Set to Off 
• Pulse On 
• Pulse Off 
• Maintained 
• Momentary 
• Multistate 
• Set Value 
• Set Constant 
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Function Description 
• Increment 
• Decrement 
• Goto Screen 
• Set password 
• Screen Scroll 
• Recipe Write/Read 
• RTC Setting 
 
NOTE: The default value is Set to On. 

Refer Device -
Device Address Select the device address that the Button element writes to. 

Refer Device – 
Enable Read 

Address 

Select to enable a device register to start reading the value. 
Options are: 
• No 
• Yes 
 
NOTE: The default value is No. 

Refer Device – 
Read Address 

Select the device address that the button reads from to get a 
value. This field is enabled only when the Enable Read 
Address is set to Yes. 

Enable Function 
Key 

Select whether to enable or disable the function key. Options 
are: 
• No 
• Yes 
 
NOTE: The default value is No. 

Function Key 

Select the function key from the drop-down list. 
 
NOTE: This field is enabled when Enable Function Key is set 
to Yes. 

Value Type 

Select the datatype of the variable. Options are: 
• Unsigned 
• Signed 
• Hex 
• BCD 
 
NOTE: The default value is Unsigned. 

Value Length 
Select the bit length. Options are: 
• 16 Bits 
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Function Description 
• 32 Bits 
 
NOTE: The default value is 16 Bits. 

User Security 
Level and select 

field 

Select the user security level. Options are: 
• 0 
• 1 
• 2 
• 3 
• 4 
 
NOTE: The default value is 0. 
 

Click the  button to open the User-Level Password Setting 
window to set the passwords for various user levels.For the 
setting method, refer to 3.7.2 User-Level Password Setting 

Notify Setting – 
Enable Notify 

Address 

Select to enable notify address. Options are: 
• No 
• Yes 
 
NOTE: The default value is No. 

Notify Setting – 
Notify Address 

Select the notify address. 
 
NOTE: This is enabled if the Enable Notify Address is set to 
Yes. 

Notify Setting – 
Before/After 

Writing 

Select when to send notification. Options are: 
• Before Writing 
• After Writing 
 
NOTE: This field is enabled if Enable Notify Address is set to 
Yes. The default value is Before Writing. 

Notify Setting – 
Reset/Set 

Select to set the variable. Options are: 
• Reset 
• Set 
 
NOTE: This field is enabled if Enable Notify Address is set to 
Yes. The default value is Reset. 

 



Chapter 3                                                                                                     DIAScreen 

160 
 

When the Button Type is set to Multistate, the Property tab in the Button window 

displays as shown in the following figure. 

 

 

Figure 3 - 103: Button window - Property tab - Multistate for general model 

 

The Property tab in the Button window for the Multistate Button Type displays 

extra properties as mentioned in the following table: 

 

Function Description 
Multi-State Setting – 

Bit 
Select the Bit option to set the State Counts to 2. The 
states are state0 and state1. 

Multi-State Setting – 
Value 

Select the Value option to set State Counts up to a 
maximum of 255 states. The states are from state0 to 
(State Counts -1) 

Multi-State Setting – 
LSB 

Select the LSB option to set States Counts to 16. The 
available states are 1(20), 2(21), 4(22),  
8 16…2 State Counts -1 

Change to – Next State Select to change to next state. 
Change to – Previous 

State Select to change to previous state. 

State Counts Select the number of state counts. The count depends 
on the Multi-State Setting. 
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When the Button Type is set to Set Value, the Property tab in the Button window 

displays as shown in the following figure. 

 

 

Figure 3 - 104: Button window - Property tab - Set Value button type for general 
model 

 

The Property tab in the Button window for the Set Value Button Type displays extra 

properties as mentioned in the following table: 

 

Function Description 

Value Format – 
Integer Digits 

Select the number of integer places. Options are: 
• 1 
• 2 
• 3 
• 4 
• 5 
 
NOTE: The default value is 5. 

Value Format – 
Fractional Digits 

Select the number of decimal places. Options are: 
• 0 
• 1 
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Function Description 
• 2 
• 3 
• 4 
• 5 
 
NOTE: The default value is 0. 

Value Format – 
Maximum 

Enter the maximum value for the set value. 
 
NOTE: The default value is 65535. 

Value Format - 
Minimum 

Enter the minimum value for the set value. 
 
NOTE: The default value is 0. 

 

Example: 

Case 1: If Integer Digits = 3, Fractional Digits = 2, Maximum = 5000, Minimum = 
0, the maximum set value possible is 50.00 

 

Case 2: If Integer Digits = 3, Fractional Digits = 2, Maximum = 500, Minimum = 
0, the maximum set value possible is 5.00 

 
When the Button Type is set to Set Constant, the Property tab in the Button 

window displays as shown in the following figure. 
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Figure 3 - 105: Button window - Property tab - Set Constant Button Type for 
general model 

 

The Property tab in the Button window for the Set Constant Button Type displays 

extra properties as mentioned in the following table: 

 

Function Description 
Constant 
Setting 

Enter the value that is written to the device address when user 
press the set constant button type 

 

When the Button Type is set to Increment or Decrement, the Property tab in the 

Button window displays as shown in the following figure. 
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Figure 3 - 106: Button window - Property tab – Increment Button Type for 
general model 

 

The Property tab in the Button window for the Increment/Decrement Button Type 

displays extra properties as mentioned in the following table: 

 

Function Description 

Increment/Decrement Setting – 
Step Value 

Enter the value that is added to the existing 
value when the button is pressed. 
 
NOTE: The default value is 1. 

Increment/Decrement Setting - 
Limit 

Set the maximum increment value. 
 
NOTE: If user select Increment, the default 
value is 65535. If user select Decrement, the 
default value is 0. 

 

Example:  

Case 1: If the Button Type selected is Increment, Step Value=10, Limit=1000, 
initial value is 10 

Result: Values are available from 20, 30, 40,…to limit 1000. 
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Case 2: If the Button Type selected is Decrement, Step Value=10, Limit=0, initial 
value is 100 

Result: Values are available from 90, 80, 70,…to limit 0. 
 

When the Button Type is set to Goto Screen, the Property tab in the Button 

window displays as shown in the following figure. 

 

 

Figure 3 - 107: Button window - Property tab - Go to Screen Button Type for 
general model 

 

The Property tab in the Button window for the Goto Screen Button Type displays 

extra properties as mentioned in the following table: 

 

Function Description 
Goto Screen 

Setting - Screen Select the screen to navigate to when this button is pressed. 

 

When the Button Type is set to Set password, the Property tab in the Button 

window displays as shown in the following figure. 
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Figure 3 - 108: Button window - Property tab - Set password Button Type for 
general model 

 

In the runtime operation of the HMI, when the Set password button is pressed, a 

window displays, to set the user level and password. 

 

When the Button Type is set to Screen Scroll, the Property tab in the Button 

window displays as shown in the following figure. 

 

Figure 3 - 109: Button window - Property tab - Screen Scroll Button Type for 
general model 
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The Property tab in the Button window for the Screen Scroll Button Type displays 

extra properties as mentioned in the following table: 

 

Function Description 

Screen Scroll – 
Scroll Type 

Select the direction of the scroll when the button is pressed. 
Options are: 
• Scroll Up 
• Scroll Down 
 
NOTE: The default value is Scroll Up. 

Screen Scroll – 
Scroll Lines Select the number of lines to scroll up or down. 

 

When the Button Type is set to RTC Setting, the Property tab in the Button 

window displays as shown in the following figure. 

 

 

Figure 3 - 110: Button window - Property tab - RTC Setting Button Type for 
general model 

 

In the runtime operation of the HMI, when the RTC Setting button is pressed, a 

window is displayed, to set the year, the month, the day, the week, and the time of 

the clock in the general model TP series text panel. 
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When the Button Type is set to PLC Link Setting, the Property tab in the Button 

window is displayed. 

In the runtime operation of the HMI, when the PLC Link Setting button is pressed, a 

window is displayed, to set the PLC Link. 

 

When the Button Type is set to Recipe Write/Read, the Property tab in the Button 

window is displayed as shown in the following figure. 

 

 

Figure 3 - 111: Button window - Property tab - Recipe Write/Read Button Type 
for general model 

 

The Property tab in the Button window for the Recipe Write/Read Button Type 

displays extra properties as mentioned in the following table: 

 

Function Description 

Recipe 
Read/Write 

Setting 

Select to write or read the recipe. Options are: 
• Write 
• Read 
 
NOTE: The default value is Write. 
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NOTE: Before using this function, users have to create a recipe. Refer 3.7.11 Recipe 

Setting for more information. 

 

Click on the Text tab in the Button window for the general model TP series text 

panel to display the contents as shown in the following figure. 

 

 

Figure 3 - 112: Button window - Text tab for general model 

 

The Text tab in the Button window for the general model TP series text panel 

displays properties as mentioned in the following table: 

 

Function Description 
Text field Select the text to display in the Button. 

Process the text of all 
states 

Click to copy the text in text field and paste in the text field 
for all states. 

Font size field 

Select the font size from the drop-down menu. Options 
are: 
• 5x8 
• 8x8 
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Function Description 
• 8x12 
• 8x16 
 
NOTE: The default value is 5x8. 

Horiz. alignment 

Select the horizontal alignment. Options are: 
• Align Left 
• Horiz. Centering 
• Align Right 
 
NOTE: The default value is Horiz. Centering. 

Vert. alignment 

Select the vertical alignment. Options are: 
• Align Top 
• Vert. Centering 
• Align Bottom 
 
NOTE: The default value is Vert. Centering. 

 

Click on the Appearance tab in the Button window of the general model TP series 

text panel to display the contents as shown in the following figure. 

 

 

Figure 3 - 113: Button window - Appearance tab for general model 
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The Appearance tab in the Button window for the general model TP series text 

panel displays properties as mentioned in the following table: 

 

Function Description 

Button Styles 

Select the border type. Options are: 
• No Border 
• Single Border 
• Double Border 
• Circle Border 
• Hide 
 
NOTE: The default value is Single Border. 

Bitmap 
Alignment 

Select the vertical alignment. Options are: 
• Align Top 
• Align Center 
• Align Bottom 
 
NOTE: The default value is Align Center. 
 
Select the horizontal alignment. Options are: 
• Align Left 
• Align Center 
• Align Right 
 
NOTE: The default value is Align Center. 

Bitmap Read 

Click to display the Open window to select a location and a .bmp 
file of the Bitmap 
 
NOTE: Bitmap images are available in:  
<drive>\Program Files (x86)\Delta Industrial Automation\ 
DIAStudio\DIAScreen\ScrEditApp\TPSeries\BmpGroup\<folders> 

Clear Picture Click to delete the current bitmap 
 

Click the Coordinates tab in the Button window of the general model TP series text 

panel to display the contents as shown in the following figure. 
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Figure 3 - 114: Button window - Coordinates tab for general model 

 

The Coordinates tab in the Button window for the general model TP series text 

panel displays properties as mentioned in the following table: 

 

Function Description 

X Displays the X coordinate for the Button element. Enter a value 
to change the X coordinate. 

Y Displays the Y coordinate for the Button element. Enter a value 
to change the Y coordinate. 

Width Displays the width for the Button element. Enter a value to 
change the width. 

Height Displays the height for the Button element. Enter a value to 
change the height. 

 

4. Set the properties as per user’s requirements and click on OK. 
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3.5.10.2 Button Element in TP70P Series Text Panel: 
 

The procedure for adding a Button element to a TP70P series text panel is same as 

steps for the general model TP series text panel. Refer 3.5.10.1 Button element in 

general model TP series text panel: for more information. 

 

For TP70P series, the Button window displays the properties as shown in the 

following figure. The Button window has four tabs for the TP70P series text panel: 

• Property 

• Text 

• Appearance 

• Coordinates 

The Property tab displays by default. 

 

 

Figure 3 - 115: Button window - Property tab for TP70P series 

 

The Property tab in the Button window for the TP70P series text panel displays 

properties as mentioned in the following table: 
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Function Description 

Button Type 

Select the button type. Options are: 
• Set to On 
• Set to Off 
• Pulse On 
• Pulse Off 
• Maintained 
• Momentary 
• Multistate 
• Set Value 
• Set Constant 
• Increment 
• Decrement 
• Goto Screen 
• Set password 
• RTC Setting 
 
NOTE: The default value is Set to On. 

Refer Device -
Device 

Address 
Select the device address that the Button element writes to. 

Interlock 
Settings – 

Enable Read 
Address 

Select to enable a device register to start reading the value. 
Options are: 
• No 
• Yes 
 
NOTE: The default value is No. 

Interlock 
Settings – 

Read Address 

Click  button to open the Refer Device dialog box to select 
the variable that works as interlock for the Numeric Input 
controls. 
 
NOTE: The Read Address is not available by default. 

Interlock 
Settings - State 

Select the OFF(0) or ON(1) state of the Read Address at which 
interlock can be applied to the Numeric Input controls. Options 
are: 
• OFF 
• ON 
 



Chapter 3                                                                                                     DIAScreen 

175 
 

Function Description 
NOTE: The default value is OFF. 

Value Type 

Select the datatype for the variable. Options are: 
• Unsigned 
• Signed 
• Hex 
• BCD 
 
NOTE: The default value is Unsigned. 

Value Length 

Select the bit length. Options are: 
• 16 Bits 
• 32 Bits 
 
NOTE: The default value is 16 Bits. 

User Security 
Level and 
select field 

Select user security level. Options are: 
• 0 
• 1 
• 2 
• 3 
• 4 
 

NOTE: The default value is 0. Click  button to open the 
User-Level Password Setting dialog box to set the passwords 
for various user levels. 

Notify Setting – 
Enable Notify 

Address 

Select to enable notify address. Options are: 
• No 
• Yes 
 
NOTE: The default value is No. 

Notify Setting – 
Notify Address 

Select the notify address. 
 
NOTE: This field is enabled if Enable Notify Address is set to 
Yes. 

Notify Setting – 
Before/After 

Writing 

Select to notify before writing or after writing. Options are: 
• Before Writing 
• After Writing 
 
NOTE: This field is enabled if Enable Notify Address is set to 
Yes. The default value is Before Writing. 
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Function Description 

Notify Setting – 
Reset/Set 

Select to set the variable. Options are: 
• Reset 
• Set 
 
NOTE: This field is enabled if the Enable Notify Address is set 
to Yes. The default value is Reset. 

 

NOTE: Other properties in the Property tab for the TP70P series panel are the same 

as those in the Property tab for the general model TP series text panel. 

 

Click on the Text tab in the Button window of the TP70P series text panel to display 

the contents as shown in the following figure. 

 

 

Figure 3 - 116: Button window - Text tab for TP70P series 

 

The Text tab in the Button window for the TP70P series text panel displays 

properties as mentioned in the following table: 
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Function Description 
Text field Select the text to display in the Button. 

Process the text 
of all states 

Click to copy the text in text field and paste in the text field for 
all the states. 

Font type field Select the font type. 
Font size field Select the font size. 

Bold check box Select to bold the font. 
Italics check box Select to italicize the font. 
Font Color field Select the font color. 

Horiz. alignment 

Select the horizontal alignment. Options are: 
• Align Left 
• Horiz. Centering 
• Align Right 
 
NOTE: The default value is Horiz. Centering. 

Vert. alignment 

Select the vertical alignment. Options are: 
• Align Top 
• Vert. Centering 
• Align Bottom 
 
NOTE: The default value is Vert. Centering. 

 

Click on the Appearance tab in the Button window of the TP70P series text panel to 

display the contents as shown in the following figure. 
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Figure 3 - 117: Button window - Appearance tab for TP70P series 

 

The Appearance tab in the Button window for the TP70P series text panel displays 

extra properties compared to the Appearance tab in general model TP series text 

panel as mentioned in the following table: 

 

Function Description 

Enable 3D Style 

Select to enable or disable the 3D style. Options 
are: 
• Yes 
• No 
 
NOTE: The default value is Yes. 

Border Width 
Select the border width. 
 
NOTE: The default value is 15. 

Border Color 

Select the border color. 
 
NOTE: This field is enabled when Enable 3D 
Style is set to No. 

Button State Color Setting – 
Button State 

Select the button state. Options are: 
• Button Up 
• Button Down 
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Function Description 
• Disable 
 
NOTE: The default value is Button Up. 

Button State Color Setting – 
Background Color Select the background color for the button. 

Use HMI Picture Bank and 
select field 

Click to select a picture bank and an image in the 
bank. 

 

Click the Coordinates tab in the Button window of the TP70P series text panel to 

display the contents as shown in the following figure. 

 

 

Figure 3 - 118: Button window - Coordinates tab for TP70P series 

 

The Coordinates tab in the Button window for the TP70P series text panel displays 

properties as mentioned in the following table: 

 

Function Description 

X Displays the X coordinate for the Button element. Enter a value 
to change the X coordinate. 

Y Displays the Y coordinate for the Button element. Enter a value 
to change the Y coordinate. 
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Function Description 

Width Displays the width for the Button element. Enter a value to 
change the width. 

Height Displays the height for the Button element. Enter a value to 
change the height. 

 

3.5.10.3 Multiple Actions Button 
 

Remark: This function is applicable to DOP-100 series and AX-8 series models. 

The Multiple actions button provides a variety of button behaviors. The user can 

define (1) the action to be performed after pressing the button, (2) the action to be 

performed after releasing the button, and (3) the action to be performed after 

pressing the button continuously. This function can be used to replace complicated 

procedures written by macro trigger buttons. 

 

The button behavior provided by the Multiple actions includes the following: 

 

 

Figure 3 - 119：Buttons provided by Multiple actions buttons 
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Remark: 

1. Press action, release action and continuous pressing action, each action can 

add up to 32 new actions, so a Multiple Actions button can perform up to 32*3 

actions. 

2. The system directory can only be used as the last action (other actions 

cannot be added later). 

3. One Multiple actions button can only have one-page change action, including 

Goto Screen and previous page. 

 

Please refer to the following steps to create a Multiple actions button： 

1. On the menu, click Element > Button > Multiple actions or click the button 

on the component selection toolbar > Multiple actions. 

2. Click anywhere in the editing area of the screen and drag out the appropriate 

size and release the mouse. 

3. Double-click the Multiple actions button component on the screen, and the 

property window will display as shown below. 
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Figure 3 - 120：Multiple actions button window 

 

4. Set the action when it is pressed, No. 1 is set as the added value, the write 

memory address is $10, the addition and subtraction number is 3, and the 

upper and lower limits are 100, as shown in the figure below. 
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Figure 3 - 121: Action setting when pressed (1) 

 

5. Continue to set the action when pressing, No. 2 is set to the reset state, the 

write memory address is $20, and the total number of states is set to 3, as 

shown below 

 

 

Figure 3 - 122: Action setting when pressed (2) 
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6. Set the action when releasing is to change the screen to Screen_2, as shown 

below. 

 

 

Figure 3 - 123: Action setting when releasing 

 

7. The action of setting the continuous pressing is a constant value, and the 

continuous pressing time is 3 seconds. Set the write memory address to $30 

and the set value to 5000, as shown below。 

 

 

Figure 3 - 124: Long pressed 

 

 

Figure 3 - 125: Action setting for continuous pressing 
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8. Create two numerical display components, respectively set the read memory 

address to $10 to display the value change after the addition action is 

executed; and set the read memory address to $30 to show the constant 

value action is executed Value change. 

 

 

Figure 3 - 126: Create two numerical display components 

 

9. Create a reset button, set the write memory address to $20, the total number 

of states to 3, and the switching sequence to the next state. And set the 

foreground color of the component in state 0, 1, 2. 

 
Status Component foreground color 

0 
 

1 
 

2 
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Figure 3 - 127: Set MultiState 

 

10. Add Screen_2, create a table component and a screen change button, and 

set the screen to switch to Screen_1. 

 

 

Figure 3 - 128: Switch screen to Screen_1 

 

Result: 

• Press the Multiple Actions button, the actions of the added value and the reset 
state will be executed. 
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Figure 3 - 129: The actions of added value and recovery state will be executed 

 

• Release the Multiple actions button, the screen change action will be executed, 
and the HMI screen has been switched to Screen_2. 
 

 

Figure 3 - 130: Switch to Screen_2 

 

• Switch the screen to Screen_1, press and hold the Multiple actions button for 3 
seconds, the action of setting the constant value will be executed. Because the 
Multiple Actions button is not only pressed for 3 seconds, but also executed the 
pressed action, so the added and re-state actions will also be executed. 
 

 

Figure 3 - 131: Switch screen to Screen_1 
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Functions in the Property tab of Multiple Actions window are described in the table 

below:  

 

Features Description 

Preview 
The Multiple actions button can only be used to view the display 
data of multiple languages, because this component does not 
have multiple status attributes. 

Main 

• Style: Set component style, component foreground color, fill 
style and use text map. 

• Action: Set the action when pressing, the action when 
releasing, the action of continuous pressing, the time of 
continuous pressing. 

Main Two 
Set transparency, turn on smooth animation, turn on anti-
aliasing。 

Text 
Set the text content / font / size / color / format / zoom / alignment 
type to be displayed. 

Picture 
Set graphics library name, alignment style, graphics extension 
mode, specify graphics transparent color. 

Advanced 
Set the effective level, effective bit, invisible bit, user authority, 
and set the lowest authority after input. 

Macro Set pre-execution macro and post-execution macro. 

Position 
X-Y coordinate value and width and height settings of button 
components. 
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• General tab function description 
 

 

Figure 3 - 132: Multiple actions button window Main tab 

 

Features Description 

Action 
when 

pressed 

• Refers to the action to be performed after pressing the Multiple 
actions button. 

• The actions supported by the action when pressed are as 
follows. 



Chapter 3                                                                                                     DIAScreen 

190 
 

Features Description 

 

Action 
when 

released 

• Refers to the action to be performed after releasing the Multiple 
actions button. 

• The behavior supported by the action when released is the 
same as the action when pressed. 

Action 
when 
long 

pressed 

• Refers to the action to be performed after continuously pressing 
the Multiple actions button. 

• Need to match the setting of continuous pressing time, the 
continuous pressing action will take effect. 

• The button behavior supported by the continuous pressing 
action is the same as the action when pressed and released. 

Long 
pressed 

time 

Continuous pressing threshold time can be set from 0 to 10 seconds. 
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Features Description 

Componen
t type 

The component types are divided into Standard, Raised, Round, 
Invisible. This setting can provide the user to change the appearance 
of the component. 
 

 

Componen
t 

foreground 
color 

• The display color of the component foreground can be set. 
• When the component type is Invisible, setting the component 

foreground color has no effect. 
 

 

Filled style 
Set the filling effect of the button, which can be set as a gradient 
color or a fixed color. 
 

Language 
When the user has set language data, they can edit the text 
attributes to be displayed through the language of the component, 
etc. 
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Features Description 

 
 

 

Componen
t 

description 

It can be used to record the action to be performed by the button. 
This description will be written into the CSV file of the operation log 
to let the user know the action performed. 
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• Main-2 tab function description 
 

 

Figure 3 - 133: Multiple actions button window Main-2 

 

Features Description 

Transparent 

The default transparency is 255, the minimum is 50, and the 
maximum is 255, which can be adjusted by the user. The 
smaller the value, the higher the transparency of the 
component. 

Smooth 
animation 

This component cannot enable smooth animation. 

Anti-aliasing This component cannot turn on anti-aliasing. 
 

• Description of the content tab function 
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Figure 3 - 134：Multiple actions button window Text tab 

 

Features Description 

Text 
The user can enter the text message to be displayed in the text 
box. 
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Features Description 

 

 

As long as it is a component that can input any text, user can click 
the component on the screen and press the blank key on the 
keyboard to edit and input text immediately. 

Text property 

User can set the text-related attributes, including setting the text 

font, text size, text color, the scale of the text to be zoomed, the 

alignment displayed, and whether the text is 

bold/italicized/underlined. 

Edit 

Multilanguage 

Text 

If the user has added multi-language data, then user can enter this 

text page to edit the multi-language text data, as shown in the text 

attribute diagram, user can enter English words in the English 

field. 
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• Picture 
 

 

Figure 3 - 135: Multiple actions button window Picture tab 

 

Features Description 

Picture 
Bank Name 

The default graphic library name is None. If the user wants to set a 
customized graphic display, he can click to pull down the graphic 
library built in the software and select the desired graphic. 
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Features Description 
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Features Description 
 

Alignment 

The alignment of the set graphics can be set through the alignment 
options. 
 

 

 

Stretch 
Mode 

• The extension mode is divided into all areas, 
maintaining the proportion, and the actual size can be 
set. 

 

 
 

• If the user selects the graphics processing all states, it 
means that the component has multiple state values, 
and the graphics may not extend to the entire area. 
After checking this function, all graphics can be 
processed instead of setting them one by one. Can 
reduce time-consuming editing. 
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Features Description 

Transparent 
Color 

This function can specify a color in the graph and make it 
transparent. Represents if using the transparent color icon of the 
selected graphics  Click the white part of the calendar, the 
software will skip the white part of the picture and become a 
transparent color, which means it is the foreground color of the 
component. 
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• Description of Details tab function 
 

 

Figure 3 - 136: Multiple actions button window Details tab 

 

Features Description 

Interlock 
State 

The interlock state bit is mainly used to allow the user to operate a 
component through this bit, and must be used with the effective level. 
If the effective level is set to OFF, it means that the effective bit can 
be operated when the effective level is OFF; on the contrary, if the 
effective level is set to ON, it means that the effective bit is in the 
state of ON Before operation. 
Its behavior is as follows: 
1. Please create a button first and set its address to $8.0, then set 

the effective bit in the Multiple actions button to $8.0. 
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Features Description 

Interlock 
Address 

2. If user want the Multiple actions button to operate, user must first 
press the $8.0 button to make the Multiple actions button action 
take effect. 
 

 

Interlock 
Display  
Mode 

• The Interlock display mode is divided into, Show Element 
and Show Prohibition Symbol. 

 

 

 
• If the prohibition symbol is displayed when no action is 

selected, the effective level is shown as follows. 
 

 

Invisible 
Address 

When the invisible bit is set to On, the button element will be hidden 
and its setting function will not be executed. 
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Features Description 

User 
Security 

Level 

• Use this function to set the authority of the components 
pressing action, and it can only be used if it is higher than 
or equal to the set authority. 

• After setting the user authority level, the password input 
window will pop up when pressing the component to 
confirm whether the authority level password is correct. 

 

 

Set Low 
Security 

Set the lowest authority after input. If it is set to YES, the HMI will 
automatically set the use authority to the lowest after each input. 
When the component is pressed next time, it will ask for the password 
again and ask for the corresponding authority level password. 
 

 

Modifier + 
Hot Key 
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• Function description of macro tab 
 

 

Figure 3 - 137: Multiple actions button window Macro tab 

 

Features Description 

Before 
Execute 
macro 

When the user touches the button element, the command in this 
macro will be executed first before the button action is executed. 
But if the state of the button is not changed by touch (using 
external controller commands or other macro changes), the macro 
command will not be executed. 
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Features Description 

 

 

After Execute 
macro 

When the user touches the button element, the button will be 
executed first, and then this macro command will be executed. But 
if the state of the button is not changed by touch (using external 
controller commands or other macro changes), the macro 
command will not be executed. 
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Features Description 
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• Function description of Coordinates tab 
 

 

Figure 3 - 138: Multiple actions button window Coordinates tab 

 

Function Description 
X Displays the X coordinate of the upper left corner of the element. 

Y Displays the Y coordinate of the upper left corner of the 
component 

Width Displays the width of an element. Enter a value to change the 
width. 

Height Displays the height of an element. Enter a value to change the 
height. 

 

3.5.11 RTC(L) 
 

User can display a real time clock on the screen of a TP series text panel using the 

RTC element, the time on the real time clock is written to a related device connected 
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to the equipment or the time in a related device connected to the equipment is read 

and displayed on the screen of the TP series text panel. 

 

The RTC element for general model and TP70P series text panel is shown in the 

following table: 

 

Element General Model TP70P series 

RTC 
  

 

3.5.11.1 RTC Element in General Model TP Series Text Panel: 
 

Follow these steps to add the RTC element to a screen and edit the properties in a 

general model TP series text panel: 

1. Click the Element(O) > RTC(L) on the Menu bar, or 

Click the  icon on the Element Selection Toolbar. 

2. Click the screen and drag the mouse to the required dimensions. 

Result: The RTC element is added to the screen. 

3. Double-click the RTC element to edit the RTC element properties. 

Result: The RTC window displays as shown in the following figure. The RTC 

window has two tabs for general model TP series text panel: 

• Property 

• Coordinates 

The Property tab displays by default. 
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Figure 3 - 139: RTC window – Property tab for general model 

 

The Property tab in the RTC window for the general model TP series text panel 

displays properties as mentioned in the following table: 

 

Function Description 
Write Select to enable the RTC to write to the device. 

Device Address Click to open the Refer Device window to 
select the variable address for the device. 

Time Association – TP RTC 
Time 

Select, to write the time/day/date of the RTC in 
the TP series text panel to the related devices 
and display on the screen in the TP series text 
panel. 

Time Association – PLC Time 
Select, to read the time/day/date in the related 
devices and display on the screen in the TP 
series text panel. 

Outline 

Select the border type. Options are: 
• No Border 
• Single Border 
• Double Border 
• Thick Border 
• Dot Border 
• Dotted Line Border 
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Function Description 
 
NOTE: The default value is No Border. 

Font Setting 

Select the font setting. Options are: 
• 5x8 
• 8x8 
• 8x12 
• 8x16 
 
NOTE: The default value is 5x8. 

Horiz. Alignment 

Select the horizontal alignment. Options are: 
• Align Left 
• Horizontal Centering 
• Align Right 
 
NOTE: The default value is Align Left. 

Time 
Select to display the RTC time. 
 
Example: HH:MM: SS 

Day 
Select to display the RTC day. 
 
Example: SUN.  

Date 
Select to display the RTC date. 
 
Example: YYYY/MM/DD. 

 

Click on the Coordinates tab in the RTC window of the general model TP series text 

panel to display the contents as shown in the following figure. 
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Figure 3 - 140: RTC window – Coordinates tab for general model 

 

The Coordinates tab in the RTC window for general model TP series text panel 

displays properties as mentioned in the following table: 

 

Function Description 

X Displays the X coordinate for the RTC element. Enter a 
value to change the X coordinate. 

Y Displays the Y coordinate for the RTC element. Enter a 
value to change the Y coordinate. 

Width Displays the width for the RTC element. Enter a value to 
change the width. 

Height Displays the height for the RTC element. Enter a value to 
change the height. 

 
4. Set the properties as per user’s requirements and click on OK button. 
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3.5.11.2 RTC Element in TP70P Series Text Panel: 
 

The procedure to add a RTC element in the TP70P series text panel is same as that 

for the general model TP series text panel. Refer 3.5.11.1 RTC element in general 

model TP series text panel: for more information. 

 

The RTC window for the TP70P series displays as shown in the following figure. The 

RTC window has three tabs for TP70P series text panel: 

• Property 

• Appearance 

• Coordinates 

The Property tab is the default tab. 

 

 

Figure 3 - 141: RTC window – Property tab for TP70P series 

 

The Property tab in the RTC window for the TP70P series text panel displays 

properties as mentioned in the following table: 
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Function Description 
Write Select to enable RTC write to the device. 

Device Address Click to open Refer Device window to select the variable 
address for the device. 

Time 
Association – 
TP RTC Time 

Select, to write the time/day/date of RTC in the TP series text 
panel to the related devices and display on the screen in the TP 
series text panel. 

Time 
Association – 

PLC Time 

Select, to read the time/day/date in the related devices and 
display on the screen in the TP series text panel. 

 

Click the Appearance tab in the RTC window of the TP70P series text panel to 

display the contents as shown in the following figure. 

 

 

Figure 3 - 142: RTC window – Appearance tab for TP70P series 

 

The Appearance tab in the RTC window for the TP70P series text panel displays 

properties as mentioned in the following table: 

 

Function Description 
Time Select to display the RTC time. 
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Function Description 
 
Example: HH:MM: SS. 

Day 
Select to display the RTC day. 
 
Example: SUN. 

Date 
Select to display the RTC date. 
 
Example: YYYY/MM/DD. 

Font Settings 

Click to open Font Setting window to set the following 
properties: 
• Font 
• Size 
• Bold 
• Italics  
 
Click OK to save settings. 

Horiz. Alignment 

Select the horizontal alignment. Options are: 
• Align Left 
• Horizontal Centering 
• Align Right 
 
NOTE: The default value is Align Left. 

Vert. alignment 

Select the vertical alignment. Options are: 
• Align Top 
• Vert. Centering 
• Align Bottom 
 
NOTE: The default value is Align Top. 

Enable 3D Style 

Select to enable or disable 3D style. Options are: 
• Yes 
• No 
 
NOTE: The default value is Yes. 

Border Width 
Select the border width. 
 
NOTE: The default value is 5. 

Color Setting -
Border Color Select the border color. 
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Function Description 
Color Setting -
Border Color Select the font color. 

Color Setting -
Background Color Select the background color. 

 

Click the Coordinates tab in the RTC window of the TP series text panel to display 

the contents as shown in the following figure. 

 

 

Figure 3 - 143: RTC window – Coordinates tab for TP70P series 

 

The Coordinates tab in the RTC window for the TP70P series text panel displays 

properties as mentioned in the following table: 

 

Function Description 

X Displays the X coordinate for the RTC element. Enter a value to 
change the X coordinate. 

Y Displays the Y coordinate for the RTC element. Enter a value to 
change the Y coordinate. 

Width Displays the width for the RTC element. Enter a value to 
change the width. 
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Function Description 

Height Displays the height for the RTC element. Enter a value to 
change the height. 

 

3.5.12 Multistate Indicator 
 

User can add a multistate image or text to a screen using the Multistate Indicator 
element. 

3.5.12.1 Multistate Indicator in General Model TP Series Text Panel: 
 

Follow these steps to add a Multistate Indicator element to the screen in a general 

model TP series text panel: 

1. Click the Element(O) > Multistate Indicator on the Menu bar, or 

           Click the  icon on the Element Selection Toolbar. 

2. Click the screen and drag the mouse to the required dimensions. 

Result: The Multistate Indicator element is added to the screen. 

3. Double-click on the Multistate Indicator element to edit the properties. 

Result: The Multistate Indicator window displays as shown in the following 

figure. 

The Multistate Indicator window has three tabs for general model TP series 

text panel: 

• Property 

• Text 

• Coordinates 

The Property tab is the default tab. 
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Figure 3 - 144: Multistate Indicator window – Property tab (Bit) for general 
model 

The Property tab in the Multistate Indicator window for the general mode TP series 

text panel displays properties as mentioned in the following table: 

 

Function Description 
Refer Device -

Device Address Select the device address that user want to display. 

Refer Device – 
Bit 

Select Bit if there are only 2 states. 
 
NOTE: The default value is Bit. 

Refer Device - 
Value Select Value, if there are multiple states. 

Bitmap Read Click to display the Open window to select a location and 
a .bmp file for the Bitmap. 

Clear Picture Click to delete the current Bitmap. 
 

If user select Bit, user can select images corresponding to the values of 0 and 1. If 

user select Value, user can set up to a maximum of 255 states.  

If user select Value, the Multistate Indicator window displays the Property tab as 

shown in the following figure. 
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Figure 3 - 145: Multistate Indicator – Property tab (Value) for general model 

 

The Property tab in the Multistate Indicator window for the general model TP 

series text panel displays Value properties as mentioned in the following table: 

 

Function Description 
Range Value 

Sequence -From Max 
to Min 

Select to define range values in descending order. 

Range Value 
Sequence -From Min 

to Max 
Select to define range values in ascending order. 

All States Table Enter the values for states from state0 to stateN, where N 
= (States Counts -1). 

All States Table 
Reference Value 

Click the button to open Range Value Reference Value 
dialog box. Enter the Range Limit for Lower Bound and 
Upper Bound. 

 

Click the Text tab in the Multistate Indicator window in the general model TP series 

text panel to display the contents as shown in the following figure. 
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Figure 3 - 146:  Multistate Indicator – Text tab for general model 

 

The Text tab in the Multistate Indicator window for the general model TP series 

text panel displays properties as mentioned in the following table: 

 

Function Description 
Text field Enter the text. 

Process the text of all 
states Click to copy the text in text field to paste in all the state. 

Font Type field Select the font type. 
Font Size field Select the font size. 

Bold field Select to bold the text. 
Italic Select to italicize the text. 

 

Click the Coordinates tab in the Multistate Indicator window for the general model 

TP series text panel to display the contents as shown in the following figure. 
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Figure 3 - 147: Multistate Indicator – Coordinates tab for general model 

 

The Coordinates tab in the Multistate Indicator window for the general model TP 

series text panel displays properties as mentioned in the following table: 

 

Function Description 

X Displays the X coordinate for the Multistate Indicator 
element. Enter a value to change the X coordinate. 

Y Displays the Y coordinate for the Multistate Indicator 
element. Enter a value to change the Y coordinate. 

Width Displays the width for the Multistate Indicator element. 
Enter a value to change the width. 

Height Displays the height for the Multistate Indicator element. 
Enter a value to change the height. 

 

4. Set the properties as per user’s requirements and click OK. 
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3.5.12.2 Multistate Indicator in TP70P Series Text Panel: 

 
The steps for adding a Multistate Indicator element in the TP70P series text panel 

are the same as the steps for the general model TP series text panel. Refer 3.5.12.1 

Multistate Indicator in general model TP series text panel: for more information. 

 

The Multistate Indicator window for the TP70P series text panel is shown in the 

following figure. The Multistate Indicator window has four tabs for the TP70P series 

text panel: 

• Property 

• Text 

• Appearance 

• Coordinates 

The Property tab is the default tab. 

 

 

Figure 3 - 148: Multistate Indicator – Property tab (Bit) for TP70P series 

 



Chapter 3                                                                                                     DIAScreen 

221 
 

The Property tab in the Multistate Indicator window for the TP70P series text panel 

displays properties as same as general model. 

 
The Property tab in the Multistate Indicator window for the TP70P series text panel 

displays Value properties as mentioned in the following table: 

 

Function Description 
Range Value 
Sequence -
From Max to 

Min 

Select to define range values in descending order. 

Range Value 
Sequence -
From Min to 

Max 

Select to define range values in ascending order. 

All States Table Enter the values for states from state0 to stateN, where N = 
(States Counts -1). 

All States Table 
- Reference 

Value 

Click the button to open Range Value Reference Value dialog 
box. Enter the Range Limit for Lower Bound and Upper 
Bound. 

 

Click the Text tab in the Multistate Indicator window of the TP70P series text panel 

to display the contents as shown in the following figure. 
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Figure 3 - 149: Multistate Indicator – Text tab for TP70P series 

 

The Text tab in the Multistate Indicator window for the TP70P series text panel 

displays properties as mentioned in the following table: 

 

Function Description 
Text field Enter the text. 

Process the text 
of all states Click to copy the text in text field to be past in all the states. 

Font Type field Select the font type. 
Font Size field Select the font size. 

Bold field Select to bold the text. 
Italic Select to italicize the text. 

Horiz. alignment 

Select the horizontal alignment. Options are: 
• Align Left 
• Horiz. Centering 
• Align Right 
 
NOTE: The default value is Align Left. 

Vert. alignment 
Select the vertical alignment. Options are: 
• Align Top 
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Function Description 
• Vert. Centering 
• Align Bottom 
 
NOTE: The default value is Align Top. 

 

Click the Appearance tab in the Multistate Indicator window of the TP70P series 

text panel to display the contents as shown in the following figure. 

 

 

Figure 3 - 150: Multistate Indicator – Appearance tab for TP70P series 

 

The Appearance tab in the Multistate Indicator window for the TP70P series text 

panel displays properties as mentioned in the following table: 

 

Function Description 

Enable 3D 
Style 

Select enable or disable the 3D style. Options are: 
• Yes 
• No 
 
NOTE: The default value is Yes. 

Border Width Select the border width. 
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Function Description 
 
NOTE: The default value is 5. 

Border Color Select the border color. 
Background 

Color Select the background color. 

Style 

Select the style. Options are: 
• Standard 
• Round 
 
NOTE: The default value is Standard. 

Background 
Color Select the background color. 

Bitmap Setting 
– From File 

Click to display the Open window to select a location and a .bmp 
file for the Bitmap. 

Bitmap Setting 
– Clear Picture Click to delete the current Bitmap. 

User HMI 
Picture Bank Click to select picture bank and an image in the picture bank. 

Bitmap 
Alignment 

Select vertical and horizontal alignment 
 
NOTE: The default values are Align Top and Align Left. 

 

Click the Coordinates tab in the Multistate Indicator window of the TP70P series 

text panel to display the contents as shown in the following figure. 
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Figure 3 - 151: Multistate Indicator - Coordinates tab for TP70P series 

 

The Coordinates tab in the Multistate Indicator window for the TP70P series text 

panel displays properties as mentioned in the following table: 

 

Function Description 

X Displays the X coordinate for the Multistate Indicator element. 
Enter a value to change the X coordinate. 

Y Displays the Y coordinate for the Multistate Indicator element. 
Enter a value to change the Y coordinate. 

Width Displays the width for the Multistate Indicator element. Enter a 
value to change the width. 

Height Displays the height for the Multistate Indicator element. Enter a 
value to change the height. 

 

3.5.13 Measurement 
 

User can display engineering unit on the screen of the TP series text panel using the 

Measurement element.  
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Follow these steps to add a Measurement element to a screen and edit the 

properties in a general model TP series text panel: 

1. Click the Element(O) > Measurement on the Menu bar, or 

Click the  icon on the Element Selection Toolbar. 

Result: The Measurement element is added to the screen. 

A sample Measurement for general models is shown in the following figure. 

 

 

Figure 3 - 152: Measurement 

 

2. Double-click the Measurement element to edit the properties. 

Result: The Measurement window displays as shown in the following figure. 

The Measurement window has two tabs for the general model TP series text 

panel: 

• Property 

• Coordinates 

The Property tab is the default tab. 
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Figure 3 - 153: Measurement window - Property tab for general model 

 

The Property tab in the Measurement window for the general model TP series text 

panel displays properties as mentioned in the following table: 

 

Function Description 

Measurement 
Type 

Select the measurement type. Options are: 
• Length 
• Square Measure 
• Volume/Solid Measure 
• Weight 
• Speed 
• Time 
• Temperature 
 
NOTE: The default value is Length. 

Measurement 
Units 

Select the measurement units. Options available depends on 
the Measurement Type. 
 
Options available for Length are: 
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Function Description 

 
 
Options available for Square Measure are: 

 
 
Options available for Volume/Solid Measure are: 

 
 
Options available for Weight are: 

 
 
Options available for Speed are: 

 
 
Options available for Time are: 

 
 
Options available for Temperature are: 
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Click the Coordinates tab in the Measurement window of the general model TP 

series text panel to display the contents as shown in the following figure. 

 

 

Figure 3 - 154: Measurement window - Coordinates tab for general model 

 

The Coordinates tab in the Measurement window for the general model TP series 

text panel displays properties as mentioned in the following table: 

 

Function Description 

X Displays the X coordinate for the Measurement element. 
Enter a value to change the X coordinate. 

Y Displays the Y coordinate for the Measurement element. 
Enter a value to change the Y coordinate. 

Width 
Displays the width for the Measurement element. 
 
NOTE: Width is read-only. 

Height 
Displays the height for the Measurement element. 
 
NOTE: Height is read-only. 

 

3. Set the properties as per user’s requirements and click OK Button. 

 



Chapter 3                                                                                                     DIAScreen 

230 
 

3.5.14 Numeric Input 
 

User can write a value to a related device address in the TP series text panel using 

the Numeric Input element. 

 

The Numeric Input element for the general model and TP70P series text panel is 

shown in the following table: 

 

Element General Model TP70P series 

Numeric 
Input   

 

3.5.14.1 Numeric Input Element in General Model TP Series Text Panel: 

 
Follow these steps to add a Numeric Input element to a screen and edit the 

properties in a general model TP series text panel: 

1. Click the Element(O) > Numeric Input on the Menu bar, or 

Click the  icon on the Element Selection Toolbar. 

2. Click the screen and drag the mouse to the required dimensions. 

Result: The Numeric Input element is added to the screen. 

3. Double-click the Numeric Input element to edit the properties. 

Result: The Numeric Input window displays as shown in the following figure. 

The Numeric Input window has two tabs for the general model TP series text 

panel: 

• Property 

• Coordinates 

The Property tab is the default tab. 
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Figure 3 - 155: Numeric Input window - Property tab for general model 

 

The Property tab in the Numeric Input window for the general model TP series text 

panel displays properties as mentioned in the following table: 

 

Function Description 
Refer Device -

Device Address Select the device address to write the value. 

Refer Device – 
Enable Read 

Address 

Select to enable a device register to start reading the value. 
Options are: 
• No 
• Yes 
 
NOTE: The default value is No. 

Refer Device – 
Read Address 

Select the device address to read the value. This field is 
enabled only when the Enable Read Address is set to Yes. 

Enable Function 
Key 

Select whether to enable or disable the function key. 
 
NOTE: The default value is No. 

Function Key 

Select the function key from the drop-down menu. 
 
NOTE: This field is enabled when Enable Function Key is 
set to Yes. 
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Function Description 

Arithmetic 
Select the check box to perform an arithmetic operation on 
the device address. Click  to open the Operation Setting 
dialog box. 

Value Type 

Select the datatype for the variable. Options are: 
• Unsigned 
• Signed 
• Hex 
• BCD 
 
NOTE: The default value is Unsigned. 

Value Length 

Select the bit length. Options are: 
• 16 Bits 
• 32 Bits 
 
NOTE: The default value is 16 Bits. 

Value Setting – 
Integer Digits 

Select the number of integer places. Options are: 
• 1 
• 2 
• 3 
• 4 
• 5 
 
NOTE: The default value is 5. 

Value Setting – 
Fractional Digits 

Select the number of decimal places. Options are: 
• 0 
• 1 
• 2 
• 3 
• 4 
• 5 
 
NOTE: The default value is 0. 

Value Setting - 
Maximum 

Enter the maximum value of the numeric input. 
 
NOTE: The default value is 65535. 

Value Setting – 
Minimum 

Enter the minimum value of the numeric input. 
 
NOTE: The default value is 0. 
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Function Description 

Style – Outline 

Select the border type. Options are: 
• No Border 
• Single Border 
• Double Border 
• Thick Border 
• Dot Border 
• Dotted Line Border 
 
NOTE: The default value is No Border. 

Style – Font 
Setting 

Select the Font Setting. Options are: 
• 5x8 
• 8x8 
• 8x12 
• 8x16 
 
NOTE: The default value is 5x8. 

Style – Horiz. 
alignment 

Select the horizontal alignment. Options are: 
• Align Left 
• Horiz. Centering 
• Align Right 
 
NOTE: The default value is Horiz. Centering. 

Style – Vert. 
alignment 

Select the vertical alignment. Options are: 
• Align Top 
• Vert. Centering 
• Align Bottom 
 
NOTE: The default value is Vert. Centering. 

Notify Setting – 
Enable Notify 

Address 

Select to enable the notify address. Options are: 
• No 
• Yes 
 
NOTE: The default value is No. 

Notify Setting – 
Notify Address 

Select the notify address. 
 
NOTE: This is enabled if Enable Notify Address is set to 
Yes. 
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Function Description 

Notify Setting – 
Before/After 

Writing 

Select to notify before writing or after writing. Options are: 
• Before Writing 
• After Writing 
 
NOTE: This is enabled if Enable Notify Address is set to 
Yes. The default value is Before Writing. 

Notify Setting – 
Reset/Set 

Select to set or reset the variable. Options are: 
• Reset 
• Set 
 
NOTE: This is enabled if Enable Notify Address is set to 
Yes. The default value is Reset. 

User Security 
Level 

Select the user security level. Options are: 
• 0 
• 1 
• 2 
• 3 
• 4 
 
NOTE: The default value is 0. Click  icon to open User-
Level Password Setting window to set the passwords for 
various user levels.For the setting method, refer to 3.7.2 
User-Level Password Setting 

 
Click the Coordinates tab in the Numeric Input window of the general model TP 

series text panel to display the contents as shown in the following figure. 
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Figure 3 - 156: Numeric Input window - Coordinates tab for general model 

 

The Coordinates tab in the Numeric Input window for the general model TP series 

text panel displays properties as mentioned in the following table: 

 

Function Description 

X Displays the X coordinate for the Numeric Input element. Enter 
a value to change the X coordinate. 

Y Displays the Y coordinate for the Numeric Input element. Enter 
a value to change the Y coordinate. 

Width Displays the width for the Numeric Input element. Enter a value 
to change the width. 

Height Displays the height for the Numeric Input element. Enter a value 
to change the height. 

 
4. Set the properties as per user’s requirements and click on OK button. 
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3.5.14.2 Numeric Input Element in TP70P Series Text Panel: 

 
The steps for adding a Numeric Input element in the TP70P series text panel are the 

same as the steps for the general model TP series text panel. Refer 3.5.14.1 

Numeric Input element in general model TP series text panel: for more information. 

 

The Numeric Input window in the TP70P series text panel is shown in the following 

figure. The Numeric Input window has three tabs in the TP70P series text panel: 

• Property 

• Appearance 

• Coordinates 

The Property tab is the default tab. 

 

 

Figure 3 - 157: Numeric Input window – Property tab for TP70P series 

 

The Property tab in the Numeric Input window for the TP70P series text panel 

displays properties as mentioned in the following table: 
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Function Description 
Refer Device -

Device Address Select the device address to write the value. 

Refer Device – 
Enable Read 

Address 

Select to enable a device register to start reading the value. 
Options are: 
• No 
• Yes 
 
NOTE: The default value is No. 

Refer Device – 
Read Address 

Select the device address to read the value. This field is 
enabled only when the Enable Read Address is set to Yes. 

Interlock 
Settings – 

Enable Read 
Address 

Select to enable a device register to start reading the value. 
Options are: 
• No 
• Yes 
 
NOTE: The default value is No. 

Interlock 
Settings – Read 

Address 

Click  button to open the Refer Device window to select the 
interlock for the Numeric Input controls. 
 
NOTE: The Read Address is disabled by default. 

Interlock 
Settings - State 

Select the OFF(0) or ON(1) state of the Read Address in which 
to apply the interlock to the Numeric Input controls. Options 
are: 
• OFF 
• ON 
 
NOTE: The default value is OFF. 

Leading Zeros 
Select to enable or disable leading zeros. 
 
NOTE: The default value is No. 

Value Type 

Select the datatype for the variable. Options are: 
• Unsigned 
• Signed 
• Hex 
• BCD 
• ASCII 
• Binary 
• Float 
 



Chapter 3                                                                                                     DIAScreen 

238 
 

Function Description 
NOTE: The default value is Unsigned. 

Value Length 

Select the bit length. Options are: 
• 16 Bits 
• 32 Bits 
 
NOTE: The default value is 16 Bits. 

User Security 
Level 

Select the user security level. Options are: 
• 0 
• 1 
• 2 
• 3 
• 4 
 
NOTE: The default value is 0. Click on the  button to open 
User-Level Password Setting window to set the passwords for 
various user levels. For the setting method, refer to 3.7.2 User-
Level Password Setting 

Value Setting – 
Integer Digits 

Select the number of integer places. Options are: 
• 1 
• 2 
• 3 
• 4 
• 5 
 
NOTE: The default value is 5. 

Value Setting – 
Fractional Digits 

Select the number of decimal places. Options are: 
• 0 
• 1 
• 2 
• 3 
• 4 
• 5 
 
NOTE: The default value is 0. 

Value Setting - 
Maximum 

Enter the maximum value for the numeric input. 
 
NOTE: The default value is 65535. 



Chapter 3                                                                                                     DIAScreen 

239 
 

Function Description 

Value Setting – 
Minimum 

Enter the minimum value for the numeric input. 
 
NOTE: The default value is 0. 

Notify Setting – 
Enable Notify 

Address 

Select to enable the notify address. Options are: 
• No 
• Yes 
 
NOTE: The default value is No. 

Notify Setting – 
Notify Address 

Select the notify address. 
 
NOTE: This is enabled if Enable Notify Address is set to Yes. 

Notify Setting – 
Before/After 

Writing 

Select to notify before writing or after writing. Options are: 
• Before Writing 
• After Writing 
 
NOTE: This is enabled if Enable Notify Address is set to Yes. 
The default value is Before Writing. 

Notify Setting – 
Reset/Set 

Select to set or reset the variable. Options are: 
• Reset 
• Set 
 
NOTE: This is enabled if Enable Notify Address is set to Yes. 
The default value is Reset. 

 

Click the Appearance tab in the Numeric Input window of the TP70P series text 

panel to display the contents as shown in the following figure. 
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Figure 3 - 158: Numeric Input window - Appearance tab for TP70P series 

 

The Appearance tab in the Numeric Input window for the TP70P series text panel 

displays properties as mentioned in the following table: 

 

Function Description 
Style – Font Select the font type. 
Style – Size Select the font size. 
Style – Bold Select to bold the number. 
Style – Italic Select to italicize the number. 

Style – Horiz. 
alignment 

Select the horizontal alignment. Options are: 
• Align Left 
• Horiz. Centering 
• Align Right 
 
NOTE: The default value is Align Left. 

Style – 
Vert. alignment 

Select the vertical alignment. Options are: 
• Align Top 
• Vert. Centering 
• Align Bottom 
 
NOTE: The default value is Align Top. 
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Function Description 

Style – Enable 
3D Style 

Select to enable or disable 3D style. Options are: 
• Yes 
• No 
 
NOTE: The default value is Yes. 

Style – Border 
Width 

Select the border width. 
 
NOTE: The default value is 5. 

Style – Border 
Color Select the border color. 

Style – Font 
Color Select the font color. 

Style – 
Background 

Color 
Select the background color. 

 

Click the Coordinates tab in the Numeric Input window of the TP70P series text 

panel to display the contents as shown in the following figure. 

 

 

Figure 3 - 159: Numeric Input window – Coordinates tab for TP70P series 
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The Coordinates tab in the Numeric Input window for the TP70P series text panel 

displays properties as mentioned in the following table: 

 

Function Description 

X Displays the X coordinate for the Numeric Input element. Enter 
a value to change the X coordinate. 

Y Displays the Y coordinate for the Numeric Input element. Enter 
a value to change the Y coordinate. 

Width Displays the width for the Numeric Input element. Enter a value 
to change the width. 

Height Displays the height for the Numeric Input element. Enter a value 
to change the height. 

 

3.5.15 Curve 
 

User can represent the values in registers by displaying two curves on the screen of 

a TP series text panel with the Curve element. 

 

Follow these steps to add a Curve element to a screen and edit the properties in a 

general model TP series text panel: 

1. Click the Element(O) > Curve on the Menu bar, or 

Click the  icon on the Element Selection Toolbar. 

2. Click the screen and drag the mouse to the required dimensions. 

Result: The Curve element is added to the screen. 

3. Double-click the Curve element to edit the properties. 

Result: The Curve window displays as shown in the following figure. The 

Curve window has two tabs for general model TP series text panel: 

• Property 

• Coordinates 

The Property tab is the default tab. 
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Figure 3 - 160: Curve window - Property tab for general model 

 

The Property tab in the Curve window for the general TP series text panel displays 

properties as mentioned in the following table: 

 

Function Description 

Device Address Select the device address that user want to display in the 
Curve. 

Vertical Max Enter the maximum value to be read. 
Vertical Min Enter the minimum value to be read. 

Horizontal Max Not available. 
Horizontal Min Not available. 

 

NOTE: If the value in the register is not in the range of the Vertical Min ~ Vertical 
Max values, it will not be represented by a point on the Curve. 

 

The rule of the sampling points: 

Suppose the Device Address is D0. The number of points that are stored depends 

on the value in D0. The maximum number of points that can be sampled is 100. The 
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odd register numbers (D1, D3,…) are in a group, and the even register numbers (D2, 

D4,…) are in another group. Two curves are drawn. 

 

Example: 

D0: Number of points stored 

D1: First point of the first curve 

D2: First point of the second curve 

D3: Second point of the first curve 

D4: Second point of the second curve 

 

The series of values are represented by curves displayed on the screen of a TP 

series text panel. 

 

Click the Coordinates tab in the Curve window of the general model TP series text 

panel to display the contents as shown in the following figure. 

 

 

Figure 3 - 161: Curve window - Coordinates tab for general model 
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The Coordinates tab in the Curve window for the general model TP series text 

panel displays properties as mentioned in the following table: 

 

Function Description 

X Displays the X coordinate for the Curve element. Enter a value to 
change the X coordinate. 

Y Displays the Y coordinate for the Curve element. Enter a value to 
change the Y coordinate. 

Width Displays the width for the Curve element. Enter a value to 
change the width. 

Height Displays the height for the Curve element. Enter a value to 
change the height. 

 

4. Set the properties as per user’s requirements and click on OK button. 

 

3.5.16 X-Y Curve 
 

User can represent the values in registers by an X-Y curve on the screen of a TP 

series text panel with the X-Y Curve element. 

 

Follow these steps to add a X-Y Curve element to a screen and edit the properties in 

a general model TP series text panel: 

1. Click the Element(O) > X-Y Curve in Menu bar, or 

Click the  icon on the Element Selection Toolbar. 

2. Click the screen and drag the mouse to the required dimensions. 

Result: The X-Y Curve element is added to the screen. 

3. Double-click the X-Y Curve element to edit the properties. 

Result: The X-Y Curve window displays as shown in the following figure. The 

X-Y Curve window has two tabs for general model TP series text panel: 

• Property 
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• Coordinates 

The Property tab is displayed by default. 

 

 

Figure 3 - 162: X-Y Curve window - Property tab for general model 

 

The Property tab in the X-Y Curve window for the general model TP series text 

panel displays properties as mentioned in the following table: 

 

Function Description 

Device Address Select the device address in which the number of points to be 
displayed in the Curve has to be stored. 

Vertical Max Enter the maximum value that can be plotted along the vertical 
axis. 

Vertical Min Enter the minimum value that can be plotted along the vertical 
axis. 

Horizontal Max Enter the maximum value that can be plotted along the 
horizontal axis. 

Horizontal Min Enter the minimum values that can be plotted along the 
horizontal axis. 
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NOTE: If the value in the register is not in the range of the Vertical Min ~ Vertical 
Max or in the range of the Horizontal Max ~ Horizontal Min values, it is not 

represented by a point in the X-Y Curve. 

 

The rule of sampling points: 

Suppose the Read Address is D0. The number of points which are stored depends 

on the value in D0. The maximum number of points that can be sampled is 100. D1 

and D2 define the x-coordinate and y-coordinate of the first point, D3 and D4 define 

the x-coordinate and y-coordinate of the second point, and so on. An X-Y Curve is 

drawn. 

D0: Number of points stored 

D1: X-coordinate of the first point on the X-Y Curve 

D2: Y-coordinate of the first point on the X-Y Curve 

D3: X-coordinate of the second point on the X-Y Curve 

D4: Y-coordinate of the second point on the X-Y Curve 

The series of values are represented by an X-Y curve displayed on the screen of a 

TP series text panel. 

 

Click on the Coordinates tab in the X-Y Curve window of the general model TP 

series text panel to display the contents as shown in the following figure. 
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Figure 3 - 163: X-Y Curve window - Coordinates tab for general model 

 

The Coordinates tab in the X-Y Curve window for the general model TP series text 

panel displays properties as mentioned in the following table: 

 

Function Description 

X Displays the X coordinate for the X-Y Curve element. Enter a 
value to change the X coordinate. 

Y Displays the Y coordinate for the X-Y Curve element. Enter a 
value to change the Y coordinate. 

Width Displays the width for the X-Y Curve element. Enter a value to 
change the width. 

Height Displays the height for the X-Y Curve element. Enter a value to 
change the height. 

 

4. Set the properties as per user’s requirements and click on OK button. 
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3.5.17 Alarm 
 

DIAScreen supports three types of Alarm functions for the TP70P series text panels 

as shown in the following figure. 

• Active Alarm List 

• Alarm History Table 

• Alarm Moving Sign 

 

 

Figure 3 - 164: Alarm element 

 

3.5.17.1 Active Alarm List: 

 
An Alarm list must be used with a System Alarm Buzzer as mentioned in section 

3.7.6 System Alarm Buzzer Setting. If an alarm condition is met, the current active 

alarm displays. The Alarms display in the TP70P series text panel with the Active 
Alarm List element. 

 

Follow these steps to add an Active Alarm List to a screen and edit the properties in 

a TP70P series text panel: 
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1. Click the Element(O) > Alarm > Active Alarm List on the Menu bar, or 

Click the  icon on the Element Selection Toolbar. 

2. Click the screen and drag the mouse to the required dimensions. 

Result: The Active Alarm List element is added to the screen. 

A sample Active Alarm List displays as shown in the following figure. 

 

 

Figure 3 - 165: Active Alarm List 

 

3. Double-click the Active Alarm List element to edit the properties 

Result: The Active Alarm List window displays as shown in the following 

figure. 

The Active Alarm List window has two tabs: 

• Property 

• Coordinates 

The Property tab is displayed by default. 
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Figure 3 - 166: Active Alarm List window - Property tab for TP70P series 

 

The Property tab in the Active Alarm List window displays properties as mentioned 

in the following table: 

 

Function Description 

Time Format 

Select the time format. Options are: 
• hh:mm:ss 
• hh:mm 
• ss:hh:mm 
• hh 
 
NOTE: The default value is hh:mm:ss. 

Date Format 

Select the date format. Options are: 
• mm/dd/yyyy 
• dd/mm/yyyy 
• yyyy/mm/dd 
• yyyy/dd/mm 
 
NOTE: The default value is mm/dd/yyyy. 

Display Order – 
Date 

Select to display or hide the Date. 
 
NOTE: The Date is selected by default. 
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Function Description 

Display Order – 
Time 

Select to display or hide the Time 
 
NOTE: The Time is selected by default. 

Display Order – 
Event 

Select to display or hide the Event. 
 
NOTE: Event is selected by default. 

Display Order -
Selection field 

Use the up and down arrows to select the order in which to 
display the Date, Time and Event. 
 
NOTE: Date, Time, Event is the default order. 

Enable 3D Style 

Select to enable or disable the 3D style. Options are: 
• Yes 
• No 
 
NOTE: The default value is Yes. 

Border Width 
Select the border width. 
 
NOTE: The default value is 5. 

Color Settings – 
Border Color 

Select the border color. 

Color Settings – 
Background 

Color 

Select the background color. 

Color Settings – 
Font Color 

Select the font color. 

System Alarm 
Buzzer 

Click to open the System Alarm Buzzer Setting dialog box. 

Text Settings – 
Font Settings - 

Font 

Click Font to open the Font Setting dialog box to set the 
following properties: 
• Font 
• Size 
• Bold 
• Italics  
 
Click on OK to save settings. 

 

Click the Coordinates tab in the Active Alarm List window of the TP70P series text 

panel to display the contents as shown in the following figure. 
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Figure 3 - 167: Active Alarm List window - Coordinates tab for TP70P series 

The Coordinates tab in the Active Alarm List window displays properties as 

mentioned in the following table: 

 

Function Description 

X Displays the X coordinate of the Active Alarm List. Enter a value 
to change the X coordinate. 

Y Displays the Y coordinate of the Active Alarm List. Enter a value 
to change the Y coordinate. 

Width Displays the width of active alarm list. Enter a value to change 
the width. 

Height Displays the height of active alarm list. Enter a value to change 
the height. 

 

4. Set the properties as per user’s requirements and click on OK button. 

 

3.5.17.2 Alarm History Table: 

 
A historical alarm is used with the system alarm buzzer as mentioned in section 

3.7.6 System Alarm Buzzer Setting If the value in the selected device address is set 
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to 1, it clear all the historical records. A historical alarm shows up to a maximum of 

256 records. After 256th record, the next record replaces the very first record shown 

in the historical alarm. User can display historical alarms in a TP70P series text 

panel with the Alarm History Table element. 

 

Follow these steps to add an Alarm History Table to a screen and edit the properties 

in a TP70P series text panel: 

1. Click the Element(O) > Alarm > Alarm History table on Menu bar, or 

Click the  icon on the Element Selection Toolbar. 

2. Click the screen and drag the mouse to the required dimensions. 

Result: The Alarm History Table element is added to the screen. 

A sample Alarm History Table displays as shown in the following figure. 

 

 

Figure 3 - 168: Alarm History Table 

 

3. Double-click the Alarm History Table element to edit the properties. 

Result: The Alarm History Table window displays as shown in the following 

figure. The Alarm History Table window has two tabs: 

• Property 

• Coordinates 

The Property tab is displayed by default. 
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Figure 3 - 169: Alarm History Table window - Property tab for TP70P series 

 

The Property tab in the Alarm History Table window displays properties as 

mentioned in the following table: 

 

Function Description 

Time Format 

Select the time format. Options are: 
• hh:mm:ss 
• hh:mm 
• ss:hh:mm 
• hh 
 
NOTE: The default value is hh:mm:ss. 

Date Format 

Select the date format. Options are: 
• mm/dd/yyyy 
• dd/mm/yyyy 
• yyyy/mm/dd 
• yyyy/dd/mm 
 
NOTE: The default value is mm/dd/yyyy. 

Display Order – 
Date 

Select to display or hide the Date. 
 



Chapter 3                                                                                                     DIAScreen 

256 
 

Function Description 
NOTE: Date is selected by default. 

Display Order – 
Time 

Select to display or hide the Time. 
 
NOTE: Time is selected by default. 

Display Order – 
Event 

Select to display or hide the Event. 
 
NOTE: Event is selected by default. 

Display Order -
Selection field 

Use the up and down arrows to select the order in which to 
display the Date, Time and Event 
 
NOTE: Date, Time, Event is the default order. 

Enable 3D 
Style 

Select to enable or disable the 3D style. Options are: 
• Yes 
• No 
 
NOTE: The default value is Yes. 

Border Width 
Select the border width. 
 
NOTE: The default value is 5. 

Color Settings 
– Border Color Select the border color. 

Color Settings 
– Background 

Color 
Select the background color. 

Color Settings 
– Font Color Select the font color. 

System Alarm 
Buzzer Click to open the System Alarm Buzzer Setting dialog box. 

Text Settings – 
Font Settings - 

Font 

Click Font to open the Font Setting dialog box to can set the 
following properties: 
• Font 
• Size 
• Bold 
• Italics  
 
Click OK to save settings. 

Refer Device – 
Read Address 

Select the variable reference address. If the value in the selected 
device address is 1, clear all historical records.  
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Click the Coordinates tab in the Alarm History Table window of the TP70P series 

text panel to display the contents as shown in the following figure. 

 

Figure 3 - 170: Alarm History Table window - Coordinates tab for TP70P series 

 

The Coordinates tab in the Alarm History Table window displays properties as 

mentioned in the following table: 

 

Function Description 

X Displays the X coordinate of the Alarm History Table element. 
Enter a value to change the X coordinate. 

Y Displays the Y coordinate of the Alarm History Table element. 
Enter a value to change the Y coordinate. 

Width Displays the width of Alarm History Table element. Enter a value 
to change the width. 

Height Displays the height of Alarm History Table element. Enter a 
value to change the height. 

 

4. Set the properties as per user’s requirements and click on OK button. 

 

When system conditions are met, the message in Alarm History Table appears in 

chronological order. Red or green color LEDs display to the left side of the alarm 
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messages. The red color LED is the time the alarm condition is met and the green 

color LED is the time the alarm condition releases. An example of Alarm History 

Table display is shown in the following figure. 

 

 

Figure 3 - 171: Alarm History Table - example 

 

3.5.17.3 Alarm Moving Sign: 
 

A scrolling alarm is used with a system alarm buzzer as mentioned in section 3.7.6 

System Alarm Buzzer Setting. If an alarm condition is met, a scrolling alarm appears 

and the text corresponding to the condition scrolls in the direction set.  User can add 

a scrolling alarm to a TP70P series text panel screen with the Alarm Moving Sign 

element. 

 

Follow these steps to add an Alarm Moving Sign to a screen and edit the properties 

in a TP70P series text panel: 

1. Click the Element(O) > Alarm > Alarm Moving Sign on the Menu bar, or 

Click the  icon on the Element Selection Toolbar. 

2. Click the screen and drag the mouse to the required dimensions. 

Result: The Alarm Moving Sign element is added to the screen. 

A sample Alarm Moving Sign displays as shown in the following figure. 
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Figure 3 - 172: Alarm Moving Sign 

 

3. Double-click the Alarm Moving Sign element. 

Result: The Alarm Moving Sign window displays as shown in the following 

figure. The Alarm Moving Sign window has two tabs:  

• Property 

• Coordinates 

The Property tab displays by default. 

 

 

Figure 3 - 173: Alarm Moving Sign window - Property tab for TP70P series 

 

The Property tab in the Alarm Moving Sign window displays properties as 

mentioned in the following table: 
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Function Description 

Time Format 

Select the time format. Options are: 
• hh:mm:ss 
• hh:mm 
• ss:hh:mm 
• hh 
 
NOTE: The default value is hh:mm:ss. 

Date Format 

Select the date format. Options are: 
• mm/dd/yyyy 
• dd/mm/yyyy 
• yyyy/mm/dd 
• yyyy/dd/mm 
 
NOTE: The default value is mm/dd/yyyy. 

Display Order – 
Date 

Select to display or hide the Date 
 
NOTE: Date is selected by default. 

Display Order – 
Time 

Select to display or hide the Time 
 
NOTE: Time is selected by default. 

Display Order – 
Event 

Select to display or hide the Event 
 
NOTE: The Event is selected by default. 

Display Order -
Selection field 

Use the up and down arrows to select the order in which to 
display of Date, Time and Event. 
 
NOTE: Date, Time, Event is the default order. 

Enable 3D 
Style 

Select to enable or disable the 3D style. Options are: 
• Yes 
• No 
 
NOTE: The default value is Yes. 

Border Width 
Select the border width. 
 
NOTE: The default value is 5. 

Color Settings 
– Border Color Select the border color. 



Chapter 3                                                                                                     DIAScreen 

261 
 

Function Description 
Color Settings 
– Background 

Color 
Select the background color. 

Color Settings 
– Font Color Select the font color. 

System Alarm 
Buzzer Click to open the System Alarm Buzzer Setting window. 

Text Settings – 
Horiz. 

alignment 

Select the horizontal text alignment. Options are: 
• Align Left 
• Horiz. Centering 
• Align Right 
 
NOTE: Horiz. alignment is disabled when Direction is set to 
From Left to Right or From Right to Left. The default value is 
Align Left. 

Text Settings – 
Font Settings - 

Font 

Click on Font to open the Font Setting dialog box to set the 
following properties: 
• Font 
• Size 
• Bold 
• Italics  
 
Click OK to save settings. 

Direction 

Select the alarm text scroll direction. Options are: 
• From Bottom to Top 
• From Top to Bottom 
• From Right to Left 
• From Left to Right 
 
NOTE: The default value is From Bottom to Top. 

Interval(ms) 

Set the time interval in ms for scrolling. Options are: 
• 50 
• 100 
• 200 
• 300 
• 400 
• 500 
• 1000 
• 1500 
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Function Description 
• 2000 
• 2500 
 
NOTE: The default value is 50. 

Points per time Select the moving distance for every move. 
 

Click on the Coordinates tab in the Alarm Moving Sign window of the TP70P 

series text panel to display the contents as shown in the following figure. 

 

 

Figure 3 - 174: Alarm Moving Sign window - Coordinates tab for TP70P series 

 

The Coordinates tab in the Alarm Moving Sign window displays properties as 

mentioned in the following table: 

 

Function Description 

X Displays the X coordinate of the Alarm Moving Sign element. 
Enter a value to change the X coordinate. 

Y Displays the Y coordinate of the Alarm Moving Sign element. 
Enter a value to change the Y coordinate. 
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Function Description 

Width Displays the width of Alarm Moving Sign element. Enter a value 
to change the width. 

Height Displays the height of Alarm Moving Sign element. Enter a 
value to change the height. 

 

4. Set the properties as per user’s requirements and click on OK button. 

 

3.5.17.4 Alarm Enable Function 
 

Remark: This function is only applicable to DOP-100 series and AX-8 series. 

The alarm function has a new enable function. User can click on the enable function 

for individual alarms. If the alarm is not checked, the alarm rule will not be executed 

when it is downloaded into the HMI. 

When using the alarm function, enter the alarm from the project tree.  

The alarm setting is mainly to set the following attributes: 

• monitor address  

• sampling period 

• maximum number of records that can be accessed 

• power-off holding area setting  

• alarm revolving lights related settings  

• output to CSV file 

• and to edit the content of the alarm message to be displayed and other 

related attributes. 
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Figure 3 - 175: Alarm 

 

Features Description 

No. Represents the number of alarm messages, and supports up to 8192 
alarms. 

Enable 
User can enable this alert rule after download. 
NOTE: By default, alarm is disabled. 

Message 
Content 

The user can write the content of the alarm message to be displayed 
in the message content field. User can modify the message content 
directly in the field. Provide "%d1" format string, add the message 
content such as Alarm%d1, but it needs to be used with the monitoring 
address. 
 

Category 

It represents the category to which the alarm number belongs, and has 
the concept of a group. 

• The range of category support is 1 ~ 4095. 
• User can use the batch tool to set the category number quickly. 

 

 

• Steps to set alarm category Settings: 
o Set starting alarm number, example: 1 
o Set ending alarm number, example: 10 
o Set the category ID, example: 5 and click Press Batch 

Setting. Now, the alarm number 1-10 is defined as group 
5. 
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Features Description 
 

 

 

Trigger 
Condition 

Trigger condition settings decides when to raise the Alarm. 
ON: If Trigger Condition is set to ON, (when the bit is 1, Alarm is 
triggered). 
OFF: If Trigger Condition is set to OFF, (when the bit is 0, Alarm is 
triggered) 

Monitor 
Address 

 

The monitor address is used to display customized alarm message 
content. Click   to display watch address setting.Add "%d1" after the 
entered message such as Alarm in the message content field. When 
the value of the monitoring address is 10, the alarm message 
displayed in the historical alarm table is Alarm10. 

Text color The text color is the color of the text displayed in the alarm message. 
The default color is black. 

Alarm 
Screen 

Set the screen needs to display when the alarm triggered, the user can 
select the other screen using drop down list. 
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Features Description 

 

Mail 
The mail data function can send an e-mail to notify the relevant 
personnel at the same time when an alarm occurs. It needs to be used 
with the Options > Configuration > Network Settings > SMTP. 

 

After setting the alarm-related configuration, select the alarm-related component on 

the screen, fill in the content of the message address and uncheck the alarm to 

enable the function. When compiling, the software will skip this item and no error 

message will be generated. As shown in the figure below, the alarms that are also 

enabled will not appear on the display of the alarm element. 

 

 

Figure 3 - 176: Alarm activation related interface 

 

NOTE: For detailed alarm settings, please refer to the DELTA_IA-

HMI_DOPSOFT_UM alarm display chapter 
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3.5.18 Slider 
 

User can write a value to a related device address by moving the indicator on a 

slider displayed on a TP70P series text panel. To add a slider to the screen, use the 

Slider element.  

 

Follow these steps to add a Slider to a screen and edit the properties in a TP70P 

series text panel: 

1. Click on the Element(O) > Slider on the Menu bar, or 

Click the  icon on the Element Selection Toolbar. 

2. Click the screen and drag the mouse to the required dimensions. 

Result: The Slider element is added to the screen. 

A sample Slider displays as shown in the following figure. 

 

 

Figure 3 - 177: Slider 

 

3. Double-click the Slider element to edit the properties. 

Result: The Slider window displays as shown in the following figure. The 

Slider window has three tabs: 

• Property 

• Appearance 

• Coordinates 

The Property tab is displayed by default. 
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Figure 3 - 178: Slider window - Property tab for TP70P series 

 

The Property tab in the Slider window displays properties as mentioned in the 

following table: 

 

Function Description 

Refer Device – 
Write Address 

Click  button to open the Refer Device window to select 
the variable that the Slider value is written to. 

Value Type 

Select the value type. Options are: 
• Unsigned 
• Signed 
• Hex 
• BCD 
 
NOTE: The default value is Unsigned. 

Value Length 

Select the value length. Options are: 
• 16 Bits 
• 32 Bits 
 
NOTE: The default value is 16 Bits. 

Refer Device – 
Interlock Settings 

Select to enable a device register to start reading the value. 
Options are: 
• No 
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Function Description 
– Enable Read 

Address 
• Yes 
 
NOTE: The default value is No. 

Refer Device – 
Interlock Settings 
– Read Address 

Click the  button to open the Refer Device window to 
select the variable that works as an interlock for the Slider 
controls. 
 
NOTE: The Read Address is disabled by default. 

Refer Device – 
Interlock Settings 

– State 

Select the OFF(0) or ON(1) state of the Read Address at 
which interlock is applied to the Slider controls. Options are: 
• OFF 
• ON 
 
NOTE: The default value is OFF. 

Max/Min Value 
Settings – 
Maximum 

Enter the maximum value for the Slider control. 
 
NOTE: The default value is 65535. 

Max/Min Value 
Settings - 
Minimum 

Enter the minimum value for the Slider control 
 
NOTE: The default value is 0. 

 

Click the Appearance tab in the Slider window of the TP70P series text panel to 

display the contents as shown in the following figure. 
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Figure 3 - 179: Slider window - Appearance tab for TP70P series 

 

The Appearance tab in the Slider window displays properties as mentioned in the 

following table: 

 

Function Description 
Color Settings 
– Thumb Color Select the slider thumb (pointer) color. 

Color Settings 
– Track Color Select the slider track color. 

Direction 
Select the Slider direction. 
 
NOTE: The default value is Horizontal. 

 

Click the Coordinates tab in the Slider window of the TP70P series text panel to 

display the contents as shown in the following figure. 
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Figure 3 - 180: Slider window - Coordinates tab for TP70P series 

 

The Coordinates tab in the Slider window displays properties as mentioned in the 

following table: 

 

Function Description 

X Displays the X coordinate for the Slider element. Enter a value 
to change the X coordinate. 

Y Displays the Y coordinate for the Slider element. Enter a value 
to change the Y coordinate. 

Width 
Displays the width for the Slider element.  
Enter a value to change the width. 

Height 
Displays the height for the Slider element.  
Enter a value to change the height. 

 

4. Set the properties as per user’s requirements and click on OK button. 

 
3.5.19 Input List 
 

User can write a value to a related device address by entering a string value on the 

TP70P series text panels with the Input List element.  
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Follow these steps to add an Input List to a screen and edit the properties in a 

TP70P series text panel: 

1. Click the Element(O) > Input List on the Menu bar, or 

Click the  icon on the Element Selection Toolbar. 

2. Click the screen and drag the mouse to the required dimensions. 

Result: The Input List element is added to the screen. 

A sample Input List displays as shown in the following figure. 

 

 

Figure 3 - 181: Input List 

 

3. Double-click the Input List element to edit the properties. 

Result: The Input List window is displayed as shown in the following figure. 

The Input List window has four tabs: 

• Property 

• Appearance 

• Items 

• Coordinates 

The Property tab is displayed by default. 
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Figure 3 - 182: Input List window - Property tab for TP70P series 

 

The Property tab in the Input List window displays properties as mentioned in the 

following table: 

 

Function Description 
Refer 

Device – 
Write 

Address 

Click  button to open the Refer Device window to select the 
variable in which the Input List value is written to. 

Interlock 
Settings – 

Enable 
Read 

Address 

Select to enable a device register to start reading the value. 
Options are: 
• No 
• Yes 
 
NOTE: The default value is No. 

Interlock 
Settings – 

Read 
Address 

Click  button to open the Refer Device window to select the 
variable that works as an interlock for the Input List entry. 
 
NOTE: The Read Address is disable by default. 

Interlock 
Settings - 

State 

Select the OFF(0) or ON(1) state of the Read Address in which the 
interlock is applied to the Input List. Options are: 
• OFF 
• ON 
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Function Description 
NOTE: The default value is OFF. 

Value Type 

Select the datatype for the variable. Options are: 
• Unsigned 
• Signed 
• Hex 
• BCD 
• Float 
 
NOTE: The default value is Unsigned. 

Value 
Length 

Select the bit length. Options are: 
• 16 Bits 
• 32 Bits 
 
NOTE: The default value is 16 Bits. 

Keyboard 
Setting 

Select the language for the keyboard. Options are: 
• English 
• Chinese (Traditional) 
• Chinese (Simplified) 
 
NOTE: The language that is installed with the system is the default 
value. 

 

Click the Appearance tab in the Input List window of the TP70P series text panel to 

display the contents as shown in the following figure. 
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Figure 3 - 183: Input List window - Appearance tab for TP70P series 

 

The Appearance tab in the Input List window displays properties as mentioned in 

the following table: 

 

Function Description 

Enable 3D 
Style 

Select to enable or disable the 3D style. Options are: 
• Yes 
• No 
 
NOTE: The default value is Yes. 

Border Width 
Enter the border width. 
 
NOTE: The default value is 5. 

Border Color Select the border color. 
Font Color Select the font color. 

Background 
Color Select the background color. 

 

Click the Items tab in the Input List window of the TP70P series text panel to 

display the contents as shown in the following figure. 
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Figure 3 - 145: Input List window - Items tab for TP70P series 

 

The Items tab in the Input List window displays properties as mentioned in the 

following table: 

 

Function Description 

Add a row 
Click to add a row to the item list. Enter a value and 
corresponding text that is written to the Write Address when the 
value is entered in the Input List. 

Insert a row Click to insert a row above the selected row. 
Delete a row Click to delete the selected row. 

Clear All Click to delete all records. 
 

Click the Coordinates tab in the Input List window of the TP70P series text panel to 

display the contents as shown in the following figure. 
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Figure 3 - 146: Input List window - Coordinates tab for TP70P series 

 

The Coordinates tab in the Input List window displays properties as mentioned in 

the following table: 

 

Function Description 

X Displays the X coordinate for the Input List element. Enter a value 
to change the X coordinate. 

Y Displays the Y coordinate for the Input List element. Enter a value 
to change the Y coordinate. 

Width Displays the width for the Input List element. Enter a value to 
change the width. 

Height Displays the height for the Input List element. Enter a value to 
change the height. 

 

4. Set the properties as per user’s requirements and click on OK button. 
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3.5.20 ComboBox 
 

User can write a value to a related device address by selecting an item in a combo 

box displayed on the TP70P series text panel. Use the ComboBox element to add a 

combo box to a screen. 

 

Follow these steps to add a ComboBox to a screen and edit the properties in a 

TP70P series text panel: 

1. Click the Element(O) > ComboBox on the Menu bar, or 

Click the  icon on the Element Selection Toolbar. 

2. Click the screen and drag the mouse to the required dimensions. 

Result: The ComboBox element is added to the screen. 

A sample ComboBox displays as shown in the following figure. 

 

 

Figure 3 - 184: ComboBox 

 

3. Double-click on the ComboBox element. 

Result: The ComboBox window displays as shown in the following figure. 

The ComboBox window has four tabs: 

• Property 

• Appearance 

• Items 

• Coordinates 

The Property tab displays by default. 
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Figure 3 - 185: ComboBox window - Property tab for TP70P series 

 

The Property tab in the ComboBox window displays properties as mentioned in the 

following table: 

 

Function Description 

Refer Device – 
Write Address 

Click  button to open the Refer Device window to select the 
variable in which the ComboBox value is written to. 

Interlock 
Settings – 

Enable Read 
Address 

Select to enable a device register to start reading the value. 
Options are: 
• No 
• Yes 
 
NOTE: The default value is No. 

Interlock 
Settings – 

Read Address 

Click  button to open the Refer Device window to select the 
variable that works as an interlock for the ComboBox controls. 
 
NOTE: The Read Address is disable by default. 

Interlock 
Settings - State 

Select the OFF(0) or ON(1) state of the Read Address in which 
the interlock is applied to the ComboBox controls. Options are: 
• OFF 
• ON 
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Function Description 
NOTE: The default value is OFF. 

Value Type 

Select the datatype for the variable. Options are: 
• Unsigned 
• Signed 
• Hex 
• BCD 
• Float 
 
NOTE: The default value is Unsigned. 

Value Length 

Select the bit length. Options are: 
• 16 Bits 
• 32 Bits 
 
NOTE: The default value is 16 Bits. 

 

Click on the Appearance tab in the ComboBox window of the TP70P series text 

panel to display the contents as shown in the figure. 

 

 

Figure 3 - 186: ComboBox window - Appearance tab for TP70P series 
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The Appearance tab in the ComboBox window displays properties as mentioned in 

the following table: 

 

Function Description 

Enable 3D 
Style 

Select to enable or disable the 3D style. Options are: 
• Yes 
• No 
 
NOTE: The default value is Yes. 

Border Width 
Enter the border width. 
 
NOTE: The default value is 5. 

Border Color Select the border color. 
Font Color Select the font color. 

Background 
Color Select the background color. 

 

Click the Items tab in the ComboBox window of the TP70P series text panel to 

display the contents as shown in the following figure. 

 

 

Figure 3 - 187: ComboBox window - Items tab for TP70P series 
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The Items tab in the ComboBox window displays properties as mentioned in the 

following table: 

 

Function Description 

Add a row 
Click to add a row to the Item List. Enter a value and a 
corresponding text that is written to the Write Address when the 
value is selected in the ComboBox. 

Insert a row Click to insert a row above the selected row. 
Delete a row Click to delete a selected row. 

Clear All Click to delete all records. 
 

Click the Coordinates tab in the ComboBox window of the TP70P series text panel 

to display the contents as shown in the following figure. 

 

 

Figure 3 - 188: ComboBox window - Coordinates tab for TP70P series 

 

The Coordinates tab in the ComboBox window displays properties as mentioned in 

the following table: 
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Function Description 

X Displays the X coordinate for the ComboBox element. Enter a value 
to change the X coordinate. 

Y Displays the Y coordinate for the ComboBox element. Enter a value 
to change the Y coordinate. 

Width Displays the width for the ComboBox element. Enter a value to 
change the width. 

Height Displays the height for the ComboBox element. Enter a value to 
change the height. 

 

3.5.21 Delta Products Communication Device Setting 
 

User can set the input parameters in the equipment connected to a TP04G text 

panel in DIAScreen using the Delta Products Communication Device Setting 

feature. 

 

User can launch the Delta Products Communication Device Setting window by 

clicking the  icon on the Element Selection Toolbar. 

 

The Delta Products Communication Device Setting window is shown in the 

following figure. 
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Figure 3 - 189: Delta Products Communication Device Setting window 

 

Select the equipment connected to a TP04G text panel from the Controller drop-

down menu. Enter the equipment address in the Address field and then select the 

communication port connected to the equipment from the TP Com Port drop-down 

menu. The equipment selected in the Controller determines the Parameter Group 

parameters.  

 

After selecting a particular group and a parameter, the Delta Product Communication 

Device Setting window displays whether the parameter is Read or Write, Parameter 
Number, Parameter Address, and Element Type. Click OK to insert the object set 

related to the selected parameter. The corresponding element will be added to the 

screen and the element property window will be displayed in DIAScreen. 
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Figure 3 - 190: Delta Products Communication Device Setting window - 
Numeric Display 

 

 

Figure 3 - 191: Delta Products Communication Device Setting window - Button 
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3.6 Menu Bar - Screen Setting  
 

This section provides the detailed information about the functions available on the 

Screen Setting menu.For more details refer to 2.2.2 Menu bar. The Screen Setting 

menu functions are: 

• Change Screens Condition 

• Function Key Setting 

• Alarm Setting 

• Alarm LED Setting 

• Write Screen ID Setting 

• Hide Screen Setting 

• Screen Macro Setting 

 

Use the Screen Setting functions to configure the screens on a TP series text panel. 

Each individual page on a TP series can be set and therefore the TP series text 

panel can operate conveniently. Some functions are supported only in some models. 

Refer A.3 Screen Setting Menu Items and supported Models for more information. 

 

3.6.1 Change Screens Condition 
 

Use the Change Screens Condition to set the conditions for navigating to a 

particular screen. Once the condition is met, the target screen displays on the TP 

series text panel.  

 

Follow these steps to configure the Change Screens Condition: 

1. Click Screen Setting > Change Screens Condition on the Menu bar, or 

           Click Change Screens Condition on the screen’s context menu. 
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Result: The Change Screens Condition Settings window is shown as in the 

following figure. 

 

 

Figure 3 - 192: Change Screens Condition Settings window 

 

The Change Screens Condition Settings window displays the properties as shown 

in the following table: 

 

Property/Field Description 

Enable Select the check box to enable the Change Screens 
Condition Settings options. 

Refer Device Click  button to open the Refer Device window to select 
the device address. 

Conditional Settings 
– Bit 

Select Bit if the change screen condition is based on an 
ON or OFF condition. Select ON or OFF condition in ON / 
OFF Settings. 

Conditional Settings 
– Value 

Select Value if the change screen condition is based on a 
value. Select the – Value Type, Value Length, 
Conditional operator and Condition in Value Setting. 

Goto Select the screen user want to navigate to. 
ON / OFF Settings - 

ON Select ON condition for ON / OFF settings. 
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Property/Field Description 
ON / OFF Settings - 

OFF Select OFF condition for ON / OFF settings. 

Delete Select a condition on the Condition display area and click 
Delete to remove it. 

Add 
Click to add the condition to the Condition display area. 
 
NOTE: User can set up to 20 conditions. 

Update Select a condition in the Condition display area and click 
Update to modify the condition. 

Close Click to close the Change Screens Condition Settings 
window. 

 

When Value is selected in Conditional Setting field, the Change Screens 
Condition Settings window displays the value properties as shown in the following 

figure. 

 

 

Figure 3 - 193: Change Screens Condition Setting window - Value 
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The Change Screens Condition Settings window displays the Value properties as 

shown in the following table: 

 

Property/Field Description 

Value Type 

Select the value type. Options are: 
• Unsigned 
• Signed 
• Hex 
• BCD 
 
NOTE: The default value is Unsigned. 

Value Length 

Select the value length. Options are: 
• 16 Bits 
• 32 Bits 
 
NOTE: The default value is 16 Bits. 

Conditional operator 

Select the conditional operator. Options are: 
• = 
• > 
• < 
• >= 
• <= 
• != 
 
NOTE: The default value is =. 

Conditional Value Enter the conditional parameter value. 

 
2. Set the properties as per user’s requirements and click Close. 

 

Example 1: 

Change Screens Condition Setting with the Refer Device value M0 = OFF, Goto 

= Screen0 displays on the screen as shown in the following figure. 
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Figure 3 - 194: Change Screens Condition Setting - Example - Bit 

 

Example 2:  

Change Screens Condition Setting with the Refer Device value D0, Value Type = 

Unsigned, Value Length = 16 Bits, Conditional operator = >, Conditional value = 

100, Goto = Screen0 displays on the screen as shown in the following figure. 
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Figure 3 - 195: Change Screens Condition Setting - example - Value 

 

NOTE: Once the Change Screens Condition is set, the Change Screens Condition 

icon on the menu bar and the screen’s context menu displays as shown in the 

following figure. 

 

 

Figure 3 - 196: Change Screens Condition Setting – enabled 
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3.6.2 Function Key Setting 

 
User can set the functions corresponding to function keys on a TP series text panel 

for a screen with the Function Key Setting. When a function key is pressed, it 

enables the function corresponding to the key.  

 

Follow these steps to configure the Function Key Setting: 

1. Click Screen Setting > Function Key Setting on the Menu bar, or 

           Click Function Key Setting on the screen’s context menu. 

Result: The Function Key Setting window displays as shown in the   

following figure. 

 

 

Figure 3 - 197: Function Key Setting window 

 

The Function Key Setting window displays the properties as shown in the following 

table: 
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Property/Field Description 

Enable Select the check box to enable the Function Key 
Setting options. 

Function Key box Select the Function Key to edit the settings. 

Button Type 

Select the button type. Options are: 
• Set to On 
• Set to Off 
• Pulse On 
• Pulse Off 
• Maintained 
• Momentary 
• Multistate 
• Set Value 
• Set Constant 
• Increment 
• Decrement 
• Goto Screen 
• Password Setting 
• Screen Scroll 
• Recipe Write/Read 
 
NOTE: The screen displays the button’s properties to 
the right of this field. 

Write Address Select the device address to write the value. 

Enable Read Address 

Select to enable a device register to start reading the 
value. Options are: 
• No 
• Yes 
 
NOTE: The default value is No. 

Read Address 
Select the device address to read the value. This field 
is enabled only when the Enable Read Address is set 
to Yes. 

Value Type 

Select the value type. Options are: 
• Unsigned 
• Signed 
• Hex 
• BCD 
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Property/Field Description 
NOTE: This field is enabled based on the selected 
Button Type. The default value is Unsigned. 

Value Length 

Select the value length. Options are: 
• 16 Bits 
• 32 Bits 
 
NOTE: This field is enabled based on the selected 
Button Type. The default value is 16 Bits. 

User Permission 

Select the user permission. Options are: 
• 0 
• 1 
• 2 
• 3 
• 4 
 
NOTE: The default value is 0. 

Enable Notify Address 

Select to enable the notify address. Options are: 
• No 
• Yes 
 
NOTE: The default value is No. 

Notify Address 
Select the notify address. 
NOTE: This field is enabled if the Enable Notify 
Address property is set to Yes. 

Before/After Writing 

Select to notify before writing or after writing. Options 
are: 
• Before Writing 
• After Writing 
 
NOTE: This is enabled if Enable Notify Address is 
set to Yes. The default value is Before Writing. 

Reset 

Select to set or reset the variable. Options are: 
• Reset 
• Set 
 
NOTE: This is enabled if Enable Notify Address is 
set to Yes. The default value is Reset. 

Apply Click to apply the changes. 
Clear Settings Click to change settings back to the default values. 
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Property/Field Description 
Close Click to close the Function Key Setting window. 

 

2. Set the properties as per user’s requirements and click on Close button. 
 
NOTE: Once the Function Key Settings is set, the Function Key Setting icon 

on the menu bar and the screen’s context menu displays as shown in the 

following figure. 

 

 

Figure 3 - 198: Function Key Setting - enabled 

 

3.6.3 Alarm Buzzer Setting 

 
User can set the alarm buzzer for a screen with the Alarm Buzzer Setting. If the 

condition is met, the alarm buzzer for the TP series text panel will activates.  

 

Follow these steps to configure Alarm Buzzer Setting: 

1. Click on the Screen Setting > Alarm Buzzer Setting on the Menu bar, or 

           Click Alarm Buzzer Setting on the screen’s context menu. 

Result: The Alarm Buzzer Setting window display as shown in the following 

figure. 
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Figure 3 - 199: Alarm Buzzer Setting window 

 

The Alarm Buzzer Setting window displays the properties as shown in the following 

table: 

 

Property/Field Description 

Enable Click the check box to enable the Alarm Buzzer 
Setting options. 

Refer Device Click  button to open the Refer Device window to 
choose the device address. 

Bit Select Bit if the Alarm Buzzer Condition is based on an 
ON or OFF condition in ON / OFF Settings. 

Value 

Select Value if the Alarm Buzzer Condition is based on 
a value. Select the – Value Type, Value Length, 
Conditional operator and Condition in Value 
Setting. 

ON / OFF Settings – 
OFF 

Select OFF condition for ON / OFF Settings. 
 
NOTE: This field is enabled if the Refer Device is a 
Bit. This field is selected by default. 

ON / OFF Settings - 
ON 

Select ON condition for ON / OFF Settings. 
 
NOTE: This field is enabled if the Refer Device is a 
Bit. 
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Property/Field Description 

Value Type 

Select the value type. Options are: 
• Unsigned 
• Signed 
• Hex 
• BCD 
 
NOTE: This field is enabled only if the Refer Device is 
a Value. The default value is Unsigned. 

Value Length 

Select the value length. Options are: 
• 16 Bits 
• 32 Bits 
 
NOTE: This field is enabled only if the Refer Device is 
a Value. The default value is 16 Bits. 

Condition operator 

Select the conditional operator. Options are: 
• = 
• > 
• < 
• >= 
• <= 
• != 
 
NOTE: This field is enabled only if the Refer Device is 
a Value. The default value is =. 

condition value 

Enter the conditional parameter value. 
 
NOTE: This field is enabled only if the Refer Device is 
a Value. 

OK Click to save the settings and close the Alarm Buzzer 
Setting window. 

Cancel Click to cancel the action and close the window. 
 

2. Set the properties as per user’s requirements and click on OK button. 
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Example: 

 

Alarm Buzzer Setting with Refer Device value D0, Value Type = Unsigned, Value 
Length = 16 Bits, Conditional operator = >, Conditional value = 100 displays on 

the screen as shown in the following figure.  

 

 

Figure 3 - 200: Alarm Buzzer Setting - example 

 

NOTE: Once the Alarm Buzzer Setting is set, the Alarm Settings icon on the menu 

bar and the screen’s context menu displays as shown in the following figure. 

 

 

Figure 3 - 201: Alarm Buzzer Setting - enabled 
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3.6.4 Alarm LED Setting 
 

User can set the Alarm LED on a TP series text panel using the Alarm LED Setting. 

When the condition for the alarm is met, the alarm LED on the TP series text panel 

blinks.  

Follow these steps to configure the Alarm LED Setting: 

1. Click the Screen Setting > Alarm LED Setting on the Menu bar, or 

           Click Alarm LED Setting on the screen’s context menu. 

Result: The Alarm LED Setting window displays as shown in the following 

figure. 

 

 

Figure 3 - 202: Alarm LED Setting window 

 

The Alarm LED Setting window displays the properties as shown in the following 

table: 

 

Property/Field Description 

Enable Select the check box to enable the Alarm LED Setting 
options. 
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Property/Field Description 

Refer Device Click the  button to open the Refer Device window to 
choose the device address. 

Bit Select Bit if the Alarm LED condition is based on an ON or 
OFF condition in ON / OFF Settings. 

Value 
Select Value if the Alarm LED condition is based on a 
value. Select the – Value Type, Value Length, 
Conditional operator and Condition in Value Setting. 

ON / OFF Settings – 
OFF 

Select OFF condition for ON / OFF Settings. 
 
NOTE: This field is enabled only if the Refer Device is a 
Bit. This field is selected by default. 

ON / OFF Settings – 
ON 

Select ON condition for ON / OFF Settings. 
 
NOTE: This field is enabled only if the Refer Device is a 
Bit. 

Value Type 

Select the value type. Options are: 
• Unsigned 
• Signed 
• Hex 
• BCD 
 
NOTE: This field is enabled only if the Refer Device is a 
Value. The default value is Unsigned. 

Value Length 

Select the value length. Options are: 
• 16 Bits 
• 32 Bits 
 
NOTE: This field is enabled only if the Refer Device is a 
Value. The default value is 16 Bits. 

Condition Value 
operator 

Select the conditional operator. Options are: 
• = 
• > 
• < 
• >= 
• <= 
• != 
 
NOTE: This field is enabled only if the Refer Device is a 
Value. The default value is =. 



Chapter 3                                                                                                     DIAScreen 

301 
 

Property/Field Description 

conditional value 

Enter the conditional parameter value. 
 
NOTE: This field is enabled only if the Refer Device is a 
Value. 

OK Click to save the settings and close the Alarm LED Setting 
window. 

Cancel Click to cancel the action and close the window. 
 

2. Set the properties as per user’s requirements and click on OK Button. 

 

Example: 

Alarm LED Setting with Refer Device value D0, Value Type = Unsigned, Value 
Length = 16 Bits, Conditional operator = !=, Conditional value = 100 displays on 

the screen as shown in the following figure. 

 

 

Figure 3 - 203: Alarm LED Setting – example 

 

NOTE: Once the Alarm LED Settings is set, the Alarm LED Settings icon on the 

menu bar and the screen’s context menu displays as shown in the following figure. 
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Figure 3 - 204: Alarm LED Setting - enabled 

 

3.6.5 Write Screen ID Setting 
 

User can write the number assigned to the screen that is opened on a TP series text 

panel using the Write Screen ID Setting. When a screen is open, the screen’s 

number is written to a variable address. 

 

Follow these steps to configure the Write Screen ID Setting: 

1. Click the Screen Setting > Write Screen ID Setting on the Menu bar, or 

           Click Write Screen ID Setting on the screen’s context menu. 

Result: The Write Screen ID Setting window is displayed as shown in the 

following figure. 

 

 

Figure 3 - 205: Write Screen ID Setting window 

 

The Write Screen ID Settings window displays the properties as shown in the 

following table: 
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Property/Field Description 

Enable Select the check box to enable the Write Screen ID Setting 
feature. 

Write Address 
Click the  button to open the Refer Device window to 
select the device address in which the opened screen 
number is written to. 

 

Example: 

Write Screen ID Setting with Write Address = D10 displays as shown in the 

following figure. 

 

 

Figure 3 - 206: Write Screen ID Setting - example 

 

NOTE: Once the Write Screen ID Settings is set, the Write Screen ID Settings icon 

on the menu bar and the screen’s context menu displays as shown in the following 

figure. 

 

 

Figure 3 - 207: Write Screen ID Setting - enabled 

 

3.6.6 Hide Screen Setting 
 

User can display screens on the TP text panel series by pressing the Up or the 

Down key on the panel. User can hide the edited screen using the Hide Screen 
Setting. 
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Follow these steps to configure the Hide Screen Setting: 

1. Click the Screen Setting > Hide Screen Setting on the Menu bar, or 

           Click Hide Screen Setting on the screen’s context menu. 

Result: The screen does not display on the TP series text panel.  

2. Click the Screen Setting > Hide Screen Setting on the Menu bar again, or 

           Click Hide Screen Setting on the screen’s context menu again. 

NOTE: This function switches between hiding or displaying the screen. 

Result: The screen displays in the TP series text panel. 

NOTE: Once the Hide Screen Setting is set, the Hide Screen Setting icon on 

the menu bar displays as shown in the following screen. 

 

 

Figure 3 - 208: Hide Screen Setting - enabled 

 

A screen which is hidden using Hide Screen Setting can be displayed using 

Change Screens Condition Setting. 

 
3.6.7 Screen Macro Setting 
 

User can set a macro for a screen using the Screen Macro Setting. If the macro is 

set for a screen, then the program executes continuously when the screen displays.  

Follow these steps to configure the Screen Macro Setting: 

1. Click the Screen Setting > Screen Macro Setting on the Menu bar, or 

           Click Screen Macro Setting on the screen’s context menu. 

Result: The Screen Macro Setting window displays as shown in the 

following figure. 
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Figure 3 - 209: Screen Macro Setting window 

 

The Screen Macro Setting window displays the properties as shown in the following 

table: 

 

Icon Function Description 

 Open 

The Open function is equivalent to the action of import. 
The software provides *.mrc formats for opening. User can 
import edited macros to reduce the time for repeated 
editing. Click to open a Macro (*.mrc) file. 

 Save 

The Save function is equivalent to the action of export. 
The software can save the macro in *.mrc format only. 
User can save the edited macros for backup or for use of 
other screens. Click to save a Macro file. 

 Update 

Click to update a Macro file. The Update function updates 
the modified macro contents and check the macro syntax 
as well. If user close the macro edit window without 
executing update the software informs user that the macro 
is changed. 
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If update is executed, the current syntax is checked. If 
there are syntax errors, the software shows the following 
message. 

 

 

 

 Cut Operations of Cut, Copy, and Paste are the same as 
those of Office. User can also execute Cut, Copy, and 
Paste with the keyboard shortcuts. 
 
NOTE: cut: Ctrl+X; copy: Ctrl+C; paste: Ctrl+V. 

 Copy 

 Paste 

 
Syntax 
check 

The function of Syntax check is used to make sure that 
macro commands are correct. An error message displays 
if there is a syntax error. 

 
Macro 
Wizard 

The Macro Wizard function provides convenient and easy 
input of macro commands, that are less error-prone than 
manually entering macro commands. 

 
Input 

Address 

User can input the PLC memory address used in the 
macro through the Input Address function preventing any 
entry of wrong address. 
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1. Click on the  icon.  

Result: The Macro Command window is displayed as shown in the following 

figure. 

 

Figure 3 - 210: Macro Command window 

 
The Macro Command window displays the properties as shown in the following 

table: 

 

Icon/Field/Property Description 

Edit – Up Click to move a macro command up.   

Edit – Down Click to move a macro command down. 
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Edit – Update 

Click the Update button to check whether the syntax of 
macro command is correct. If there are syntax errors, 
an error message displays. 
 

 

 

Edit – Insert 
Insert (add) a line of macro command. The new macro 
command is inserted above the selected macro 
command. 

Edit – Delete 

Delete the selected macro command. If there are other 
macro commands below the deleted one, they move 
up automatically. If the cursor has selected a line 
without a macro command, the delete action is invalid. 

Double Word The command is operated with 32 bits if Double Word 
is checked and 16 bits if it is not checked. 

Signed 
The command is operated with signed number if 
Signed is checked and unsigned number if it is not 
checked. 

Command – Arithmetic 

Click to add arithmetic macro command. Options are: 
 

Command Expression NOTE 
ADD Var3 = Var1 + Var2 addition 
SUB Var3 = Var1 - Var2 subtraction 
MUL Var3 = Var1 - Var2 multiplication 
DIV Var3 = Var1 / Var2 division 
MOD Var3 = Var1 % Var2 remainder 

 

Command – 
Logical Operation 

Click to add logical macro command. Options are: 
Command Expression NOTE 
AND Var3 = Var1 & Var2 AND  
OR Var3 = Var1 | Var2 OR 
XOR Var3 = Var1 ^ Var2 XOR 
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NOT Var3 = NOT Var1  NOT 
SHR Var3 = Var1 >> Var2 right shift 
SHL Var3 = Var1 <<Var2 left shift 

 

Command – 
Data Transfer 

Click to add data transfer command. Options are: 
Command Expression 
MOV Var1 -> Var3 
BMOV Var1(Var2 bytes)-> Var3(Var2 bytes) 

 

Command – Compare 
Operation 

Click to add compare operation command. Options 
are: 
 

Command Expression 
IF == IF Var1 == Var2 
IF != IF Var1 != Var2 
IF > IF Var1 > Var2 
IF >= IF Var1 >= Var2 
IF < IF Var1 < Var2 
IF <= IF Var1 <= Var2 
ELSEIF == ELSEIF Var1 ==Var2 
ELSEIF != ELSEIF Var1 !=Var2 
ELSEIF > ELSEIF Var1 >Var2 
ELSEIF >= ELSEIF Var1 >=Var2 
ELSEIF < ELSEIF Var1 <Var2 
ELSEIF <= ELSEIF Var1 <=Var2 
IF AND ==0 IF (Var1 & Var2)== 0 
IF AND !=0 IF (Var1 & Var2)!= 0 
IF ==ON IF Var1 == ON 
IF ==OFF IF Var1 == OFF 
ELSEIF AND ==0 ELSEIF (Var1 & Var2) == 0 
ELSEIF AND != ELSEIF (Var1 & Var2) != 0 
ELSEIF ==ON ELSEIF Var1 == ON 
ELSEIF ==OFF ELSEIF Var1 == OFF 
ELSE ELSE 
ENDIF ENDIF 
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Command – 
Bit Operation 

Click to add bit operation command. Options are: 
• SETB 
• CLRB 
 

Command - Other Click to add other commands. Options are: 
• NOP 
• END 

 

NOTE: Click Command button to select command with input instruction. 

 
3.6.8 Screen Color Setting 
 

User can change the background color of the screen in a TP series text panel using 

the Screen Color Setting.  

 

Follow these steps to configure the Screen Color Setting: 

1. Click on the Screen Setting > Screen Color Setting on the Menu bar, or 

           Click Screen Color Setting on the context menu. 

Result: The Screen Color Setting window displays as shown in the following 

figure. 

 

 

Figure 3 - 211: Screen Color Setting window 

 

2. Click the Screen Color drop-down menu to choose a color. 

Result: The Color window displays as shown in the following figure. 
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Figure 3 - 212: Color window 

3. Select the required color or define a custom color by selecting the RGB 

values. 

4. Click OK button on the Color window to save the color selection. 

5. Click OK button on the Screen Color Setting window. 

Result: The screen’s background color is set. 

 

3.7 Menu Bar - Global Setting 
 

This section provides the detailed information about the functions available on the 

Global Setting menu.For more details refer to 2.2.2 Menu bar The Global Setting 

menu allows user to set the functions for a TP series text panel as a whole. Different 

models support different functions. The Global Setting menu functions are: 

• User-Defined Direction Keys 

• User-Level Password Setting 

• System Parameter Setting 

• System Change Screen Setting 

• System Function Key Setting 

• System Alarm Buzzer Setting 

• System Alarm LED Setting 
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• System RTC Setting 

• System Power ON Setting 

• Global Macro Setting 

• Recipe Setting 

• Default Screen Color Setting 

 
3.7.1 User-Defined Direction Keys 

 
If user set the Hide Screen Setting on a TP series text panel, the hidden screens do 

not display on the text panel. To display the hidden screens, use the User-Defined 
Direction Keys setting. 

 

Follow these steps to configure the User-Defined Direction Keys: 

1. Click the Global Setting > User-Defined Direction Keys on the Menu bar. 

Result: A Confirm window is displayed as shown in the following figure. 

 

 

Figure 3 - 213: Confirm window 

 

2. Click on Yes button to display the hidden screens in the text panel. Select No 

to cancel the action and the screens remain hidden. 

Result: When the User-Defined Direction Keys is activated, a check mark 

appears next to the Global Setting > User-Defined Direction Keys as 

shown in the following figure. 
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Figure 3 - 214: User-Defined Direction Keys – enabled 

 

NOTE: Click User-Defined Direction Keys to toggle between the enabling and 

disabling the function.  

3.7.2 User-Level Password Setting 
 

User can set passwords belonging to different levels with the User-Level Password 
Setting. 

Follow these steps to configure the User-Level Password Setting: 

1. Click on the Global Setting > User-Level Password Setting on the Menu 

bar. 

Result: The User-Level Password Setting window is displayed as shown in 

the following figure. 

 

 

Figure 3 - 215: User-Level Password Setting window 

 

If the User-Level Password is set for an element, the system asks user to type 

the password when user presses the element’s function key. If user type  
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inputs a password of the same user level or a password for a higher user 

level, the element is enabled. Select 0 in a User Level drop down menu to 

disable the user level. The user levels are arranged in ascending order from 1 

to 4. The user level password must include six numerals.  

NOTE: User cannot enter 000000 as a password. 

2. Select a User Level and enter a Password. 

3. Click on OK button to save the settings or Cancel to cancel the action. 

 

3.7.2.1 LUA program password setting 
 

Remark: This function is only applicable to DOP-100 series and AX-8 series. 

 

The user can set the password protection for the LUA program. Each program (Prog) 

can be set with its own password, and the protected program can be opened 

normally after entering the correct password. This password executes the procedure 

to export/import, and the password will not be cleared or changed after 

archiving/opening the old file. 

 

After the user has completed the program, please follow the steps below to set the 

password: 

1. Right-click on the program to protect with password 

Result: Context menu of Program is displayed! 

2. Click Protection on the context menu of the program. 

Result: The Enable Protection pop-up is displayed! 

3. Enter the password user want to set (the maximum characters are limited to 8 

digits, numbers: 0~9, letters are limited to English A~F). 

4. After completing the password setting, the color of the Prog pattern changes 

from blue to red and the protection item shows a check mark. (Please refer to 

Figure 3-192 for this status). 
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Figure 3 - 216: Program setting password protection 

 

Follow the steps to open the protected program (Prog) file: 

1. Double-click on the Protected program (Prog) on left mouse button. 

2. Enter the correct password. 

3. Open the file. 

Result: After entering the correct password, the program is displayed to user. 
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Figure 3 - 217: Open a protected program 

 

Follow the steps to remove the password protection: 

1. Right click on the protected program. 

2. Click Protection on the context menu of the protected program.  

Result: Displays the Enable Protection window, then enter password. 

3. Enter the correct password. 

On inputting a correct password, the color of the Prog pattern changes from 

red to blue, and the protected icon against the item is also removed. (Please 

refer to Figure 3-190 for this status). 
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Figure 3 - 218: Program setting to remove password protection 

 

3.7.3 System Parameter Setting 
 

User can set the system parameters in a TP series text panel using the System 
Parameter Setting.  

 

3.7.3.1 System Parameter Setting for general models except TP04P 
 

This section provides the system parameter settings for TP04G, TP04G-AL-C, 

TP04G-AL2, TP04G-BL-C, TP04G-BL-CU, TP05G and TP08G series of TP text 

panels. 

 

Click the Global Setting > System Parameter Setting on the menu bar. 

Result: The System Parameter Setting window is displayed as shown in the 

following figure. 
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Figure 3 - 219: System Parameter Setting window – general models except 
TP04P 

 

The System Parameter Setting window displays the properties as shown in the 

following table: 

 

Property/Field Description 

Enable Select the check box to enable the Auto Goto 
Screen and Backlight Control. 

Refer Device of auto Goto Click the  button to open the Refer Device window 
to select the variable.  

Refer Device of Backlight 

Displays the address of the device address that 
controls the backlight illumination of a TP series text 
panel.  
 
NOTE: This is a read-only field. Its value = (Refer 
Device of auto Goto +1). 

Read Block 
(PLC => TP) 

Select the checkbox to enable reading data from the 
PLC to the TP. 

PLC Address (Read 
Block) 

Enter the starting PLC address from which the values 
are read to the TP. 
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Property/Field Description 
TP Address 

(Read Block) 
Enter the starting TP address to which the values are 
written to. 

Length 
(Read Block) 

Enter the number device addresses to be read. 

Write Block 
(TP => PLC) 

Select the checkbox to enable writing from the TP to 
the PLC. 

PLC Address 
(Write Block) 

Enter the starting PLC Address to which the values 
are written to. 

TP Address 
(Write Block) 

Enter the starting TP Address from which the values 
are written to the PLC.  

Length 
(Write Block) 

Enter the number of registers to write (length). 

 

After a value is written to the address set in the Refer Device of auto Goto field, the 

screen specified by the value displays. If the register value set in Refer Device of 
auto Goto field is greater than the number of screens in the text panel, the present 

screen displays. After a value is written to the register in the Refer Device of auto 
Goto field, it becomes 0xFFFF whether or not the screen specified by the value 

displays. The register that controls the backlight illuminating the screen of a TP 

series text panel is the device address following the device address set in the Refer 
Device of auto Goto field. By default, its address is (Refer Device of auto Goto+1). 

If the first bit (bit0) in the device address that controls the backlight illuminating the 

screen of a TP series text panel is 1, the backlight will always illuminate the TP 

series text panel screen. If the first bit (bit0) in the device address that controls the 

backlight illuminating the screen of a TP series text panel is 0, the backlight will last 

for a specified time. 

 

After user select the Read Block (PLC => TP) checkbox, user must select a register 

in the PLC Address field, a register in the TP Address field and a value in the 

Length field. When the text panel operates, the value in the N device addresses 

starting from the device address set in the PLC Address field will be written to the N 

device addresses starting from the device address set in the TP Address field, 

where N = value selected in the Length (Read) field. 
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After user select the Write Block (TP > PLC) checkbox, user must select a register 

in the PLC Address field, a register in the TP Address field and a value in the 

Length field. When the text panel operates, the values in the N device addresses 

starting from the device address set in the TP Address field will be written to the N 

device addresses starting from the device address set in the PLC Address field, 

where N = value selected in the Length (Write) field. 

 

3.7.3.2 System Parameter Setting for TP04P and TP70P series: 
 

This section provides the System Parameter Setting for the TP04P and TP70P 

series of TP text panels. 

Click the Global Setting > System Parameter Setting on the Menu bar. 

Result: The System Parameter Setting window displays as shown in the following 

figure. 

 

 

Figure 3 - 220: System Parameter Setting - TP04P and TP70P series 
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The System Parameter Setting window for TP04P and TP70P TP text panels 

displays the properties as shown in the following table: 

 

Property/Field Description 

Enable Select the check box to enable the Auto Goto Screen 
and Backlight Control options. 

Refer Device of auto 
Goto 

Click the  button to open the Refer Device window 
to select the variable.  

Refer Device of Backlight 

Displays the device address that controls the backlight 
illumination of a TP series text panel.  
 
NOTE: This is a read-only field. Its value = (Refer 
Device of auto Goto +1). 

Read Block Address Select the checkbox to enable reading. 
Read Start Address 

(Read Block Address) Enter the starting address (source) of the Read Block. 

Write Start Address 
(Read Block Address) Enter the starting address (target) of the Read Block. 

Length (Read Block 
Address) Enter the number of device addresses to read. 

Write Block Address Select the checkbox to enable writing. 
Write Start Address 

(Write Block Address) Enter the starting address (target) of the Write Block. 

Read Start Address 
(Write Block Address) Enter the starting address (source) of the Write Block. 

Length (Write Block 
Address) Enter the number of device addresses to write. 

 

After a value is written to the device address set in the Refer Device of auto Goto 

field, the screen specified by the value displays. If the device address value in the 

Refer Device of auto Goto field is greater than the number of text panel screens, 

the present screen displays. After a value is written to the device address set in the 

Refer Device of auto Goto field, it will become 0xFFFF whether or not the screen 

indicated by the value displays. The device address that controls the backlight 

illuminating the screen of a TP series text panel is the device address following the 

device address set in the Refer Device of auto Goto field. By default, its address is 
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(Refer Device of auto Goto+1). If the first bit (bit0) in the device address that 

controls the backlight illuminating the screen of a TP series text panel is 1, the 

backlight will always illuminate the TP series text panel screen. If the first bit (bit0) in 

the device address that controls the backlight illuminating the TP series text panel 

screen is 0, the backlight will last for the specified time. 

 

After user select the Read Block Address checkbox, user must select a related 

device address in the Read Start Address field, a related device address in the 

Write Start Address field and a value in the Length field. When the text panel 

operates, the value in the N device addresses starting from the device address set in 

the Read Start Address field will be written to the N device addresses starting from 

the device address set in the Write Start Address field, where N = value selected in 

the Length (Read) field. 

 

After user select the Write Block Address checkbox, user must select a related 

device address in the Write Start Address field, a related device address in the 

Read Start Address field and a value in the Length field. When the text panel 

operates, the value in the N device addresses starting from the device address set in 

the Read Start Address field will be written to the N device addresses starting from 

the device address set in the Write Start Address field, where N = value selected in 

the Length (Read) field. 

 
NOTE: Once the System Parameter Setting is set, the System Parameter Setting 

icon on the menu bar and the screen’s context menu displays as shown in the 

following figure. 

 

 

Figure 3 - 221: System Parameter Setting - enabled 
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3.7.4 System Change Screens Setting 
 

With the Screen Setting > Change Screens Condition Setting, set the conditions 

to go from the current screen to a particular screen. Set the conditions to go to a 

particular screen for all screens with the System Change Screens Setting. 

 

Follow these steps to configure the System Change Screens Setting: 

1. Click the Global Setting > System Change Screens Setting on the Menu 

bar. 

Result: The System Change Screens Setting window is displayed as shown 

in the following figure. 

 

 

Figure 3 - 222: System Change Screens Setting window 

 

NOTE: The properties in the System Change Screens Setting window are the 

same as the properties for the Change Screen Condition Setting. Refer 3.6.1 

Change Screens Condition for more information. 
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If the conditions set in the Change Screen Condition Setting window conflicts with 

the conditions set in the System Change Screen Setting window, the conditions in 

the Change Screen Condition Setting are given preference. 

 

NOTE: User can set up to 20 conditions in the System Change Screen Setting 

window. Once the System Change Screens Setting is set, the System Change 

Screens Setting icon on the menu bar displays as shown in the following figure. 

 

 

Figure 3 - 223: System Change Screens Setting - enabled 

 

3.7.5 System Function Key Setting 
 

With the Screen Setting > Function Key Setting, user set the functions for the 

function keys on a TP series text panel screen. User configure the functions keys for 

all screens with the System Function Key Setting. 

 

Follow these steps to configure the System Function Key Setting: 

1. Click Global Setting > System Function Key Setting on the Menu bar. 

Result: The System Function Key Setting window displays as shown in the 

following figure. 
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Figure 3 - 224: System Function Key Setting window 

 

NOTE: The properties in the System Function Key Setting are the same as the 

Function Key Setting properties. Refer 3.6.2 Function Key Setting for more 

information. 

 

If the functions corresponding to the function keys set in the Function Key Setting 

window conflicts with the functions corresponding to the function key in the System 
Function Key Setting window, the Function Key Settings are given preference. 

 

NOTE: Once the System Function Key Setting is set, the System Function Key 

Setting icon on the menu bar displays as shown in the following figure. 

 

 

Figure 3 - 225: System Function Key Setting - enabled 
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3.7.6 System Alarm Buzzer Setting 

 
With the Screen Setting > Alarm Buzzer Setting, user set the alarm buzzer for a 

TP series text panel screen. User can set the alarm buzzer for all screens with the 

System Alarm Buzzer Setting. 

 

3.7.6.1 System Alarm Buzzer Setting for General Model TP Series Text Panels: 
 

Follow these steps to configure the System Alarm Buzzer Setting for a general 

model TP series text panel: 

1. Click the Global Setting > System Alarm Buzzer Setting on the Menu bar. 

Result: The System Alarm Buzzer Setting window is displayed as shown in 

the following figure. 

 

 

Figure 3 - 226: System Alarm Buzzer Setting window for general models 

 

NOTE: The properties in the System Alarm Buzzer Setting window are the same 

as the properties for the Alarm Buzzer Setting. Refer 3.6.3 Alarm Buzzer Setting for 

more information. 
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If the condition set in the Alarm Buzzer Setting window is different from the 

condition set in the System Alarm Buzzer Setting window, then both conditions can 

be used to trigger the alarm buzzer for the TP series text panel. 

 

3.7.6.2 System Alarm Buzzer Setting for TP70P Series Text Panels: 

 
In the case of TP70P series text panel, user can set up to 20 Alarm conditions in the 

System Alarm Buzzer Setting window. 

 

Follow these steps to configure the System Alarm Buzzer Setting in a TP70P series 

text panel: 

1. Click the Global Setting > System Alarm Buzzer Setting on the Menu bar. 

Result: The System Alarm Buzzer Setting window is displayed as shown in 

the following figure. 

 

 

Figure 3 - 227: System Alarm Buzzer Setting window - TP70P series 
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The System Alarm Buzzer Setting window for TP70P series text panel has the 

additional properties mentioned in the following table: 

 

Property/Field Description 
Text Enter the alarm message user want to display. 

Notify 

Select the check box to write the Alarm value to an 
address. 
 
NOTE: This field is unchecked by default. 

Address field 

Select the notify address. Click the  button to open the 
Refer Device dialog box to select the variable. 
 
NOTE: This field is enabled if the Notify property is 
selected. 

Before Writing 

Select the check box to Notify before writing the alarm 
value. 
 
NOTE: This field is enabled if the Notify check box is 
selected. Before Writing is selected by default. 

After Writing 

Select the check box to Notify after writing the alarm value. 
 
NOTE: This field is enabled if the Notify check box is 
selected. After Writing is not selected by default. 

Reset 

Select the check box to reset the Notify variable. 
 
NOTE: This field is enabled if the Notify check box is 
selected. The Reset is selected by default. 

Set 

Select the check box to configure the Notify variable. 
 
NOTE: This field is enabled if the Notify check box is 
selected. Set is not selected by default. 

Delete Select a condition and click Delete to delete the condition. 
Delete All Click to delete all the conditions. 

Add Click to add a condition. 
Update Select a condition and click Update to edit the condition. 

 

NOTE: Once the System Alarm Buzzer Setting is set, the System Alarm Buzzer 

icon on the menu bar displays as shown in the following figure. 
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Figure 3 - 228: System Alarm Buzzer Setting - enabled 

 

3.7.7 System Alarm LED Setting 
 

With the Screen Setting > Alarm LED Setting, user set the alarm LED on a TP 

series text panel. User can set the alarm LED for all screens with the System Alarm 
LED Setting. 

 

Follow these steps to configure the System Alarm LED Setting: 

1. Click the Global Setting > System Alarm LED Setting on the Menu bar. 

Result: The System Alarm LED Setting window is displayed as shown in the 

following figure. 

 

 

Figure 3 - 229: System Alarm LED Setting window 
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NOTE: The properties in the System Alarm LED Setting are the same as the 

properties for the Alarm LED Setting. Refer 3.6.4 Alarm LED Setting for more 

information. 

 

If the condition set in the Alarm LED Setting window is different from the condition 

set in the System Alarm LED Setting window, then both conditions can be used to 

trigger the alarm LED for the TP series text panel. 

 

NOTE: Once the System Alarm LED Setting is set, the System Alarm LED Settings 

icon on the menu bar is displayed as shown in the following figure. 

 

 

Figure 3 - 230: System Alarm LED Setting - enabled 

 

3.7.8 System RTC Setting 
 

User can write the time, week, and date in a TP series text panel to a device address 

with the System RTC Setting. 

Follow these steps to configure the System RTC Setting: 

1. Click the Global Setting > System RTC Setting on the Menu bar. 

Result: The System RTC Setting window displays as shown in the following 

figure. 

 

Figure 3 - 231: System RTC Setting window 
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The System RTC Setting window displays the properties as shown in the following 

table: 

 

Property/Field Description 
Enable Select the check box to enable the RTC settings. 

Write Address Click the  button to open the Refer Device dialog box to 
select the variable in which the RTC can write to. 

 

Example: 

In the System RTC Setting window, the Write Address D10 is displayed as shown 

in the following figure. 

 

 

Figure 3 - 232: System RTC Setting - example 

 

NOTE: Once the System RTC Setting is set, the System RTC Setting icon on the 

menu bar is displayed as shown in the following figure. 

 

 

Figure 3 - 233: System RTC Setting – enabled 
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3.7.9 System Power ON Setting 
 

User can send a command to a variable address after the system is powered on with 

the System Power ON Setting.  

Follow these steps to configure the System Power ON Setting: 

1. Click the Global Setting > System Power ON Setting on the Menu bar. 

Result: The System Power ON Settings window is displayed as shown in 

the following figure. 

 

 

Figure 3 - 234: System Power ON Settings 

 

The System Power ON Settings window displays the properties as shown in the 

following table: 

 

Property/Field Description 

Enable Select the check box to enable the System Power On 
Settings. 

Refer Device Click the  button to open the Refer Device dialog box to 
select the variable. 
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Property/Field Description 

Bit Select Bit to select the ON or OFF condition in ON / OFF 
Settings. 

Value Select Value to select the – Value Type, Value Length 
and enter the Numeric in Value Settings. 

ON / OFF Settings – 
OFF 

Select OFF condition in the ON / OFF Settings. 
 
NOTE: This field is enabled only if the Bit option is 
selected. The field is ticked by default. 

ON / OFF Settings – 
ON 

Select ON condition in the ON / OFF Settings. 
 
NOTE: This field is enabled only if the Bit option is 
selected. 

Value Type 

Select the value type. Options are: 
• Unsigned 
• Signed 
• Hex 
• BCD 
 
NOTE: This field is enabled only if Value option is selected. 
The default value is Unsigned. 

Value Length 

Select the value length. Options are: 
• 16 Bits 
• 32 Bits 
 
NOTE: This field is enabled only if Value option is selected. 
The default value is 16 Bits. 

Numeric 

Enter the value to write to the variable during system power 
on. 
 
NOTE: This field is enabled only if Value option is selected. 

Time Interval Select the amount of time after the system power on to wait 
to send the Bit/Value command. 

OK Click to save the settings and close the System Power On 
Setting window. 

Cancel Click to cancel the action and close the window. 
 

NOTE: Once the System Power ON Setting is set, the System Power ON Setting 

icon on the menu bar is displayed as shown in the following figure. 
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Figure 3 - 235: System Power ON Setting - enabled 

 

3.7.10 Global Macro Setting 
 

With the Screen Setting > Screen Macro Setting, user can set the macros on a 

screen in the TP series text panel. User can set the macros for all screens with the 

Global Macro Setting. 

Follow these steps to configure the Global Macro Setting: 

1. Click the Global Setting > Global Macro Setting on the Menu bar. 

Result: The Global Macro Setting window displays as shown in the following 

figure. 

 

 

Figure 3 - 236: Global Macro Setting window 

 

NOTE: The properties in the Global Macro Setting window are the same as the 

properties in the Screen Macro Setting window. Refer 3.6.7 Screen Macro Setting 

for more information. 

 



Chapter 3                                                                                                     DIAScreen 

335 
 

If the macro is set in both the Screen Macro Setting window and the Global Macro 
Setting window, then the macro in Screen Macro Setting window executes first.  

 

NOTE: Once the Global Macro Setting is set, the Global Macro Setting icon on the 

menu bar is displayed as shown in the following figure. 

 

 
Figure 3 - 237: Global Macro Setting - Enable 

 

NOTE: The Global Macro Setting is applicable only to the TP05G and TP08G 

series text panels. 

 

3.7.11 Recipe Setting 
 

A recipe is composed of several groups of parameters. Different products 

correspond to different parameters. If a recipe number changes, the parameters to 

which it corresponds to will also change. For example, a bread producer needs 

different proportions of ingredients (such as - sugar, cream, and flour) for different 

breads (such as - toast and cream buns). In a recipe table, the rows represent recipe 

numbers and the columns represent ingredient types. The value selected in the 

Recipe Group (rows) is the number of recipes (the number of bread types), and the 

value selected in the Recipe Length (columns) is the number of ingredient types. 

The number of recipes multiplied by the ingredient types is the number of items in a 

recipe. 

Click the Global Setting > Recipe Setting to open the Recipe Setting window as 

shown in the following figure. 
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Figure 3 - 238: Recipe Setting window 

 

The Recipe Setting window properties are described in the following table: 

 

Property/Field Description 
Enable Select the checkbox to enable recipe settings. 

Recipe Refer 
Device 

Click the  button to open Refer Device dialog box. The 
value in the device address selected indicates a recipe.  
 
Example: A 0 indicates first recipe, 1 indicates second recipe 
and so on. 

Recipe Length 
(columns) 

Enter the number of ingredients. 
 
NOTE: Maximum recipe length is 32. 

Recipe Group 
(rows) 

Enter the number of recipes. 
 
NOTE: Maximum recipe group is 125. 

Create Click to create the recipe table in the Recipe Content area. 
Open Click to open a recipe file (*.rcp). 
Save Click to save the recipe file (*.rcp). 
Reset Click to reset the recipe data to factory settings. 
Clear Click to clear the data set. 
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Property/Field Description 
Export Click to export recipe table file (*.csv). 
Import Click to import recipe table file (*.csv). 

OK Click to save data. 
Cancel Click to cancel the actions. 

 

Here is an example of 3 group of recipe with 3 elements for each as below. 

 

 

Figure 3 - 239: Recipe Content 

 

If user want to read/write a recipe, he/she have to use a button or function key. Refer 

3.7.5 System Function Key Setting, 3.6.2 Function Key Setting and 3.5.10 Button 

sections for more information. Select the Recipe Write/Read from the Button Type 

drop-down menu. If user select the Write option, the Nth recipe in the TP series text 

panel is written to the related device address set. If user select the Read option, then 

the value in the related device address set is written to the Nth recipe in the TP series 

text panel. N is the values in the device address selected in the Refer Device 

section. 
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3.7.12 Default Screen Color Setting 
 

With the Screen Setting > Screen Color Setting, user can set the screen’s 

background color from a screen in TP series text panel. User can set the default 

screen color for all screens with the Default Screen Color Setting. 

 

Follow these steps to configure the Default Screen Color Setting in a TP70P series 

text panel: 

Click the Global Setting > Default Screen Color Setting on the Menu bar. 

Result: The Default Screen Color Setting window is displayed as shown in the 

following figure. 

 

 

Figure 3 - 240: Default Screen Color Setting window 

 

NOTE: The properties for the Default Screen Color Setting are the same as the 

properties for the Screen Color Setting. Refer 3.6.8 Screen Color Setting for more 

information. 

 

NOTE: The Default Screen Color Setting is applicable only to TP70P series text 

panels. 
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3.8 Menu Bar - Communication 
 

This section provides detailed information about the functions available on the 

Communication menu. For more details refer to 2.2.2 Menu bar Communication 

Menu functions are: 

• Upload from TP 

• Download to TP 

• Reset to Factory Setting 

• Download Boot Screen 

• Download Menu to TP 

 

3.8.1 Upload from TP 
 

If user want to edit a TP series text panel project in DIAScreen, upload the project 

from the TP series text panel using the Upload from TP. 

1. Click the Communication > Upload from TP on the Menu bar, or 

Click the  icon on the Communication Toolbar. 

 
3.8.2 Download to TP 
 

After editing a TP series text panel project in DIAScreen, download the project to the 

TP series text panel using Download to TP. 

1. Click the Communication > Download to TP on the Menu bar, or 

Click the  icon on the Communication Toolbar. 
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3.8.3 Reset to Factory Setting 

 
If user want to restore the TP series text panel to its factory settings, use the 

Communication > Reset to Factory Setting. 

 
3.8.4 Download Boot Screen 
 

If user want to download the Boot Screen to the TP series text panel, use 

Communication > Download Boot Screen. 

 
Pre-requisite: 

To download the boot screen to a TP series text panel, user must open the Boot 
Screen. If any other screen is opened, the Download Boot Screen option appears 

grayed out. 

 
Follow these steps to download the Boot Screen to TP series text panel: 

1. Click Communication > Download Boot Screen on the menu bar. 

Result: DIAScreen displays the confirmation message. 

2. If user is using one of the following models, then touch 1. D/L AP TP model 
type <= PC on the screen of the text panel screens: 

• TP02G series text panel 

• TP04G series text panel 

• TP-04G-AL-C series text panel 

• TP04G-AL2 series text panel 

• TP05G series text panel 

• TP08G series text panel 

• VFD-C series keypad 
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Result: WAIT COMM… is displayed on the text panel screen, and a window 

displaying the progress percentage of the Boot Screen download appears in 

the DIAScreen.  

NOTE: If user is using a TP series text panel that is not mentioned in the above list, 

the DIAScreen detects that the firmware in the TP series text panel is old, and 

prompts user to update the firmware. 

 
3.8.5 Download Menu to TP 

 
Follow these steps to download the User Menu to the TP series text panel: 

1. If user want to download the User Menu in DIAScreen to the TP series text 

panel, execute the User Menu Setting 3.1.6 User Menu Setting and then 

click on Communication > Download Menu to TP. 

NOTE: If any other screen is opened, then Download Menu to TP appears 

grayed out.  

2. Touch 1. D/L AP TP model type <= PC on the text panel screen.  

Result: WAIT COMM… is displayed on the text panel screen, and the window 

showing the progress percentage of the User Menu download appears in the 

DIAScreen.  

 

NOTE: If DIAScreen detects that the firmware in the TP series text panel is 

old, it prompts user to update the firmware. 

 

3.9 Menu Bar - Tools  
 

This section provides detailed information about the functions available on the Tools 

menu.For more details refer to 2.2.2 Menu bar Tools menu functions are: 

• Basic Setting 

• Change TP Type 



Chapter 3                                                                                                     DIAScreen 

342 
 

• AutoSave 

• Update System USB Driver 

• Language Setting 

 
3.9.1 Basic Setting 

 
User can configure basic communication settings on the text panel with the Basic 
Setting.  

Follow these steps to configure the Basic Setting in a text panel: 

1. Click on the Tools > Basic Setting on the Menu bar, or 

Click the  icon on the Communication Toolbar. 

Result: The Basic Setting window displays as shown in the following figure. 

 

 

Figure 3 - 241: Basic Setting window – PC < = > TP Communication Protocol 

 

The Basic Setting window supports the following functions:  

• PC<=>TP Communication Protocol 
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• TP<=>PLC Communication Protocol 

• TP Other Settings 

NOTE: The items that can be set vary with the model used.  

 

3.9.1.1 PC<=>TP Communication Protocol: 
 

User can set the communication between a TP series text panel and the computer 

with PC<=>TP Communication Protocol.  

 

The PC<=>TP Communication Protocol tab properties in the Basic Setting 

window are mentioned in the following table: 

 

Property/Field Description 

HMI Station 

Select the HMI station address that is set in the TP series 
text panel. 
 
NOTE: Range is 1 to 255 and the default value is 1. 

PC COM Port Select the communication port of the PC that is connected 
to the TP series text panel 

Baud Rate 

Select the baud rate. 
 
NOTE: Range is 9600 to 115200 and the default value is 
115200. 

 

3.9.1.2 TP<=>PLC Communication Protocol: 

 
User can set the communication between a TP series text panel and the device 

(PLC) connected to the TP series text panel with TP<=>PLC Communication 
Protocol.  

 

Click the TP<=>PLC Communication Protocol in the Basic Setting window. 



Chapter 3                                                                                                     DIAScreen 

344 
 

Result: The TP<=>PLC Communication Protocol tab properties display (except 

TP04P) as shown in the following figure. 

 

 

Figure 3 - 242: Basic Setting window - TP < => PLC Communication Protocol 
(general model except TP04P) 

 

The TP<=>PLC Communication Protocol tab properties in the Basic Setting 

window are described in the following table: 

 

Property/Field Description 

Default COM Port 

Select the Default COM Port check box to select the COM 
port. 
 
NOTE: The Default COM Port is selected by default. 

COM1(RS232) 
Select COM1 Port if the connection is through COM1 port. 
 
NOTE: The COM1(RS232) is selected by default. 

COM2(RS485) Select COM2 Port if the connection is through COM1 port. 
Default PLC Station 
and Station address 

Select the Default PLC Station check box and choose the 
station address. 
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Property/Field Description 
 
NOTE: The Default PLC Station is unchecked by default. 
The station address field is enabled only when Default PLC 
Station is selected. Default PLC Station value is 1. 

Apply Click to save the settings 

Baud Rate 

Select the baud rate for COM port in bits per second. 
Options are: 
• 4800 
• 9600 
• 19200 
• 38400 
• 57600 
• 115200 
 
NOTE: The default value is 9600. 

Data Length 

Select the data length. Options are: 
• 7 
• 8 
 
NOTE: The default value is 7. 

Parity Bits 

Select the parity bits. Options are: 
• None 
• Odd 
• Even 
 
NOTE: The default value is Even. 

Stop Bits 

Select the stop bits. Options are: 
• 1 
• 2 
 
NOTE: The default value is 1. 

OK Click to set the TP<=>PLC Communication Protocol 
settings. 

Cancel Click to cancel the action and close the window. 
 

The TP<=>PLC Communication Protocol tab properties in Basic Settings window 

for the TP04P and TP70P are shown in the following figure. 
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Figure 3 - 243: Basic Setting window - TP < => PLC Communication Protocol 
(TP04P and TP70P series) 

 

The TP<=>PLC Communication Protocol tab properties are mentioned in the 

following table: 

 

Property/Field Description 

Default COM Port 

Select the Default COM Port check box to select the COM 
port. 
 
NOTE: The Default COM Port is selected by default. 

Internal COM Port 

Select if the Internal COM Port is the communication port. 
 
NOTE: This field is enabled only if Default COM Port is 
selected. Internal COM Port is selected by default. 

External COM Port 
COM3 (RS485) 

Select External COM Port if it is the communication port. 
 
NOTE: This field is enabled only if Default COM Port is 
selected. External COM Port COM3(RS485) is not 
selected by default. 

Default PLC Station 
and Station address 

Select Default PLC Station check box and choose the 
station address. 
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Property/Field Description 
NOTE: This field is enabled only if External COM Port 
COM3(RS485) is selected. Station address field is enabled 
only if Default PLC Station is selected. 

Apply Click to save the settings 

COM3 – RS485 – 
Baud Rate 

Select the baud rate for the COM3 port in bits per second. 
Options are: 
• 4800 
• 9600 
• 19200 
• 38400 
• 57600 
• 115200 
 
NOTE: The default value is 9600. 

COM3 – RS485 – 
Data Length 

Select the data length for COM3 port. Options are: 
• 7 
• 8 
 
NOTE: The default value is 7. 

COM3 – RS485 – 
Parity Bits 

Select the parity bits for the COM3 port. Options are: 
• None 
• Odd 
• Even 
 
NOTE: The default value is Even. 

COM3 – RS485 – 
Stop Bits 

Select the stop bits for the COM3 port. Options are: 
• 1 
• 2 
 
NOTE: The default value is 1. 

OK Click to set the TP<=>PLC Communication Protocol 
settings. 

Cancel Click to cancel the action and close the window. 
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3.9.1.3 TP Other Settings: 
 

User can set the hardware properties for the TP series text panel with TP Other 
Settings. 

Click the Tools > Basic Setting to open the Basic Setting window and then click 

the TP Other Settings option. 

Result: The TP Other Settings tab is displayed as shown in the following figure. 

 

 

Figure 3 - 244: Basic Setting window - TP Other Settings 

 

The properties available in TP Other Settings tab are mentioned in the following table: 

 

Property/Field Description 

Default TP Station 
Enter the default TP Station address. 
 
NOTE: Range is 1-255 and the default value is 1. 

Backlight 
Brightness 

Select the backlight brightness in a scale of 0 to 10. 
 
NOTE: The default value is 5. 
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Property/Field Description 

Backlight Time 

Enter the time in minutes in which the backlight has to be 
illuminated. 
 
NOTE: A value of 0 always illuminates the TP series text 
panel screen. 

Enable Buzzer 

Select the check the box to enable or disable the Buzzer. 
 
NOTE: The Enable Buzzer check box is unchecked by 
default. 

Update Firmware 

Select the check box to perform a firmware update. 
 
NOTE: The Update Firmware check box is unchecked and 
appears grayed out by default. 

Synchronize RTC 
with PC 

If user select this check box, the PC time clock downloads to 
the TP series text panel while downloading the project from 
the PC to the TP series text panel. 
 
NOTE: Synchronize RTC with PC check box is selected by 
default 

Enable PLC Core 

Select this check box, to enable the PLC in the TP series text 
panel. Clear the check box to disable the PLC in the TP series 
text panel. System resources are saved and the screens of 
the text panel are updated more rapidly. 
 
NOTE: The Enable PLC Core check box is selected by 
default. 

Enable PLC 
Control COM3 

Select this check box, when the COM3 port is occupied by the 
internal PLC core. Clear the check box if COM3 belongs to TP 
for communication. 
 
NOTE: The Enable PLC Control COM3 check box is 
unchecked by default. 

Upload/Download 
Protection 
Password - 

Enable 

Select this check box to enable Password Protection and 
enter a password during the upload or download. Clear the 
check box to disable the Password Protection feature. 
 
NOTE: The Upload/Download Password Protection is 
unchecked by default. 

Upload/Download 
Protection 

Password - field 

Enter the password for the upload or download protection 
feature. 
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Property/Field Description 

Default Boot 
Screen 

Select this check box to display the default boot screen during 
the boot of the TP series text panel. 
 
NOTE: The Default Boot Screen is checked by default. 

User Defined Select this check box to enable the user defined boot screen 
during the boot of the TP series text panel. 

Boot Screen 
Delay Time 

Enter a delay time to apply to the boot before displaying the 
selected boot screen. 

 

3.9.2 Change TP Type 
 

User can replace the current TP series text panel with another TP series text panel 

as long as the current panel’s screen is smaller than the replacement scree. To 

replace the TP series text panel and configure the keys corresponding to function 

keys, use Change TP Type function. 

 

NOTE: User cannot replace a TP series text panel with a screen that is smaller than 

the current panel’s screen. 

 

Follow these steps to configure the Change TP Type in a text panel: 

1. Click the Tools > Change TP Type on the Menu bar. 

Result: The Change TP Type window is displayed. 

 

Example:  

On a TP02G project in DIAScreen, the Change TP Type window is displayed as 

shown in the following figure. 
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Figure 3 - 245: Change TP Type window 

 

NOTE: The options available in the TP Type field for the TP02G panel are shown in 

the following figure. 

 

 

Figure 3 - 246: Change TP Type - example 

 

2. If user select TP04G-AL to replace the TP02G, a confirmation window is 

displayed. Click Yes. 
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Result: After saving the changes, a confirmation dialog box is displayed as 

shown in the following figure. 

 

 

Figure 3 - 247: Confirmation of keys used 

 

3. Click on Yes button. 

Result: The HMI changes and the project compiles.  

 

3.9.3 AutoSave 
 

User can set a time to save the DIAScreen project file using AutoSave.  

 

Follow these steps to configure the AutoSave in a text panel: 

1. Click the Tools > AutoSave on the menu bar. 

Result: The AutoSave window is displayed as shown in the figure. 

 

 

Figure 3 - 248: Auto Save 
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The AutoSave window displays the properties as shown in the following table: 

 

Property/Field Description 
Enable Select the check box to enable AutoSave settings. 

Saving at 
beginning to 

compile 

Select this option to save the DIAScreen project file every 
time the compile action is performed. 
 
NOTE: The Saving at beginning to compile is enabled by 
default when AutoSave is enabled. 

Saving at intervals 

Select this option to save the project at a specified time 
interval. 
 
NOTE: When user select Saving at intervals, the time 
period field displays where user can set the time period in 
minutes. 

 

3.9.4 Update System USB Driver 
 

In case the USB driver is not installed properly. User can update the USB Driver 

installed in the PC with the Update System USB Driver. 

1. Click the Tools > Update System USB Driver on the Menu bar. 

NOTE: The function is only allowed with administrator user of computer. 

 

 

Figure 3 - 249: Success to proceed 

 

2. Click the OK to proceed to the next step. 
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Figure 3 - 250: Update USB driver 

 

3. Click Next to start installation. After the installation is complete, the below 

message displays. 
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Figure 3 - 251: Update USB driver finish 

 

3.9.5 Language Setting 
 

User can configure to show project functionalities for any supported language with 

Language Setting. 

 

Follow these steps to configure the Language Setting: 

1. Click the Tools > Language Setting on the Menu bar. 

Result: The Language Setting window displays as shown in the following 

figure. 
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Figure 3 - 252: Language Setting window 

 

The following languages are supported by DIAScreen: 

• Traditional Chinese 

• Simplified Chinese 

• English – United States 

2. Select a language from the drop-down menu. 

3. Click OK to apply the changes. 

Result: All the fonts change to the selected language. 

NOTE: DIAScreen will restart application to realize the change. 

 

  

Figure 3 - 253: Ask for restarting DIAScreen 

 

3.9.5.1 System Settings Multi-language Conversion 
 

Remark: This function is applicable to DOP-100 series and AX-8 series. 

For the system setting page of DOP-100 series and AX-8 series during operation, 

the user can set the internal system parameter LANG_OF_SYSMSG address 
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through the numerical input component, and input the number 0~6 of the national 

language system during operation, and then the system language can be changed 

through 

 

0: English (English)  

1: Traditional Chinese 

2: Simplified Chinese  

3: Spanish (Spanish) 

4: French (French) 

5: Russian (Russian)  

6: Turkish (Turkish) 

 

Click the menu Element > Input> Numeric Entry .Create a Numeric entry on 

screen. Double click the Numeric entry on screen. Numeric Entry window opens. 

Click . In the Write address in Memory. Input window opens, set the Link > 

internal parameter. In Device type, select LANG_OF_SYSMSG. 
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Figure 3 - 254: Internal national language system parameters 

 

• After the setting is completed, it can be downloaded to the HMI or viewed by 

online simulation. 

 

 

Figure 3 - 255: Download button 
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Figure 3 - 256: Online simulation button 

 

After entering the screen, change the input value to 2, long press the blank space, 

user can see the system setting page is converted to Simplified Chinese. 

 

 

Figure 3 - 257: Transform the input value 

 

 

Figure 3 - 258: System setting 
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Figure 3 - 259: Simplified Chinese 

 

3.10 Menu Bar - Window 
 

This section provides detailed information about the functions available from the 

Window menu.For more details refer to 2.2.2 Menu bar Window menu functions are: 

• Close Current Window (O) 

• Close All Windows 

• Next Window 

• Previous Window 

• Reset Window Layout 

 
3.10.1 Close Current Window(O) 
 

Close the current window (screen) using one of the following methods: 
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• Click  icon on the title bar of the window (screen) opened or as shown in 

the following figure. 

 

 

Figure 3 - 260: Close Current Window 

 

• Click Window > Close Current Window(O). 

Result: The current window (screen) close. 

NOTE: When no window is open, Close Current Window(O) option appears 

grayed out. 

 

3.10.2 Close All Windows 
 

Close all the screens open in the screen editing area with Close All Windows. 

Click the Windows > Close All Windows on the Menu bar. 

Result: All screens will close. 

NOTE: When no screen is open, Close All Windows option appears grayed out. 

 

3.10.3 Next Window 
 

Switch or navigate to the next open screen in the DIAScreen application with Next 
Window.  

Click the Windows > Next Window on the menu bar. 

Result: A screen with the next higher number displays. 

NOTE: When the screen with highest number is open, Next Window option appears 

grayed out. 
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3.10.4 Previous Window 
 

Switch or navigate to the previous screen in the DIAScreen application with 

Previous Window.  

Click the Windows > Previous Window on the menu bar. 

Result: A screen with the next lower number displays.  

NOTE: When the Boot screen is the current screen, Previous Window option 

appears grayed out.  

 

3.10.5 Reset Window Layout 
 

User can reset the entire screen layout with Reset Window Layout. 

 

Follow these steps to reset the window layout: 

1. Click the Window > Reset Window Layout on the Menu bar. 

Result: The confirmation window appears to confirm the action as shown in 

the following figure. 

 

 

Figure 3 - 261: Reset Window Layout – confirmation 

 

2. Click on Yes button. 

Result: The system prompts user to save the project. 
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3.11 Menu Bar - Help 
 

This section provides detailed information about the functions available from the 

Help menu. Help menu functions are: 

• About 

 

3.11.1 Help > About 
 

The About window provides the information about the software version and the 

supported devices in the current software version.  

Click the Help > About on the Menu bar. 

Result: The About window displays as shown in the following figure. 

 

 

Figure 3 - 262: About window 
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3.11.2 Help > Software Manual 
 

The Software Manual window provides the information about the latest user 

manual. 

 

 

Figure 3 - 263: Software Manual 

 

 
3.12 Menu-Options 
 

Remark: This function is suitable for DOP-100 series and AX-8 series. 

 
3.12.1 Configuration 
 

The Configuration is divided into seven pages: Main, Control Status Block, Real 

Time Clock, Print, Default, Network Settings, and Multi-language. 
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Figure 3 - 264: Configuration 

 

3.12.1.1 General 
 

Features Description 

Name 

• User can change the name of the project yourself, and it will be 
displayed in the project tree on the left. 
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Features Description 

 
 
• When saving, this name will be the default archive name. 
 

 
 

HMI 
interface 

types 
Used to display the current HMI model. 

Clock Macro 
delay time 

Clock macro delay time, the range is 50 ms ~ 65535 ms. This time 
is how long is the interval after the macro is executed every time 
the Clock is executed. 
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Features Description 
Clock 
Macro 
priority 

 

Clock macro priority can be divided into low, medium and high. Set 
the priority of Clock macro execution. The higher the priority, the 
more accurate the clock macro delay time can be. 
 

Background 
macro 
Update 
Cycle 

Set the number of lines executed by the background macro in each 
cycle. The set number of rows range is 1 ~ 512. 

LUA delay 
time 

 

LUA delay time, the range is 0 ~ 10 ms. This time is the interval 
time after each execution of LUA. 

LUA priority 
 

LUA priority can be divided into low, medium and high. Set the 
priority of LUA execution, the higher it can ensure the more 
accurate LUA delay time. 

Project 
Description 

It can be used to describe the purpose and description of this HMI 
screen. After running the software, when user select this file, user 
can see the project description, which makes the purpose of the 
project clearer. 

 
 

 
Non Volatile 
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Features Description 

 
• The storage location of the data to be kept after power failure 

can be divided into three parts according to the category: one is 
alarm; the second is recipe; the third is history buffer. 

• The historical data will be determined according to whether the 
customer has established a historical buffer. 

 

 
 
• If users have used these three parts of data, they can choose 

where they want to store their data. Storage locations include 
HMI, USB Disk, and SD Card. 

• The user can directly click [Storage Location] to set the storage 
location of the power-off retention data in the alarm, formula, 
and history buffer. 
 

External 
storage 

device cache 
write 

Set value 
 

• External storage devices include USB Disk and SD Card. 
 

• The data written by the HMI to the external storage device will 
be temporarily placed in the cache area. However, the external 
storage device cache write setting value is for the amount of 
data in the cache area. If it does not reach this cache write 
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Features Description 
setting value, the data will not actually be written to the external 
storage device. This method can prevent the external storage 
device from being damaged due to continuous writing. 

 
• Assuming that the amount of data that the user expects to 

access is less than the capacity of the buffer or an 
unannounced power failure may cause part of the data to be 
lost, to avoid this situation, the Bit5 external storage device can 
be forced to trigger the general control flag in the control area at 
regular intervals. Fetch and write data to an external storage 
device to ensure the existence of the data. 
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Security Level and Password 

 

 

Figure 3 - 265：Authority and password 

 

Features Description 

Highest security 
password 

The highest authority password is the password with the 
highest HMI authority level, which means level 8. The 
default value of the highest authority password is 
[12345678]. This password is used to control upload screen 
data and formulas, download screen data and formulas 
(user need to check the download password verification 
first), password protection, execute system formatting, 
system file encryption function and copy file function (need 
to check screen update first) Times check). The password 
text format is 
The hexadecimal unit of 0 ~ F. 

Default startup 
security level 

 

• If user want to use the default boot permissions, 
please use it with the user permissions of each 
component attribute. 

• The preset power-on authority is the authority level 
when the HMI is turned on, and the range is level 0 ~ 
7. 
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Features Description 

Check password 
when downloading 

program 
 

• If user check this option, they must download this 
setting to the HMI first, and then execute the second 
download of screen data and formulas, the software 
will ask the user to enter the highest authority 
password. 

 

 
 

• The screen can be downloaded to the HMI normally 
after the password is entered successfully; if the 
password fails to be entered, a warning window will 
pop up to inform the user that the entered password 
is incorrect and the download cannot be performed. 

 

Screen upload 
prohibited 

 

The screen upload prohibition function allows the user to 
download the screen to the HMI, and then upload all the 
data. DIAScreen will display the following message to 
inform the user that the data cannot be uploaded. 

 

Prompt a reminder 
for insufficient 
security level. 

Assuming that the user permissions set by the component 
are higher than the default boot permissions, and the user 
checks this option, the component will display after 
downloading to the HMI 

  The user is prompted that the current permission 
level is insufficient. 

Restrict high 
account function 

Restrict the functions of high-level accounts, do not do any 
operations on low-level accounts 

Complex password  
When this option is activated, the password must contain an 
uppercase letter, lowercase letter, number, symbol (!, $, #, 
%), greater than (including) 8 characters. 
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Features Description 

Limit the times of 
updating screens 

via USB drive 

The screen update frequency check is mainly used for file 
encryption and copying files. Therefore, users can perform 
encryption operations on screen data files, and can set a 
limit on the number of copies to provide customers with a 
safe and flexible file protection mechanism 

Logout when time 
out 

When the user selects this function, the user can return to 
the default boot permission after the number of minutes 
selected by the user. 

Account disabled 
after login failed 

 

After checking, the account will be disabled according to the 
number of failed logins selected by the user. 

Change password 
on first login 

After checking, the HMI will force the user to change the 
password after the user logs in for the first time. 

Account and 
Password 

• The password table setting is mainly used to 
distinguish the permission level of HMI. The 
permission level is divided into 0 ~ 7, a total of eight 
levels, each level has a preset password. The DOP-
100 series HMIs also provide multiple accounts and 
passwords for multiple users to log in at the same 
time. 

NOTE: 
1. The password cannot be blank. 

 
2. In the same permission level, the account name 

cannot be the same, but the password can be the same. 
3. The account names of different permission levels 

can be the same. For example, the account name of 
permission level 0 is 123, and the account name of 
permission level 1 can also be 123. 

4. The length of the account and password is limited to 
24 characters. 

5. The account number and password are not case 
sensitive and will only be displayed in uppercase. 

6.  
o Permission level 0: No protection function, 
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Features Description 
anyone can operate. 

o Permission level 1 ~ 7: User need to enter the 
corresponding password or a higher 
permission level to operate. 

o Permission level 8: the highest permission 
password. Higher than permission level1 ~ 7 
password, and this password is also the 
protection password after project storage, 
download password verification, format 
system files, etc. 

 
• When the user adds the same account in the same 

permission level, the HMI will display the message of 
the duplicate account. 

 

 
• The user can also change the password and account 

content through the button element Set Password 
Table. Or enter the system screen, select [System 
Settings > Password to change the password and 
account content. 

• The account supports Unicode input and combines 
multilingual input components to log in user 
permissions. 

 

Global keypad Settings 

 

Global Keypad Setting provides decimal, hexadecimal, binary and ASCII Keypads 

for users to customize their styles. This function can be applied to multiple numeric 

input or alphanumeric input components on the editing screen. Set the decimal, 

hexadecimal, binary and ASCII keyboard styles through the global Keypad, and then 

execute the application to update the system Keypad. Into a customized format. 

Users don’t need to worry about multiple numeric input on the old screen or the 
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Keypad style in the alphanumeric input cannot be applied. The global Keypad setting 

provides the function of applying to all, replacing the old existing Keypad style with 

the new one. If it is a new component, we also provide the function of applying to the 

new one. This will only apply to the newly created Keypad, so users can apply it 

conveniently and quickly whether it is new or old Update Custom Keypad format. 

 

 

Figure 3 - 266：All-in-one Keypad setting 

 

Features Description 

Decimal 
keypad 

System 
keypad 

The decimal keypad style can be customized. 
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Features Description 
 

 

Apply 
Settings 

Not apply 
Even if the Keypad style is customized, the 
old or new Keypad Will maintain the original 
style of the system Keypad. 

Apply to 
all 

Replace the old Keypad style with the new 
one. 

Apply to 
new 

 

This will only apply to the newly created 
Keypad. 

Binary 
keypad 

System 
Keypad 

Customizable binary Keypad style. 
 

 

Apply 
Settings 

Not apply Even if the Keypad style is customized, the 
old or new Keypad 

Apply to 
all 

Replace the old Keypad style with the new 
one. 

Apply to 
new 

Only apply to newly created Keypads. 

Hexadecimal 
Keypad 

System 
keypad 

The hexadecimal Keypad style can be customized. 
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Features Description 
 

 

Apply 
Settings 

Not apply 

Even if the Keypad style is customized, the 
old or new Keypad 
Will maintain the original style of the system 
Keypad. 

Apply to 
all 

Replace the old Keypad style with the new 
one. 

Apply to 
new 

Only apply to newly created Keypads. 

ASCII 
Keypad 

System 
keypad 

Customizable ASCII Keypad style. 
 

 

 

Apply 
Settings 

Not apply 
Even if the Keypad style is customized, the 
old or new Keypad will maintain the original 
style of the system Keypad. 

Apply to 
all 

Replace the old Keypad style with the new 
one. 
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Features Description 
Apply to 

new 
Only apply to newly created keypads. 

ASCII 
Keypad 

System 
Keypad 

Customizable ASCII Keypad style. 
 

 

Apply 
Settings 

Not apply 
Even if the Keypad style is customized, the 
old or new Keypad will maintain the original 
style of the system Keypad. 

Apply to 
all 

Replace the old Keypad style with the new 
one. 

Apply to 
new 

Only apply to newly created Keypads. 
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Other 

 

 

Figure 3 - 267: Other 

 

Features Description 

Enable Touch 
Cursor 

• The HMI provides the same mouse pointer as the 
Windows system. When the HMI screen is touched, the 
mouse pointer icon will appear. 

• The HMI can support wireless mice with Unifying 
receivers. 

Display initial 
screen at startup 

Check the display initial screen at boot, it means that the HMI 
will display the initial screen every time it is turned on, as 
shown in the figure below. The user can set whether to display 
the initial screen. 
 



Chapter 3                                                                                                     DIAScreen 

379 
 

Features Description 

 

 

USB 
Upload/Download 

AUTO 
• AUTO mode will be based on the HMI USB upload and 

download mode. 
• If the USB upload and download mode is set to AUTO, 

after downloading the project, the operator will maintain 
the currently set USB upload and download mode. If the 
USB is currently downloaded through Disk mode 
(USBCommMode is 1), after downloading the project, 
the HMI will still use Disk mode to download; if the 
current USB is downloaded through CDC mode 
(USBCommMode is 2), after downloading the project, 
the HMI will still Use CDC mode to download. 

• Except for B05S100, B05S101, B07S201, and 
B07S211, the factory default values of other HMI 
models are AUTO. 

DISK 
Disk is equivalent to USBCommMode 1. When set to Disk, 
after downloading to the HMI, user can view a removable 
storage device named DELTA in My Computer. 
 
 

 
 
CDC 
CDC is equivalent to USBCommMode 2. When set to CDC, 
after downloading to the HMI, user can go to My Computer > 
Right-click the content> Device Manager to check whether the 
port has a device named HMI. 
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Features Description 

 

Auto detect 
baud rate 

• After this function is turned on, the baud rate of the HMI 
will be automatically adjusted to be the same as that of 
the PLC. 

 

 

• The condition for adjustment is when the HMI baud rate 
is different from the PLC baud rate. 

Brightness The user can adjust the brightness of the HMI backlight by 
himself. 

TP Delay 

Set the delay time for HMI processing to touch and move 
messages. Set the delay to the right to decrease, which means 
faster speed; set the delay to the left to increase, mean the 
speed becomes slower. 
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Features Description 

TP Force 

Set the force with which the HMI presses the screen. Setting 
the force to the left becomes smaller, which means that the 
HMI recognizes that the trigger force is smaller, so it becomes 
easier to touch; setting the force to the right becomes larger, 
which means it is harder to press. 

Buzzer 
This setting can adjust the sound produced by the HMI 
pressing and the volume of the buzzer. The lower the volume 
is set to the left, the higher the volume is set to the right. 

Animation FPS This setting can adjust the update speed of the animation 
component setting frequency 

Screensaver 
Setup  

The related screen saver settings can only be turned on if user 
check Enable screen saver. 

• After starting the screen saver, just touch the HMI 
screen again to end the screen saver. 

• If user check Enable screen saver and go to Screen> 
Screen Saver, but there is no screen saver to be 
activated, the screen saver will be displayed on the HMI 
in a completely black state. 

• If the screen saver activation is not checked, but the 
screen saver to be activated is edited in Screen> 
Screen Saver, the screen saver will not be activated. 

Enable 
Screensaver 

If user check Enable screen saver, they can set how long the 
HMI screen will not be touched before entering the screen 
saver screen. The time range is 1 ~ 100 min., and the default 
value is 10 min. 

Enable backlight 
saving 

• Tick Backlight Saving, user can set how long the HMI 
screen will not be touched before enabling the Backlight 
Saving function. 

• The time range is 1~10min, and the default is 3min. 
• The time range is 1~10min, and the default is 3min. 

Screensaver 
trigger address 

Set the starting address of word, 0 means to turn off the 
screen saver, 1 to turn on the screen saver. 

After exiting the 
screensaver  

Return to 
original 
screen 

If user check Enable screen saver, they can 
select the screen they want to go to after the 
screen saver ends. Jump to the original screen 
means that after the screen saver screen ends, it 
will jump to the original screen before the screen 
saver is activated. 

Choose 
Screen 

• If user check Enable screen saver, they 
can also choose to go to the designated 
screen number after the screen saver 
ends. The designated screen means that 
the user can specify the screen number 
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Features Description 
by himself, so that after the screen saver 
ends, the user can go to the specified 
screen. 

 
NOTE: If user want to use the specified screen, 
they must create a screen saver screen. 
 

 
 

• The following figure is the flow chart of the 
screen saver: 

 

 

Show disk 
accessing error 

message 

• Since alarms, history buffers and recipes can all be set 
to keep data as USB Disk or SD Card after power 
failure, if the external disk access fails, user can use 
this option to determine whether to display its warning 
message. 

• The so-called disk access failure means that if the 
history buffer has set the power-off retention data 
location to USB Disk, but the HMI cannot detect the 
existence of the USB Disk and cannot write data after 
power-on, this is considered Disk access failed. 
Therefore, if the display disk access failure warning 
message is not checked, when the HMI cannot detect 
the existence of the USB Disk and cannot write data to 
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Features Description 
the USB Disk, no error message will pop up to inform 
the user. 

 
Insufficient 
storage hint 

screen 

The user can specify three storage spaces: HMI, USB DISK, 
and SD when the storage space is lower than the set MB, the 
HMI screen will jump to the specified screen 

 

3.12.1.2 Control Commands 
 

DIAScreen software provides command area and status area functions to execute or 

monitor the execution or status of some system actions. Users can set the memory 

addresses of the command area and status area from Options > Configuration > 

Control Status Block. 

 

 

Figure 3 - 268: Configuration 

 

NOTE: This function is applicable to DOP-100 series and AX-8 series. 
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Control Block 
 

The Control Block page provides the Auto Reset Flags & Data Format 
 setting used in the command area. 

 

• Auto Reset Flags 
If some functions of the command area need to be used repeatedly, user 

must first set this flag to OFF and then trigger again. The flag can be cleared 

through the action to be completed by the HMI to automatically complete the 

flag clearing action. 

• Data Format 
Allows users to customize the numerical format of the command area, 

providing Unsigned Decimal and BCD. 

 

 

Figure 3 - 269: Control Block 
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Control Block 
 

The Control Block of the HMI allows the user to define the address of the controller 

or some register of the HMI. The user can perform HMI control actions by setting the 

command area. 

 

• Use discontinuous addresses in Control Block 
 
If it is not checked, set the address at the starting address, and then check the 

function according to the requirement. The command area will be 

automatically configured with consecutive addresses and only the checked 

control function application will be opened. If user check the use of 

discontinuous addresses in the command area, user can individually set the 

control addresses of each function in the command area. 

 

• Sampling Cycle 
 
The sampling period allows the user to flexibly control the sampling time. The 

default is 300ms, which means that the sampling will be performed every 

300ms. The minimum sampling period is 100ms; the maximum sampling 

period is 1000ms. 
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Figure 3 - 270: Sampling Cycle 

 

The function description of the command area is as follows: 

Screen Number Register 
Bit 0~15 
Screen 
number 

• Write the specified screen number into this register, and 
the HMI will jump to the specified screen. 

• As shown in the figure below, if a value input element is 
set to D0 and the input value is 1, the HMI will switch to 
the first page. 
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General Control Register 

Communication 
enable/disable flag 

 

• Control the HMI re-communication switch. If user 
want to use this communication switch flag, the user 
must go to Options > Communication Settings, 
click Cancel connection after communication is 
interrupted and set the number of retries after 
interruption, as shown in the figure below. 

 

 

 
• When the HMI communicates with the controller, 

when the number of communication interruptions 
reaches the set number of retries after interruption, 
the HMI will automatically close the communication 
with the controller and set this flag to ON. At this time, 
the communication between the HMI and the 
controller will be interrupted and no communication 
error warning window will appear. The user can 
restart the communication between the HMI and the 
controller by setting this flag to OFF. 

• This flag can only be used to resume communication 
when the communication is automatically interrupted, 
and it is not possible to directly close the 
communication between the HMI and any controller 
by setting this flag to ON. If user need to manually 
close or open the communication with the controller, 
user can use the LOCKCOM/UNLOCKCOM macro 
command. 

• This flag is not applicable to clear the flag after the 
action is completed. 
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General Control Register 

Backlight 
enable/disable flag 

 

Enable/disable the HMI backlight. 
• When the flag is ON, the HMI backlight is disabled. 
• When the flag is OFF, the HMI backlight is enabled. 

The Auto Reset Flags function is not applicable to this flag. 

Buzzer  
enable/disable flag 

 

• Enable/disable the HMI buzzer. 
When the flag is ON, the HMI buzzer is enabled. 
When the flag is OFF, the HMI buzzer is disabled. 

• The Auto Reset Flags function is not applicable to this 
flag. 

Bit 3 Alarm buffer 
clear 

Clear the HMI alarm buffer. When the flag is turned ON, the 
HMI clears the alarm buffer. To reactivate the function, user 
must turn the flag OFF and then ON again. 

Bit 4 Alarm counter 
clear 

Clear the HMI Alarm Frequency Table. When the flag is 
turned ON, the data in the Alarm Frequency Table is 
cleared. To reactivate the function again, user must turn the 
flag OFF and then ON again. 

Bit 5 External 
storage device 
cache write flag 

• Update the HMI cache data into a USB Disk or an SD 
Card in real time. If the alarm buffer, history buffer or 
recipe function is activated, and the non-volatile 
storage location is set to a USB Disk or an SD Card, 
when the flag is turned ON, the HMI updates the data 
temporarily stored in the cache into a USB Disk or an 
SD Card in real time. To reactivate the function again, 
user must turn the flag OFF and then ON again. 

 
• The data written into a USB Disk or an SD Card by 

the HMI is temporarily stored in the cache first. Before 
the cache data size reaches the set limit, the data is 
not 
written into a USB Disk or an SD Card. This is to 
keep the USB Disk or SD Card from being damaged 
by frequent overwriting. However, if the data volume 
user are accessing is less than the buffer capacity or 
the power is cut off unexpectedly, part of the data 
may be lost. To keep the data, user can have the flag 
turned ON in a cyclic pattern to write the data into the 
USB Disk or SD Card. 
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General Control Register 

 

 

Bit 6 
Remote control 

lock 

Enable / disable the operation of eRemote. 
• When the flag is ON, eRemote can only be monitored 

rather than be operated. 
• When the flag is OFF, eRemote can be operated 

properly. 
The Auto Reset Flags function is not applicable to this 

flag. 

Bit 8~11 
Set user level 

• The user can change the current HMI user authority 
by triggering the three flags of Bit 8, Bit 9 and Bit 10 
provided by the general control register. There are 
two types of HMI internal permissions, as follows: 

a. Permission 0 ~ Permission 7: Permission 0 
represents the lowest permission 
b. Highest authority: when Bit 11 is 1, it is the 
highest authority 

• The user can use the three flags to set authority 0 ~ 
authority 7. The detailed setting method is as follows. 

 

Permission 
level 

Flag Control 
Bit 10 Bit 9 Bit 8 

Authority 0 0 0 0 
Authority 1 0 0 1 
Authority 2 0 1 0 
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General Control Register 
Authority 3 0 1 1 
Authority 4 1 0 0 
Authority 5 1 0 1 
Authority 6 1 1 0 
Authority 7 1 1 1 

 

 

Curve Control Register 

Bit 0~3 Curve 
sampling flags 

(1 ~ 4) 

• DIAScreen software provides four curve sampling flags. 
The graphs include general graphs and X-Y graphs. The 
graph drawing actions are controlled by the curve 
sampling flag. 

• If this flag is triggered to be ON, the corresponding graph 
component will be sampled and drawn. If user need to use 
this function again, user must first set this flag to OFF and 
then trigger again. 

• The sampling flag 1 of the graph component corresponds 
to the curve sampling flag 1; the sampling flag 2 of the 
graph component corresponds to the curve sampling flag 
2, and so on. 
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Curve Control Register 
 

Bit 8~11 Curve 
clear flag (1 ~ 

4) 

• DIAScreen software provides four curve clear flags. The 
curve graph includes general curve graph and X-Y curve 
graph, and the curve clearing is controlled by the curve 
clearing flag. 

• When this flag is triggered to be ON, the corresponding 
curve graph component will clear the curve on the 
component. If user need to use this function again, user 
must first set this flag to OFF and then trigger again. 

• The sampling flag 1 of the graph component corresponds 
to the curve clear flag 1; the sampling flag 2 of the graph 
component corresponds to the curve clear flag 2, and so 
on. 

 

History Buffer Sampling Register 

Bit 0~11 
Historical buffer 
sampling flag 

(1 ~ 12) 

• Twelve groups of historical buffer data can be recorded, 
each of which corresponds to 12 groups of historical 
buffer sampling flags. The trigger source of the history 
buffer needs to be set to [PLC] to execute the sampling 
action through the history buffer sampling flag in the 
control command area. 

 

 

• The user can determine the sampling timing by triggering 
the sampling flag of the history buffer. When the sampling 
flag of the history buffer is triggered to be ON, a data 
sampling will be performed. If user need to use this 
function again, theymust first set this flag to OFF and then 
trigger again. 

 

History Buffer Clear Registry 

Bit 0~11 
History buffer 

• The user can clear the data in the buffer by triggering the 
clear flag of the history buffer. When the trigger of the 
history buffer clear flag is ON, the buffer is cleared. If user 



Chapter 3                                                                                                     DIAScreen 

392 
 

clear flag (1 ~ 
12) 

need to use this function again, theymust first set this flag 
to OFF and then trigger again. 

 
Recipe Control Register 

Bit 0 
Recipe group 
change flag 

• Use for 16-bit recipe 
• There are two ways for the user to call or change the 

formula group: 
a. Change directly through the internal register 

RCPNO of the HMI. 

 
b. Use this formula group change flag to change. 

• If the user wants to change the HMI formula group 
number through this flag, he must first write the formula 
group he wants to change into the formula group control 
register, and then trigger the formula group change flag. 

• When the recipe group change flag is triggered to be ON, 
the recipe group number will be changed according to the 
value in the recipe group control register and the number 
of the internal register RCPNO will be automatically 
changed. If user need to use this function again, theymust 
first set this flag to OFF and then trigger again. 

Bit 1 Recipe 
read flag 

(PLC→HMI) 

• When the recipe read flag trigger is ON, the HMI will read 
the recipe data in the controller and write it to the 
specified recipe data register. If user need to use this 
function again, they must first set this flag to OFF and 
then trigger again. 

Bit 2 
Recipe write 

flag 
(HMI→PLC) 

• When the recipe writing flag trigger is ON, the HMI will 
write the specified recipe data to the controller register. If 
user need to use this function again, theymust first set this 
flag to OFF and then trigger again. 

Bit 3 Recipe 
group type 
change flag 

• Use for 32-bit formula 
• There are two ways for users to call and change the 

formula group: 
a. Change directly through the internal register 

RCPG of the HMI 
 

 

b. Use this formula group change flag to change. 
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Recipe Control Register 
• When the formula group change flag is triggered to be 

ON, the formula group number will be changed according 
to the value in the changed formula group number (Bit 8 ~ 
Bit 15) and the internal register RCPG number will be 
changed automatically. If user need to use this function 
again, theymust first set this flag to OFF and then trigger 
again. 

Bit 8~15 
Specify the 

number of the 
formula group 
to be changed 

• The user can specify the formula group number to be 
changed through the high byte of the formula control 
register Bit 8 ~ Bit 15, and cooperate with the trigger 
formula group change flag, the HMI will change the 
internal register RCPG The number means to change the 
formula group. 

 
Recipe Group Control Register 

Bit 0~15 
Recipe group 
assignment 

• The user can specify the formula group number to be 
changed through the formula group control register, and 
combined with the trigger formula group change flag, the 
HMI will automatically change the number of the internal 
register RCPNO, which means Change the formula 
group. 

 
System Control Flag register 

Bit 0~7 
Multi-language 

settings 

• Supports 32 languages, and users can switch languages 
by changing more national language settings. To edit the 
language, user can edit the multi-language settings 
through the Options> Configuration > Multi-Language 
Settings, as shown in the figure below: 

 

 

Bit 8 Print flag 

• When the print flag is set to ON, the print action will be 
executed; when the print flag is set to OFF, there is no 
action. 
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System Control Flag register 

 

 

Bit 9 Print form 
feed flag 

• When the print page feed flag is set to ON, the printer 
paper will automatically eject the paper for page change; 
when the print page feed flag is set to OFF, there is no 
action. 
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System Control Flag register 

 
 

Enhanced Recipe Control Register 

Bit 0 Enhanced 
formula group 
change flag 

• Use for enhanced formula 
• There are two ways for the user to call or change the 

enhanced formula group: 
a. Change directly through the HMI internal register 

ENRCPNO 
 

 
 

b. Use this enhanced formula group change flag to 
change. 

• If the user wants to change the HMI enhanced formula 
group number through this flag, he must first write the 
enhanced formula group to be changed into the formula 
group control register, and then trigger the enhanced 
formula group change Flags. 
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Enhanced Recipe Control Register 
• When the enhanced formula group change flag is 

triggered to be ON, the enhanced formula group number 
will be changed according to the value in the enhanced 
formula group control register and the number of the 
internal register ENRCPNO will be automatically 
changed. If user need to use this function again, they 
must first set this flag to OFF and then trigger again. 

Bit 1 Enhanced 
formula reading 
flag (PLC→HMI) 

• When the enhanced recipe read flag trigger is ON, the 
HMI will read the enhanced recipe data in the controller 
and write it into the designated enhanced recipe data 
register. If user need to use this function again, they must 
first set this flag to OFF and then trigger again. 

Bit 2 Enhanced 
formula write 

flag (HMI→PLC) 

• When the enhanced recipe writing flag is ON, the HMI 
will write the specified enhanced recipe data to the 
controller register. If user need to use this function again, 
theymust first set this flag to OFF and then trigger again. 

Bit 3 Enhanced 
formula group 
change flag 

• Use for enhanced formula 
• There are two ways for users to call and change the 

enhanced formula group: 
a. Change directly through the internal register 

ENRCPG of the HMI 
 

 
 

b. Use this enhanced formula group change flag to 
change. 

• When the enhanced formula group change flag is 
triggered to be ON, the enhanced formula group number 
will be changed according to the value in the changed 
enhanced formula group number (b8 ~ b15) and the 
internal temporary storage will be automatically changed 
The number of the ENRCPG. If user need to use this 
function again, theymust first set this flag to OFF and 
then trigger again. 

Bit 8~15 
Specify the 

number of the 
enhanced 

formula group to 
be changed 

• The user can specify the enhanced recipe group number 
to be changed through the high byte of the enhanced 
recipe control register, Bit 8 ~ Bit 15, and trigger the 
enhanced recipe group change flag, the HMI will 
Changing the number of the internal register ENRCPG 
means to change the enhanced formula group. 
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Enhanced Formula Group Control Register 

Bit 0~15 
Enhanced 

formula group 
designation 

 

• The user can specify the enhanced formula group 
number to be changed through the enhanced formula 
group control register, and combined with the trigger 
formula group change flag, the HMI will automatically 
change the internal register ENRCPNO Number, which 
means to change the enhanced formula group. 

 

Status Block 

 

The status Block of the HMI allows the user to specify the address of the controller or 

the internal register of the HMI. Users can view the current HMI action status by 

setting the status area 

 

• Use discontinuous address in Status Block 

If user don’t check it, set the address at the start address, and then check the 

function according to your needs. The status area will automatically be 

configured with consecutive addresses, and only the checked status 

applications will be opened. If user check Use discontinuous addresses in 
Status Block, user can set the status addresses of each function in the status 

area separately. 

 

NOTE:  

1. When the Control Block function is not configured, then the Status Block 
cannot monitor the status. 
 

2. The addresses of Control Block & Status Block must not be identical. 
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Figure 3 - 271: Status Area 

 

Status Block function description is as follows: 

 

General Control Status Register 

Bit 0 Screen 
switching status 

• During screen switching, this flag will be set to ON. 
• After the screen is switched, this flag is set to OFF. 

Bit 3 
Alarm buffer clear 

• When the HMI is clearing the alarm buffer, this flag will 
be set to ON. 

• When the alarm buffer is cleared, this flag is set to 
OFF. 

Bit 4 
Alarm counter 

clear 

• When the HMI is clearing the alarm counter, this flag 
will be set to ON. 

• When the alarm counter is cleared, this flag is set to 
OFF. 

Bit 5 Write to 
external storage 

immediately 

• When the HMI is updating the data in the cache area 
to the USB flash drive or SD card, this flag will be set 
to ON. 

• When the data is written, this flag is set to OFF. 
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General Control Status Register 

Bit 8~11 Set user 
level 

• And BIT 10 can know the user authority level of the 
current HMI operation. 

Permission 
level 

Flag Control 
Bit 10 Bit 9 Bit 8 

Authority 0 0 0 0 
Authority 1 0 0 1 
Authority 2 0 1 0 
Authority 3 0 1 1 
Authority 4 1 0 0 
Authority 5 1 0 1 
Authority 6 1 1 0 
Authority 7 1 1 1 

• The user can know whether it is currently the highest 
authority operation through BIT 11. 

 

Screen Number Status Register 
Bit 0~15 

Screen number 
• The last screen number of the HMI can be queried 

through this status register. 
 

Curve Control Status Register 

Bit 0~3 
Curve sampling 

status flag (1 ~ 4) 

• When the HMI executes data sampling in general 
graph or X-Y graph components, it will set the curve 
sampling state flag corresponding to the graph to ON, 
and the curve sampling state flag will be set to OFF 
after sampling is completed. 

• The sampling flag 1 of the graph component 
corresponds to the curve sampling status flag 1; the 
sampling flag 2 of the graph component corresponds 
to the curve sampling status flag 2, and so on. 
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Curve Control Status Register 

 
 

Bit 8~11 Curve 
clear status flag (1 

~ 4) 

• When the HMI executes the data clearing action in the 
general graph or X-Y graph component, it will set the 
curve clearing status flag corresponding to the graph 
to ON, and the curve clearing status flag will be set to 
OFF after the sampling is completed. 

• The curve clear flag 1 of the curve graph component 
corresponds to the curve clear state flag 1; the curve 
clear flag 2 of the graph component corresponds to 
the curve clear state flag 2, and so on. 

 

History Buffer Sampling Status Register 

Bit 0~11 Historical 
buffer sampling 

status flag (1 ~ 12) 

• When the HMI executes the historical buffer sampling 
action, it will set the historical buffer sampling status 
flag corresponding to the buffer to ON. After the 
sampling is completed, the historical buffer sampling 
status flag will be set to OFF immediately. 

 

History Buffer Clear Status Register 

Bit 0~11 
History buffer clear 
status flag (1 ~ 12) 

• When the HMI executes the historical buffer clearing 
action, it will set the historical buffer clearing status 
flag corresponding to the buffer to ON. After the 
clearing is completed, the historical buffer clearing 
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status flag will be set to OFF immediately. 

 
Recipe Control Status Register 

Bit 0 Recipe group 
change status flag 

• When the control formula group in the command area 
is changed, the formula group change status flag will 
be set to ON. When the HMI change group is 
completed and the RCPNO number is updated, the 
formula group change status flag will be set to OFF. 

Bit 1 Recipe read 
status flag 

• When the HMI reads back 1 set of recipe data from 
the command area, the recipe read status flag will be 
set to ON. When the recipe is read back from the 
command area and storage is complete, the recipe 
read status flag will be set to OFF immediately. 

Bit 2 
Recipe write status 

flag 

• When the HMI sends a group of specified formula data 
to the command area, the formula writing status flag 
will be set to ON, when the formula writing to the 
command area is completed, the formula writing status 
flag will be set to OFF immediately. 

 
Recipe Group Control Status Register 

Bit 0~15 Recipe 
group assignment 

status 

• Regardless of whether the value of the recipe group 
designation register (RCPNO) is changed by the 
command area or the HMI interface, as long as there 
is a change, the recipe group status register will be 
changed to a new value to facilitate the command area 
Get the current formula group number through this 
register. 

• This formula group designated flag should be used in 
conjunction with the formula group change flag. 

 
System Control Flag Status Register 

Bit 0~7 Multi-
language setting 

status value 

• Display the status value corresponding to the current 
language text. 

Bit 8 
Print status flag 

• When the printing status flag is set to ON, the printer 
is printing the screen displayed by the HMI or the 
edited and typeset screen at the time; when the 
printing status flag is set to OFF, the printer has no 
action. 

Bit 9 
Print form feed 

status flag 

• When the print page feed status flag is set to ON, the 
printer is executing automatic paper eject and page 
change; when the print page feed status flag is set to 
OFF, the printer does not act. 
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Enhanced Formula Control Status Register 

Bit 0 Enhanced 
formula group 

change status flag 

• When the control-enhanced formula group in the 
command area is changed, the formula group change 
status flag will be set to ON. When the HMI change 
group is completed and the RCPNO number is 
updated, the formula group change status flag will be 
set immediately OFF. 

Bit 1 Enhanced 
formula reading 

status flag 

• When the HMI reads back 1 set of recipe data from 
the command area, the enhanced recipe read status 
flag will be set to ON. When the enhanced recipe is 
read back from the command area and the storage is 
complete, the enhanced recipe read status flag Then 
set to OFF. 

Bit 2 
Enhanced formula 

write status flag 

• When the HMI sends a group of designated enhanced 
recipe data to the command area, the recipe writing 
status flag will be set to ON. When the enhanced 
recipe writing to the command area is completed, the 
enhanced recipe writing status flag will be set 
immediately Is OFF. 

 
Enhanced Formula Group Control Status Register 

Bit 0~15 
Enhanced formula 
group assignment 

status 

• Whether the value of the enhanced formula group 
designated register (ENRCPNO) is changed by the 
command area or the HMI interface, as long as there 
is a change, the enhanced formula group status 
register will be changed to the new value. Eliminate 
the command area to get the current formula group 
number through this register. 

• This enhanced formula group designated flag should 
be used in conjunction with the enhanced formula 
group change flag. 

 

3.12.1.3 Real Time Clock 
 

Some PLC controllers do not have a built-in RTC clock (Real-time clock), so they 

cannot be used for operations related to time setting, such as daily switch on and off, 

access control management... etc. If the PLC controller has a built-in RTC, the HMI 

provides a synchronization function, allowing the user to synchronize the HMI RTC 

time to the PLC or the PLC RTC time to the HMI. To use the Real Time Clock update 

settings, user must first check Enable RTC Updates. The Real Time Clock update 

setting includes two parts: PLC Link Settings and Time Field Setting. 
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Figure 3 - 272: Real Time Clock 

 

NOTE: 

 

1. If the controller is a PLC product of Delta, there is no need to set additional 

time fields. DIAScreen software will display the time field that cannot be set, 

and set this field as a special register for Delta PLCs RTC  

D1319 ~ D1313. 

 

2. Some old Delta PLC models (ES / SS / EC) do not support RTC update. 
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PLC connection setting 

Enable 
RTC 

Updates 

Check it to enable the RTC update settings. 
 

 

Link 
Name 

User can choose a Link Name arbitrarily, regardless of whether the 
controller belongs to COM1 / COM2 / COM3 or Ethernet. 
 

 

Station 
No. 

User can set the station number of the controller whose time the user 
wants to update. If the selected controller does not support station 
number setting, this option cannot be set. 

Update 

There are two modes for users to choose: 
1. HMI RTC time is set to PLC 
2. PLC RTC Set time to HMI. 
 

 
 

Trigger 
Mode 

There are three trigger modes to choose from:  
1. Timer  
2. Bit On  
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PLC connection setting 
3. Bit Off. 
 

 
 

• If user choose Timer, they can set how often to perform 
automatic update. The minimum is 1 minute; the maximum is 
1440 minutes (1 day), the default value is 60 minutes.  
 

Selecting Bit ON means that when Bit is ON, the update setting is 
triggered. 
 

• If Bit Off is selected, it means that when Bit is OFF, the update 
setting will be triggered. 

• If user choose [Bit On] or [Bit Off], they must additionally set the 
trigger address. The trigger address can be the internal memory 
or the controller register address. 

Time Field Setting 

Start 
Address 

• The register address of the controller for RTC time 
synchronization can be set. 

 

 
 

• If the controller chooses Deltas PLC product, there is no need 
to set the start address. 

Length 

• Users can choose the length according to the number of time 
fields they want to synchronize. The minimum length is 1, the 
maximum is 7. 
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PLC connection setting 

 
 

• If the controller chooses Delta’s PLC product, there is no need 
to set the length. 

Example description 

RTC 

update 

steps 

Step 1: go to [Options] > [RTC Update Settings]. 
Step 2: set the properties associated with RTC update. 

1. Enable RTC Auto Updates. 
2. Select Link name: Link3 (Mitsubishi-FX3U and FX3GA). 
3. Select [PLC RTC set to HMI] for Update setting. 
4. Set Bit On for Trigger Mode. 
5. Set the trigger address to $11.0. 
6. Set Start Address to {Link3}1@D8013. 
7. Set the Length to 6. 
8. Select Second for the Time Field corresponding to 
{Link3}1@D8013. 
9. Select Minute for the Time Field corresponding to 
{Link3}1@D8014. 
10. Select Hour for the Time Field corresponding to 
{Link3}1@D8015. 
11. Select Day for the Time Field corresponding to 
{Link3}1@D8016. 
12. Select Month for the Time Field corresponding to 
{Link3}1@D8017. 
13. Select Year for the Time Field corresponding to 
{Link3}1@D8018. 

Step 3: after setting is complete, click OK to exit the RTC Update 
settings. Please refer to the following figure:  
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PLC connection setting 

 
 

 

Set up 
Alternate 
Maintaine

d 
Button 

element 

Step 1: Create an alternate button and set its write memory address to 
$11.0. 
Step 2: Edit the alternate button State0 text as RTC BIT OFF, and 
State1 text as RTC BIT ON. The foreground color of the component is 
red, which represents the state of being triggered to ON. 
 

 
Create 
value 
Input 

compone
nts 

Step 1: Create 6 numeric input components, and set the addresses as 
{Link3}1@D8013 ~ 
{Link3}1@D8018. 
Step 2: Create 6 more numerical input components, and set the 
internal system parameters in sequence as 
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PLC connection setting 
TIME_YEAR TIME_MONTH TIME_DAY TIME_HOUR TIME_MINUTE 
TIME_SECOND. 
 
PLC Address 

 
 
Internal system parameters 

 

Executio
n Result 

After creating all elements, compile and download to the HMI. When 
the RTC alternate button (BITON) is triggered, the system will set the 
PLC's RTC time to the HMI, so the HMI internal system parameters 
TIME_YEAR, TIME_MONTH, TIME_DAY, TIME_HOUR, 
TIME_MINUTE, and TIME_SECOND will be synchronized with the 
PLC's RTC. 
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PLC connection setting 
Synchron

ize 
PC time 
to HMI 

When checked, the project will be downloaded and the HMI time will 
be synchronized with the PC. 

 

3.12.1.4 Print 
 

 

 
Figure 3 - 273： Print 

 

The print page function setting description is as follows: 

 

Features Description 

Printer 
DOP-100 series models support printers of various brands, including 
HP, EPSON, ZEBRA, Micro Printer, PDF Writer and ePrinter 
printing. 
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Features Description 

 

Paper The paper will vary depending on the selected printer. It can be 
roughly summarized as A4, Letter, Report, Custom and other settings. 

Quality 
• Quality is the resolution of the printer. 
• According to different printers, provide 72, 203 DPI for users to 

choose. 

Margin 

• The user can set the top, bottom, left, and right margins of the 
paper as the reserved area during printing, which means it will 
be blank and not printed. 

• The unit of the boundary range is mm, and the range value is 0 
~ 550 mm. 

Print Size 
The print size can also be set as the zoom ratio of width and height. 
The maximum zoom can be 400%, and the minimum zoom can be 
10%. The default is 100%. 

Interface 

• According to the selected DOP model, provide USB or Ethernet 
transmission interface 

• If user choose ePrinter to print, theyneed to fill in the PC IP 
address and printer port used 85. 

Direction The printing direction can be divided into Vertical printing and 
Horizontal printing. 

Auto Flip 

Auto-feeding means that the printer will automatically eject the paper 
and help the user to switch pages for printing. If checked, when a 
piece of paper is printed, the printer will automatically switch to the 
next paper to continue printing; if it is not checked, when the paper is 
printed, it will be forced to eject the paper, requiring the user to 
manually change the page action. 
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3.12.1.5 Network Settings 

 
Network Settings 

 

 

Figure 3 - 274: Network Settings 

 

The Network Settings page description is as follows: 

Features Description 

HMI 

Users can set their own name; this name can be used to identify 
the HMI. When using remote network monitoring or data 
sampling, the HMI name can be used to quickly identify which 
HMI is being monitored or accessing data. 

Upload 
/Download port 

• The communication port is the designated connection 
address, allowing programs on different computers to 
communicate. There are a total of 65536 ports, and 
some specific ports are reserved for specific programs. 

• The default Upload/Download Port of the HMI is 12346. 

Modbus TCP 
Server Port 

• Modbus TCP Server The default port is 502. 
• This communication port must be the same as that of the 

Modbus TCP/IP controller. 
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Features Description 
• The user can also customize the port number, but please 

make sure that both settings must be the same. 
• If the HMI is communicating with the Modbus software on 

the PC, please change the communication port here 
instead of changing the communication port of the 
controller in [Options]>[Set communication 
parameters]>[Ethernet1]>[Device]. 

Time zone The user can choose the time to display according to the local 
time zone of the HMI. 

Enable NTP 

• After checking, the HMI can adjust the time of the HMI 
through the network. 

• If NTP is enabled, please confirm whether the network 
environment of the HMI is smooth. 

Server Name User can choose the server provided in the software, or can 
enter the name of the local NTP server. 

Calibration 
when startup 

After checking, the time to correct the time is when the HMI is 
turned on. 

Calibration at 
set intervals 

• After checking, user need to set the number of seconds. 
The timing of calibration is when the machine is turned 
on and enters the HMI screen, the time will be adjusted 
in a few seconds. 

• The default is 180 seconds, the minimum is 10 seconds, 
and the maximum is 99999 seconds. 
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Remote Desktop and Data Collection 
 

 
Figure 3 - 275: Remote Desktop Tab 

 
The eServer function of Remote Desktop and Data Collection, description is as 

follows： 

Features Description 

Password 

• The password can be changed according to user needs. 
The default is 12345678. 

• This password is to obtain HMI project data after 
executing eServer and eRemote, user must enter the 
password to monitor or access data. 

Sampling time 
The sampling time is how long the eServer and eRemote will 
perform sampling. The range is 100 ~ 5000ms, the default value 
is 100 ms. 

Port 

The connection port between eServer and eRemote is set to 
12348. It is a different communication port from the 
upload/download port of the HMI, and the port used by different 
programs will be different. 
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Features Description 

Show warning  
when 

disconnected 

• This option can be enabled after checking Start. 
• When the HMI is disconnected from the eServer or 

eRemote, the HMI will display a disconnected warning 
message. 

Close warning 
window when 
the connection 

is restored 

• This option can only be enabled when the option of Show 
disconnection warning window when disconnected is 
checked. 

• If it is checked, the representative will keep popping out 
the error and will not close the error window until the HMI 
and eServer or eRemote are connected again. 

• If it is not checked, it means that the HMI will only pop up 
a disconnected error message. 

 
The VNC (Virtual Network Computing) function of the remote desktop page is a set 

of software that can remotely monitor and operate HMIs. This software can send 

Keypad and mouse actions and real-time screens through the Internet. When using 

the webpage to operate VNC, the browser must support JAVA installation, otherwise 

it cannot be opened. When using the webpage to operate VNC, the browser must 

support JAVA installation, otherwise it cannot be opened. The VNC function setting 

description is as follows： 

 

Features Description 

Enable Check Enable to remotely monitor and operate the HMI  through 
VNC. 

Password The password can be changed according to user needs. The default 
is 12345678. 

Port 

• The default connection port is 5900. If the software 
connection port setting is changed to 5902, when using VNC 
Viewer to connect, the connection port must be changed to 
5902. 

 
• Do not use 5800 when setting the connection port on the 

software side. If it is set to 5800, the following message will 
appear after downloading the screen to the HMI to inform the 
user to replace. 
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Features Description 

 

 
• VNC Viewer provides a webpage operation method. In this 

way, user only need to enter the browsers IP Address and 
the port is 5800 to open the connection. Even if the 
communication port of the software is not the default 5900, 
during browser operation, please enter 5800 for the 
connection port. Such as http://192.168.123.148:5800. 

 

Real-time Monitoring 

 

 
Figure 3 - 276: Real-time monitoring tab 
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• Network real-time monitoring provides that the HMI can write values to the 

HMI on the web side, or after the HMI writes the values, the web-side 

monitors the changes. 

 
• The real-time monitoring interface provides a variety of Data formats for users 

to use. The supported data formats include BCD, Signed Decimal, Unsigned 

Decimal, Hex, Floating, Char. 

 
• Each data format can be set to read length to determine whether to read 

Word or Double Word. When the read length is 1, the integer can be set up to 

5 digits, that means the data format is Word. When the read length is 2, the 

integer can be set up to 10 digits, that means the data format is Double Word. 

 
• Address input provides Word and Bit, which can support internal memory 

address and external PLC address. 

 
 

How to use network real-time monitoring?  
 
Check Enable real-time monitoring and set the address on the software first. Then 

please enter http://[Man Machine IP]/RemoteMon/ on the browser. After success, 

user will see the following login screen. Enter the password of the web application to 

log in. The two words R and M must be capital letters, otherwise it will not be able to 

connect to the HMI through the Webpage. 

 

 
Figure 3 - 277: Delta HMI Remote Monitoring 
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The function setting description of the Real-time monitoring page is as follows: 

Features Description 
Enable real-

time 
monitoring 

 Tick the checkbox to enable Real-time Monitoring feature. 
  

New Monitor 
Address  

• Click  to add a monitoring address. 
• The name can be used to name the entered address. The 

name length can be up to 30 characters. 
 

 
Delete 
Monitor 

Address  

Select the number user want to delete, then click to delete the 
monitoring address. 

Import CSV 
file  

After modifying the content of the exported CSV file, click to 
import the monitoring address parameters. 

Export CSV 
file  

Export the content of the monitoring address to a CSV file. 
 

 

Password 
• The default password is 12345678. 
• After entering the monitoring address in the web page, user 

will be prompted to enter the password. 

Items per 
Page 

• User can set the number of monitoring addresses to be 
displayed on a page. 

• The default setting is 10, the minimum is 1 and maximum 
20. 

Update 
Frequency 
(seconds) 

User can set the screen update frequency. The default is 30 
seconds, the minimum is 1 second, and the maximum is 30 
seconds. 
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SMTP 

 

 
Figure 3 - 278: SMTP 

 
• SMTP stands for Simple Mail Transfer Protocol. This server is used to send 

the mail. SMTP is a set of rules used to send mail from source address to 

destination address, and it controls how the mail is transferred. 

• DIAScreen software provides SMTP service function, which allows users to 

notify users that an alarm has occurred by receiving mail when an alarm 

occurs. 

• After the SMTP parameter setting is completed, the user must also enter 

Options > Alarm Settings, and fill in the recipient’s Mail and related alarm 

information in the [Mail] field. 
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Figure 3 - 279: Mail 

If the user wants to enable SMTP, please check [Enable mail host function] first, and 
then set up the security verification of its host IP address, host port, account and 
password. 

 

The SMTP page function setting description is as follows: 

 

Features Description 

Enable Mail 
Host 

• This IP address is the Mail Server IP created by the user. 
Before using the SMTP function, please set up the Mail 
Server environment first, or user can search for free Mail 
Server on the Internet. 

• In addition to filling in the IP address, user can also check 
[Use domain name] to enter the domain name. 
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Features Description 

 

Server Port The default port of the mail host port is 25, which is the general 
SMTP communication port. 

Sender 
Address Please fill in the sender’s email address. 

SSL Encrypted 
Transmission 

• SSL is the abbreviation of Secure Socket Layer, which 
can provide confidential transmission on the Internet. 
Originally proposed by Netscape, the goal of SSL is to 
ensure the confidentiality and integrity of the 
communication between two applications, and to verify 
the identity of the server. 

• To use SSL encrypted transmission, e-mail must support 
this function. 

• Gmail itself also requires SSL encrypted transmission. If 
user want to use Gmail to send mails, user need to make 
the following settings first. 

1. After logging into Gmail mailbox, select my account. 
 

 
 

2. Choose Sign-in & security. 
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Features Description 

 
 
3. Open the apps that allow less security at the bottom of the 

page. 
 

 
 

• After the above 3 points are set, user can use Gmail to 
receive alert letters. 

Enable Security 
Authentication 

• Before enabling the account security verification function, 
user must check the Enable mail host function before 
setting its account and password. 

• If the SMTP server is created with account and password 
authentication, this option must be checked. 

Account  

• The account and password must be based on the account 
and password required by the SMTP server. When setting 
up SMTP MailServer, if the security verification of account 
and password is checked, a set of account and password 
must be entered first. This account and password are 
used to check whether the recipient is a legitimate user of 
the back-end mail system, so as to prevent un received 
letters from entering the system and occupying resources, 
forming hidden mail security problems. 

• Please note that the format of the account number will be 
different due to the different formats required by each 

Password 
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Features Description 
SMTP Mail Server. Users can first ask MIS for its rules. 

Time zone 

The HMI provides the time zone function, which allows the user 
to select the local time zone, so that the HMI will not have a time 
difference in various places, and the time of sending the alarm 
mail is more accurate. 

 

 

After SMTP settings are loaded into the HMI, user can access the settings from the 
System Directory > System Settings > Network Applications > SMTP tab, as 
shown in the figure below. Users can also change the SMTP settings from the HMI 
and upload to DIAScreen. 

 

. 
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Figure 3 - 280: SMTP HMI Catalog setting page 

 

FTP 

 

 
Figure 3 - 281: FTP 
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• The FTP Server function is mainly to provide users with the ability to download 
alarms, historical data, formulas, and operation records in USB Disk or SD 
storage devices to PC for review via the Internet, and upload files from PC to 
USB Disk or SD storage devices. 

 

FTP rule Description 
Supported HMI Network model 

Network model 
File transfer software 
Windows File manager 
DOS Command Line 

Connection restrictions 
Allow up to 3 FTP Clients to connect at the same time 
Idle for more than 90 seconds will automatically 
disconnect 

Login method 

Support anonymous 

login 

Cannot add directory 
Cannot upload file 
Cannot download file 
Cannot delete file 
Allow file name change 

Support account login 

Allow new directories 
Allow file upload 
Allow downloading of files 
Allow file deletion 
Allow file name change 

File transfer rules 

Unlimited flow 
Support resume 
Unlimited file size 
The maximum file name length is 260 bytes 
Allow file name change 
Supporting document name 
Does not support encryption 
Support active mode / passive mode connection 
When FTP is transferring, access to system directory 

 

FTP supports three connection methods as follows: 

1. File transfer software 
 

Because the HMI provides FTP Server, user need to use FTP Client software to 
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upload and download files or use Windows File Explorer or DOS Command Line to 

connect. This example introduces the use of file transfer software FileZilla, which is 

free software, and the download URL is: 

https://filezilla-project.org/download.php. After installation, please open FileZilla 

software. 

 

 
Figure 3 - 282: Transfer software FileZilla 

 

Name Action Description 

Host Enter the HMI IP address. The IP address in this example is 
192.168.123.114. 

Username Enter the same username as the software setting, which is 
admin. 

Password Enter the same password as the software setting, which is 
1234. 

Port Enter the same port as the software setting, which is 21. 

Quickconnect Before executing this button, please fill in the required 
settings from 1 to 4. 

 

2. Windows File manager  
 

Please open the file explorer, enter ftp://192.168.123.114/, enter the account and 

password, user can log in FTP. 

https://filezilla-project.org/download.php


Chapter 3                                                                                                     DIAScreen 

426 
 

 

 
Figure 3 - 283: File manager 

 

After logging in, user can display all files in the USB storage device. 

 

Figure 3 - 284: Files in USB storage device 

 

3. DOS Command Line 
 

Enter ftp 192.168.123.114 at the command prompt, and enter the user account 

admin and password 1234 to connect to FTP. 

 

Figure 3 - 285: Connect to FTP 

Under the ftp command, user can use help to view the supported related commands. 
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Figure 3 - 286: Supported related commands 

 

Enter the dir command to list all files in the current USB storage device. 
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Figure 3 - 287: All current USB files 

 

If user want to download files from USB Disk or SD Card, please use the get 

command. If user want to upload files from the PC to a USB Disk or SD Card, this is 

the put command. 

 

The FTP File Setting page function description is as follows： 

Features Description 
Enable FTP host 

function The FTP function can be used only after it is checked. 

FTP Host Port The default FTP host port is 21. 
Account  User can enter the name of the account they want to use. 

Password User can enter the password they want to use. 

Root Directory 
The root directory is the storage location of the HMI files, and 
the default is USB Disk. Users can also choose SD Card as 
the storage location. 

Anonymous  • Check this option to log in without entering the account 
and password FTP. 
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Features Description 
Enable FTP host 

function The FTP function can be used only after it is checked. 

FTP Host Port The default FTP host port is 21. 
Account  User can enter the name of the account they want to use. 

Password User can enter the password they want to use. 

Root Directory 
The root directory is the storage location of the HMI files, and 
the default is USB Disk. Users can also choose SD Card as 
the storage location. 

• After logging in to FTP using an anonymous 
connection, uploading, downloading files, deleting files 
or adding directories cannot be performed. 

 

 
After FTP settings are loaded into the HMI, go to System Directory > System 
Settings > Network Application > FTP Server tab to access the settings, as 

shown below. Users can also change the FTP settings from the HMI and upload to 

DIAScreen. 

 

 

Figure 3 - 288: FTP HMI Catalog Setting page 
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3.12.2 Data Exchange Table 
 

Remark: This function is applicable to DOP-100 series and AX-8 series. 

 

The DIAScreen software provides the data exchange table function. The user 

double-clicks the data exchange table from the project tree to open the setting page. 

This function is used to map the remote device address to the HMI internal address. 

The user can use this table tool to set the correspondence between the remote 

address and the local address. For example, write the value of the remote address 

D0 to the local address $100, please refer to the figure below. 

 

 

Figure 3 - 289: Data Exchange Table 

 

The data exchange table provides WORD type data exchange. The maximum length 

of each data can be set to 100, and the entire data exchange table can set up to 200 

data. The local address can only be entered in the internal memory address, and the 

remote address is based on the currently selected communication item to enter the 

corresponding address. 

 

The data exchange table provides WORD type data exchange, and the entire data 

exchange table can set up to 200 data. The field description is as follows: 
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Field Description 

Local address 

• Enter the address of the internal register. 

The internal register provided by the HMI is 16 bits. If the 
remote address data type is set to Double Word, it will be 
read by two internal registers. Enter 2 in the length field. 

Remote address Enter the device address of the currently selected 
communication item. 

Length Data exchange length, the maximum is 100. 
 

The function setting description of the data exchange table page is as follows: 

 

Features Description 

Add  
Click on the connection user want to add in the connection 
tree, and then click  to add it in the last row of the data 
exchange form. 

Copy  

• Select the data row to be copied, click  to pop up 
the data exchange copy window, as shown below. 

 

 
 

• Enter the number to be copied, the local offset 
address, and the remote offset address. After 
confirming, add the setting data in the last column of 
the data exchange table. 

Delete  

• Select the data row to be deleted, click  to pop up 
the delete confirmation window, as shown in the figure 
below, select Yes to delete the selected data row. 
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Features Description 

 
 

• To delete multiple data, long press the  Keypad Ctrl 
key and select the data row to be deleted, and then 
click to delete the selected data row. 

• To delete multiple data in a row, click the  first row to 
be deleted, press and hold the Shift key on the 
Keypad and then click the last row to be deleted, and 
then click  to delete multiple data rows. 

Delete all  

Click  to pop up the clear confirmation window, as shown 
in the figure below, select Yes to clear all the data rows of the 
connection. 
 

 

Minimum update 
cycle 

The shortest update cycle allows users to set the data update 
time. The default is 50ms, which means that data will be 
updated every 50ms. The minimum update cycle is 50ms; the 
maximum update cycle is 6000ms. 
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Chapter 4: Tag Sharing 
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4.1 Tag Sharing with DIAStudio Programming 
 

The DIASreen can inherit the variables or tags declared by DIADesigner and 

DIADesigner-AX in the DIAStudio software package, and can be used directly in the 

components of DIAScreen without the need for repeated declarations. Please refer 

to (1) for operation mode. The following content and (2) AX-8 Series Package 

Installation Manual (Chapter 2). 

Tag means the variable that is inherited between in DIADesigner & DIAScreen. User 

can share the Variables with Address created in DIADesigner with DIAScreen 

application, so that user can directly access those Variables in DIAScreen via DIA 
Tag function. 

 

NOTE: 

Only DOP-100 HMI series supports DIA Tag sharing feature in the current version. 

 

Follow these steps to perform tag sharing to DIAScreen: 

1. Create variables with address in any global variable table of Controller > 

Programming > Global Variable. 

An example for Tag Sharing is shown in the following figure. 

 

 

Figure 4 - 1: Tag Sharing 

 

2. Compile the DIADesigner device or project. 

3. Launch DIAScreen. 
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4. Create a HMI project with DOP-100 HMI series. During Project creation, 

enter a Link Name, select Delta in Manufacturers drop-down list, select 

Delta AS series PLC in the Series drop-down list as shown in the following 

figure. 

 

 

Figure 4 - 2: Project Wizard 

 

Result: The DIAScreen project is created. 

5. Double-click DIA Tag function in the Project tree in DIAScreen. 

Result: DIA Tag window displays as shown in the following figure. 
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Figure 4 - 3: DIA Tag 

 

6. Click  icon in the DIA Tag window. 

Result: The Device Name List window of the device to be imported 

displayed as shown in the following figure. 

 

 

Figure 4 - 4: Select the device to import 

 

7. Check the Device Name of the controller and select Link Name. 
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Figure 4 - 5: Select the device to import window 

 

8. Click on OK. 

Result: The DIADesigner Tags are now shared with DIAScreen so that the 

Variables can be used for different kinds of elements, animations, etc. as 

shown in the following figure.  

 

 

Figure 4 - 6: DIA Tag updated with Tag sharing 
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Example: 

User can select DIA Tag function to select the DIADesigner variables as shown in 

the following figure: 

 

 

Figure 4 - 7: DIA Tag usage 

 

4.1.1 DIA Tag Supports One-to-Many 
 

Remarks: This function is suitable for DOP-100 series. 
 
According to Section 4.1, DIAScreen can inherit the Tag declared by DIADesigner. 
After clicking DIA Tag, the window for selecting the controller will pop up, as shown 
in the figure below. 
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Figure 4 - 8: DIA Tag 

 

Check to select the connection name to import DIA Tag. 
 

 
Figure 4 - 9: Import DIA Tag 
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The DIAScreen communication setting controller must be consistent with 
DIADesigner, as shown in the figure below: 
 

 

Figure 4 - 10: DIADesigner and DIAScreen Controller options 

 
If the DIAScreen communication setting controller is inconsistent with the 

DIADesigner, an error message will appear when user press to confirm the imported 

DIA Tag, as shown in the figure below. 
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Figure 4 - 11: DIADesigner and DIAScreen Controller inconsistent error 
message 

 

The current version of DIAScreen supports opening multiple DIAscreens at once, 
and can import DIA Tags generated by DIADesigner into multiple DIAScreen 
programs, as shown in the figure below: 
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Figure 4 - 12: Import of multiple DIAScreen programs DIA Tag 

 

4.1.2 DIA Tag Automatic Synchronization 
 

Remark: This function is applicable to DOP-100 series. 

Following the introduction of DIA Tag usage in section 4.1, this section introduces 

the automatic synchronization function of DIAScreen DIA Tag. The default value is 

on. Note that users need to perform manual synchronization first. After selecting the 

device to be imported and setting the corresponding connection name, automatic 

synchronization can work. 

• Automatic synchronization function is turned on 

 

After the user adds/adds/changes variables in DIADesigner, click compile, and 

DIAScreen “no need” clicks “Sync” to automatically import the add/add/change DIA 

Tag. The automatic synchronization button is turned on as shown in the figure below. 
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Figure 4 - 13: DIA Tag automatic synchronization button on 

 

• The automatic synchronization function is off: 

 

When the automatic synchronization function is turned off, please refer to Section 

4.1 Sharing with DIAStudio Program Variables, DIAScreen needs to manually click 

the "Sync" button to synchronize DIA Tag each time. Automatic synchronization is 

turned off as shown below. 
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Figure 4 - 14: DIA Tag automatic synchronization button off 

 

4.2 OPC UA Client Communication Function 
 

Remark: This is only applicable to DOP-100 series. 

DIAScreen supports the communication connection between the HMI and the OPC 

UA Client. Please refer to the following steps to establish the OPC UA Client 

connection, and use its tags in each function of DIAScreen: 

 

1. Create a project with DOP-100 series and select a model which supports 

Ethernet connectivity from the HMI List in Project Wizard. 

2. Create a Ethernet link device with OPC UA Client in the Controller field as 

shown in the following figure: 
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Figure 4 - 15: Establish OPC UA Client connection 

 

3. Click Import button to open ‘Tag List’ window as shown in the following figure. 

Click  to import OPC UA xml tag file. 

 

 

Figure 4 - 16: Import OPC UA Tag xml file 

 

4. Set the IP of the OPC UA Client and click Finish button to create an OPC UA 

connection project. 



Chapter 4                                                                                                  DIAScreen 
 

447 
 

 

Figure 4 - 17: IP Address set up 

 

5. Create the Element and set the read/write address to OPC UA Tag. 

 

 

Figure 4 - 18: The Component uses OPC UA Tag 
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6. Use OPC UA Tag in the macro command: Open the macro editing window , 

click the macro wizard , and enter the macro command. If the variable 

selects OPC UA Tag, the OPC UA Tag will automatically add single quotes 

after the macro is updated ; To fill in the OPC UA Tag in the address tool, 

user need to manually add single quotes around the OPC UA Tag, as shown 

in the figure below. 

 
 

 

4.2.1 Support HMI TAG Smart Input Function 
 

NOTE: This function is suitable for AX/IMP series and DOP-100 series, currently 

only supports DIADesigner-AX Tag. 

 

In order for the user to input the DIADesigner-AX Tag prefix, the DIADesigner-AX 

Tag with the prefix user input can be filtered out, the method is as follows. 

 

• Select PAC_AX8_Linux_Series as an example: 

 

1. Open a File > New >HMI series drop-down menu, select AX series > 

PAC_AX8_Linux_Series > Finish 

 

 

Figure 4 - 19: Open new file 

 
2. On the left Screen New HMI Project tree, click Build-In PLC. 
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Figure 4 - 20: New HMI  Project tree click Build-In PLC 

 
Result: Open the Build-In PLC tab. 

 
3. In Build-In PLC tab, Click Import. 

 

 

Figure 4 - 21: Import 

 
Result: The Open window is displayed. 

 
4. Select the xml file to be linked from the open window and click Open. 
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Figure 4 - 22: Open xml file 

 
5. Go back to the Screen tab created at the beginning and add components. 

6. Open the component and click Write Address. 
 

 

Figure 4 - 23: Write Address Location 
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Result: The input window is displayed. 

 
7. Select from the drop-down menu of the connection name in the input 

window Build-In PLC. 

 

 

Figure 4 - 24: Connection name Build-In PLC  

 
Result: The Input window pops up, the xml file just imported is linked to this 

screen. 
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Figure 4 - 25: Input window 

 

8. Click on Smart Input Shortcut  
 
Result: The automatic Input window pops up. 
 

 

 

Figure 4 - 26: Smart input shortcut 
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9. Enter the Application string. 
 

.

 

Figure 4 - 27: CODESYS TAG Smart input 

10. Left-click on the TAG user want to use, then click OK. 
 

 

Figure 4 - 28: Tap the smart input option 
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Remark: If user don’t check the case as a different option, it will filter out the initials 

TAG of the input letters regardless of case. 

 

 

Figure 4 - 29: Uncheck size is considered different option 

 
Conversely, if user check the box as the difference between upper and lower case, 

the first TAG with the same upper and lower case will be filtered and entered. 
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Figure 4 - 30: Check the size as different options 

 

11. User can bring in the selected CODESYS Tag. 
 



Chapter 4                                                                                                  DIAScreen 
 

456 
 

 

Figure 4 - 31: Automatically bring into component memory location 

 

The following is an example of choosing DOP-100 Series: 
 

1. Open a new file > select the desired model > click Next. 
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Figure 4 - 32: Open new file 

 

2. ①Select Ethernet connection> ②  New network link> ③Select 

CODESYS in the controller drop-down menu> ④Import. 
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Figure 4 - 33: Import xml file 

 
Result: The Tag list window pops up 

 
3. In the Tag list window, click Import. 

 
Result: Open window pops up. 
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Figure 4 - 34: Select the xml file to be imported 

 
4. Select the xml file to be imported and click to open. 

 
Result: Link the xml file to the Tag List window. 

 

Figure 4 - 35: Link xml file 

 
5. Go back to the Screen tab created at the beginning and add components. 

6. Open the component and click Write to memory location. 
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7. In the input window, select EtherLink1 in the connection name drop-down 

menu. 

 

Figure 4 - 36: Select EtherLink1 

 
Refer to step 8 in the PAC AX8_Linux_Series example at the beginning of this 

chapter. 

 

4.3 Data Code Table 
 

Remark: Applicable for DOP-100 series and AX-8 series. 

DIAScreen software provides the data code table function. Users can open the 

setting page from Options > Tag table. This function is used to help users to set the 

code of the memory address, including CODESYS Tag and OPC UA Tag, for 

example, set a certain address as $100 = DELTA, then when user want to enter 

$100 in the future, user can use DELTA to replace $100. Please refer to the figure 

below. 
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Figure 4 - 37: Data code number table 

 

 

Figure 4 - 38: Data Code 

 

Tag Table toolbar icons are described in the following table: 

 

Features Description 

New Label  
Click to add a New Label to the Tag Table and enter the name, 
type, address, and description on the form. 
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Features Description 
The label name and description can include uppercase English 
characters, traditional Chinese, simplified Chinese and numbers, 
but the label name should not begin with the number.. 
 

Delete label 
 

Click any column in the Tag table, and then click to delete the 
selected label from the Tag Table. 
 

Insert Label 
 

Inserting a label will insert new data on top of the selected data 
row. 

Import label  
 

Click  icon to import CSV file which contains the variables 
created in DIADesigner. 
To export CSV from DIADesigner to DIAScreen, steps: 

1. Right-click the Global variable > Default_Tag_Table and 
select Export CSV file, as shown in the following figure. 

 

 
 

2. Export the CSV file.CSV file imported. Click Import label 
on the tool bar of Tag table in DIAScreen to open the open 
window. Select CSV file exported from DIADesigner. Click 
OK. The Tag Import Setting window opens as shown in the 
following figure, 
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Features Description 

 
 

3. User can select the COM Port, they want to import and set 
the station number. After setting, click OK. The 
DIADesigner variables is imported into DIAScreen as a 
tag, as shown in the figure below. 

 

 
Export label  

 
Click   to open Save as window to export Labels 

Sort by 
connection 
name  

The data codes of various connections are classified in the form 
of a tree diagram for the convenience of users to read, as shown 
in the figure below. 



Chapter 4                                                                                                  DIAScreen 
 

464 
 

Features Description 

 
 
If user add a tag to the category display page in the above figure, 
the tag Label property window will pop up, as shown in the figure 
below. 
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Appendix 
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Appendix A: Functions Supported by Models 
 

A.1 Elements and Supported Models 
 

The following table shows the elements and the supported models. The V indicates 

that the model supports the element. 

 

Element 
Model 

TP04G TP02G 
TP04G-

AL-C 

TP04G-

AL2 

TP04G-

BL-C 

TP04G-BL-

CU 
TP04P TP05G TP08G 

VFD-C 

Keypad 
TP70P 

Static Text V V V V V V V V V V V 

Numeric/ASCII 
Display V V V V V V V V V V V 

Bit Lamp V V V V V V V V V   

Word Lamp V V V V V V V V V   

Static Bitmap V V V V V V V V V V V 

Dynamic Bitmap  V V V V V V V V  V 

Scale V V V V V V V V V V  

Bar Graph V V V V V V V V V V V 

Circle Meter V  V V V V V V V  V 

Message Display  V V V V V V V V  V 

Button V V V V V V V V V V V 

RTC Display V V V V V V V V V V V 

Multistate Indicator V V V V V V V V V V V 

Measurement V V V V V V V V V V  

Numeric Input V V V V V V V V V V V 

Curve V  V V V V  V V   

X-Y Curve V  V V V V  V V   

Alarm Current 
Setting           V 

Alarm History 
Setting           V 

Alarm Scroll 
Display Setting           V 

Slider           V 

Geometric Graphic V V V V V V V V V V V 
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Delta Products 
Communication 
Device Setting 

V           

Input List           V 

ComboBox           V 
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A.2 Button Types and Supported Models 

 
The following table shows the buttons and the supported models. The V indicates 

that the model supports the button. 

 

 

  

Button 
Type 

Model 
TP04G TP02G TP04G-AL-C TP04G-AL2 TP04G-BL-C TP04G-BL-CU TP04P TP05G TP08G VFD-C Keypad TP70P 

Force ON V V V V V V V V V V V 

Force OFF V V V V V V V V V V V 

Pulse ON V V V V V V V V V  V 

Pulse OFF V V V V V V V V V  V 

Push ON/OFF V V V V V  V V V  V 

Momentary V V V V V V V V V  V 

Multi-State V V V V V V V V V  V 

Input Value V V V V V V V V V  V 

Constant 
Setting V V V V V V V V V V V 

Increase V V V V V V V V V  V 

Decrease V V V V V V V V V  V 

Page Jump V V V V V V V V V V V 

Password and 
Setting V V V V V V V V V  V 

Screen Scroll   V V V V V V V   

Clock Display 
Setting   V V V V V    V 

PLC Link 
Setting       V    V 

Recipe 
Write/Read        V V   
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A.3 Screen Setting Menu Items and Supported Models 

 
The following table shows the Items on the Local Screen Setting menu and the 

supported models. The V indicates that the model supports the item. 

 

 

 

  

Item 
Model 

TP04G TP02G 
TP04G-AL-

C 

TP04G-

AL2 

TP04G-BL-

C 

TP04G-BL-

CU 
TP04P TP05G TP08G 

VFD-C 

Keypad 
TP70P 

Change Screen 
Condition V V V V V V V V V  V 

Function Key 
Setting V V V V V V V V V   

Alarm Buzzer 
Setting V V V V V V V V V   

Alarm LED 
Setting V V V V V V V V V   

Write Screen ID 
Setting V V V V V V V V V  V 

Hide Screen 
Setting V V V V V V V V V   

Screen Macro 
Setting        V V   

Screen Color 
Setting           V 
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A.4 Global Setting Menu Items and Supported Models 

 
The following table shows the Items on the Global Setting menu and the supported 

models. The V indicates that the model supports the item.  

 

 

 

 

Item 
Model 

TP04G TP02G 
TP04G-

AL-C 

TP04G-

AL2 

TP04G-

BL-C 

TP04G-

BL-CU 
TP04P TP05G TP08G 

VFD-C 

Keypad 
TP70P 

System Parameter 
Setting: Page Auto-

Jump/Backlight 
Control 

V  V V V V V V V  V 

System Parameter 
Setting: Read/Write 

Block Setting 
  V V V V V V V  V 

System Change 
Screen Setting V V V V V V V V V  V 

System Function Key 
Setting V V V V V V V V V   

System Alarm Buzzer 
Setting V V V V V V V V V  V 

System Alarm LED 
Setting V V V V V V V V V   

System RTC Setting V  V V V V  V V  V 

System Power ON 
Setting V V V V V V V V V   

Global Macro Setting        V V   

Recipe Setting        V V   

Default Screen Color 
Setting           V 
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Appendix B: USB Driver 
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B.1 Installing USB Driver 

 
This appendix describes how to install a USB driver in Windows 10. If user want to 

install a USB driver in another operating system, refer the instructions for the 

particular operating system for more information about the installation of the new 

hardware. 

 
Follow these steps to install USB driver in the computer: 

1. Make sure that the TP host is normally powered on, and connect the TP host 

to the USB port of the personal computer through the USB cable. At this time, 

the device driver installation wizard will appear on the screen. Click Next. 

 

 

Figure B - 1: Device driver installation wizard 

 

2. The installation is complete. 
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Figure B - 2:The installation is complete 
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